summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2012-02-07 22:09:17 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2012-02-07 22:09:17 +0000
commite83b81e63190fb46624540582e4cea0ad1cec24e (patch)
tree34bcefe314fa08467012da34069edc35ff2c0e66 /media-plugins/vdr-cinebars
parentCleanup (diff)
downloadgentoo-2-e83b81e63190fb46624540582e4cea0ad1cec24e.tar.gz
gentoo-2-e83b81e63190fb46624540582e4cea0ad1cec24e.tar.bz2
gentoo-2-e83b81e63190fb46624540582e4cea0ad1cec24e.zip
eapi=4, stable amd64 x86, compile fix for multicore CPU
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'media-plugins/vdr-cinebars')
-rw-r--r--media-plugins/vdr-cinebars/ChangeLog8
-rw-r--r--media-plugins/vdr-cinebars/files/vdr-cinebars-0.0.5_makefile.diff25
-rw-r--r--media-plugins/vdr-cinebars/vdr-cinebars-0.0.5.ebuild12
3 files changed, 38 insertions, 7 deletions
diff --git a/media-plugins/vdr-cinebars/ChangeLog b/media-plugins/vdr-cinebars/ChangeLog
index 276444755d5a..40591b06deee 100644
--- a/media-plugins/vdr-cinebars/ChangeLog
+++ b/media-plugins/vdr-cinebars/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/vdr-cinebars
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-cinebars/ChangeLog,v 1.5 2011/01/28 18:08:52 hd_brummy Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-cinebars/ChangeLog,v 1.6 2012/02/07 22:09:17 hd_brummy Exp $
+
+ 07 Feb 2012; Joerg Bornkessel <hd_brummy@gentoo.org>
+ vdr-cinebars-0.0.5.ebuild, +files/vdr-cinebars-0.0.5_makefile.diff:
+ eapi=4, stable amd64 x86, compile fix for multicore CPU
28 Jan 2011; Joerg Bornkessel <hd_brummy@gentoo.org>
vdr-cinebars-0.0.3a.ebuild, vdr-cinebars-0.0.5.ebuild:
diff --git a/media-plugins/vdr-cinebars/files/vdr-cinebars-0.0.5_makefile.diff b/media-plugins/vdr-cinebars/files/vdr-cinebars-0.0.5_makefile.diff
new file mode 100644
index 000000000000..d01c2fe85eab
--- /dev/null
+++ b/media-plugins/vdr-cinebars/files/vdr-cinebars-0.0.5_makefile.diff
@@ -0,0 +1,25 @@
+Joerg Bornkessel <hd_brummy@gentoo.org> 2012.01.07
+Fix Makefile for compile on multicore CPU
+
+diff -Naur cinebars-0.0.5.orig/Makefile cinebars-0.0.5/Makefile
+--- cinebars-0.0.5.orig/Makefile 2012-02-07 23:19:00.000000000 +0100
++++ cinebars-0.0.5/Makefile 2012-02-07 23:19:31.000000000 +0100
+@@ -49,13 +49,13 @@
+
+ ### The object files (add further files here):
+ OBJS = $(PLUGIN).o
+-ifneq ($(VERS157),1)
++#ifneq ($(VERS157),1)
+ OBJS += i18n.o
+-endif
++#endif
+
+ ### The main target:
+-all: libvdr-$(PLUGIN).so
+- if [ $(VERS157) = 1 ]; then make i18n; fi
++all: libvdr-$(PLUGIN).so i18n
++# if [ $(VERS157) = 1 ]; then make i18n; fi
+
+ ### Implicit rules:
+ %.o: %.c
+
diff --git a/media-plugins/vdr-cinebars/vdr-cinebars-0.0.5.ebuild b/media-plugins/vdr-cinebars/vdr-cinebars-0.0.5.ebuild
index a3ccfce32ba5..401e8727bb61 100644
--- a/media-plugins/vdr-cinebars/vdr-cinebars-0.0.5.ebuild
+++ b/media-plugins/vdr-cinebars/vdr-cinebars-0.0.5.ebuild
@@ -1,19 +1,21 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-cinebars/vdr-cinebars-0.0.5.ebuild,v 1.3 2011/01/28 21:21:24 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-cinebars/vdr-cinebars-0.0.5.ebuild,v 1.4 2012/02/07 22:09:17 hd_brummy Exp $
-EAPI="3"
+EAPI="4"
inherit vdr-plugin
-DESCRIPTION="vdr Plugin: Show black bars to hide station logo"
+DESCRIPTION="VDR Plugin: Show black bars to hide station logo"
HOMEPAGE="http://www.egal-vdr.de/plugins/"
SRC_URI="http://www.egal-vdr.de/plugins/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="amd64 x86"
IUSE=""
DEPEND=">=media-video/vdr-1.3.32"
RDEPEND="${DEPEND}"
+
+PATCHES=("${FILESDIR}/${P}_makefile.diff")