summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-08-16 04:47:51 +0000
committerJon Hood <squinky86@gentoo.org>2004-08-16 04:47:51 +0000
commitad9292889ebc2d002059a6fd902acba914ca6eb9 (patch)
tree853ecce8aea1574f43dbf7c2d425991c98d5e244 /media-plugins/streamtuner-python
parentwww-proxy/tinyproxy moved (diff)
downloadgentoo-2-ad9292889ebc2d002059a6fd902acba914ca6eb9.tar.gz
gentoo-2-ad9292889ebc2d002059a6fd902acba914ca6eb9.tar.bz2
gentoo-2-ad9292889ebc2d002059a6fd902acba914ca6eb9.zip
apply fix for #51832
Diffstat (limited to 'media-plugins/streamtuner-python')
-rw-r--r--media-plugins/streamtuner-python/ChangeLog7
-rw-r--r--media-plugins/streamtuner-python/files/0.1.2-configure.patch20
-rw-r--r--media-plugins/streamtuner-python/streamtuner-python-0.1.2.ebuild14
3 files changed, 37 insertions, 4 deletions
diff --git a/media-plugins/streamtuner-python/ChangeLog b/media-plugins/streamtuner-python/ChangeLog
index 21815f693cb2..47a8d5ac4ea8 100644
--- a/media-plugins/streamtuner-python/ChangeLog
+++ b/media-plugins/streamtuner-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/streamtuner-python
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/streamtuner-python/ChangeLog,v 1.7 2004/07/13 08:42:14 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/streamtuner-python/ChangeLog,v 1.8 2004/08/16 04:47:51 squinky86 Exp $
+
+ 15 Aug 2004; Jon Hood <squinky86@gentoo.org> +files/0.1.2-configure.patch,
+ streamtuner-python-0.1.2.ebuild:
+ Add configure patch from Alexandro Colorado and apply some editing to the
+ ebuild to fix #51832.
13 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
streamtuner-python-0.1.2.ebuild:
diff --git a/media-plugins/streamtuner-python/files/0.1.2-configure.patch b/media-plugins/streamtuner-python/files/0.1.2-configure.patch
new file mode 100644
index 000000000000..f4ec7b2121a4
--- /dev/null
+++ b/media-plugins/streamtuner-python/files/0.1.2-configure.patch
@@ -0,0 +1,20 @@
+diff -Naur streamtuner-python-0.1.2/configure streamtuner-python-0.1.2.new/configure
+--- streamtuner-python-0.1.2/configure 2004-05-24 05:29:15.000000000 -0500
++++ streamtuner-python-0.1.2.new/configure 2004-08-15 23:38:59.615829560 -0500
+@@ -21312,11 +21312,11 @@
+
+
+
+-found=no
+-PYTHON_VERSION=""
+-PYTHON_PREFIX=""
+-EMBEDDED_PYTHON_CFLAGS=""
+-EMBEDDED_PYTHON_LIBS=""
++found=yes
++PYTHON_VERSION="Python 2.3+"
++PYTHON_PREFIX="/usr/bin/python"
++EMBEDDED_PYTHON_CFLAGS="/usr/include/python2.3"
++EMBEDDED_PYTHON_LIBS="/usr/lib/python2.3"
+
+ for ac_prog in python python2.3 python2.2 python2.1 python2.0 python1.6 python1.5
+ do
diff --git a/media-plugins/streamtuner-python/streamtuner-python-0.1.2.ebuild b/media-plugins/streamtuner-python/streamtuner-python-0.1.2.ebuild
index a9057d1ebafb..9f2ca8bcb1d2 100644
--- a/media-plugins/streamtuner-python/streamtuner-python-0.1.2.ebuild
+++ b/media-plugins/streamtuner-python/streamtuner-python-0.1.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/streamtuner-python/streamtuner-python-0.1.2.ebuild,v 1.3 2004/07/13 08:42:14 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/streamtuner-python/streamtuner-python-0.1.2.ebuild,v 1.4 2004/08/16 04:47:51 squinky86 Exp $
+
+inherit eutils
DESCRIPTION="A plugin for Streamtuner that provides an embedded Python interpreter."
SRC_URI="http://savannah.nongnu.org/download/streamtuner/${P}.tar.gz"
@@ -12,9 +14,15 @@ KEYWORDS="x86 ~ppc ~amd64 ~sparc"
LICENSE="BSD"
DEPEND=">=net-misc/streamtuner-0.12.0
- >=dev-lang/python-2.0"
+ >=dev-lang/python-2.3"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-configure.patch
+}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS COPYING ChangeLog NEWS README INSTALL
}