summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2009-11-22 05:57:25 +0000
committerDoug Goldstein <cardoe@gentoo.org>2009-11-22 05:57:25 +0000
commit9a6fafb953397a5f4d0c402b47719f70a522906b (patch)
treed5ea578608a20e0c35b64c2518e58e7768fdd50e /media-plugins/mythvideo/mythvideo-0.22_p22864-r1.ebuild
parentBlock <kdevelop-3.9.96:4 due to file collision. (diff)
downloadgentoo-2-9a6fafb953397a5f4d0c402b47719f70a522906b.tar.gz
gentoo-2-9a6fafb953397a5f4d0c402b47719f70a522906b.tar.bz2
gentoo-2-9a6fafb953397a5f4d0c402b47719f70a522906b.zip
fix JAMU epends. Install default JAMU configuration scripts
(Portage version: 2.1.7.5/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins/mythvideo/mythvideo-0.22_p22864-r1.ebuild')
-rw-r--r--media-plugins/mythvideo/mythvideo-0.22_p22864-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-plugins/mythvideo/mythvideo-0.22_p22864-r1.ebuild b/media-plugins/mythvideo/mythvideo-0.22_p22864-r1.ebuild
new file mode 100644
index 000000000000..4efbad6d1d96
--- /dev/null
+++ b/media-plugins/mythvideo/mythvideo-0.22_p22864-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/mythvideo-0.22_p22864-r1.ebuild,v 1.1 2009/11/22 05:57:25 cardoe Exp $
+
+EAPI=2
+
+inherit qt4 mythtv-plugins
+
+DESCRIPTION="Video player module for MythTV."
+IUSE="+jamu"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="dev-perl/libwww-perl
+ dev-perl/HTML-Parser
+ dev-perl/URI
+ dev-perl/XML-Simple
+ sys-apps/eject
+ jamu? ( >=dev-python/imdbpy-3.8
+ >=dev-python/mysql-python-1.2.2
+ media-tv/mythtv[python] )"
+DEPEND=""
+
+src_install() {
+ mythtv-plugins_src_install
+
+ newinitd "${FILESDIR}"/mtd.init.d mtd
+
+ # correct permissions so MythVideo is actually usable
+ fperms 755 /usr/share/mythtv/mythvideo/scripts/*.pl
+ fperms 755 /usr/share/mythtv/mythvideo/scripts/*.py
+
+ # setup JAMU cron jobs
+ if use jamu; then
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/mythvideo.daily" mythvideo || die
+ exeinto /etc/cron.hourly
+ newexe "${FILESDIR}/mythvideo.hourly" mythvideo || die
+ exeinto /etc/cron.weekly
+ newexe "${FILESDIR}/mythvideo.weekly" mythvideo || die
+ insinto /home/mythtv/.mythtv/
+ newins mythvideo/scripts/jamu-example.conf jamu.conf || die
+ fi
+}
+
+pkg_postinst() {
+ elog "MythVideo can use any media player to playback files if you"
+ elog "are *NOT* using Storage Groups. If you are using Storage"
+ elog "Groups, you *MUST* use the Internal player."
+ elog
+ elog "Otherwise, you can install mplayer, xine or any other video"
+ elog "player and use that instead by configuring the player to use."
+ elog "The default is 'Internal'."
+}