summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2003-04-11 03:46:16 +0000
committerHannes Mehnert <hannes@gentoo.org>2003-04-11 03:46:16 +0000
commitd6f9b0d47c59d543593c9d9032bacfa67681740a (patch)
treefaee450df4a34825b36c514e10d4f79f3df1e51a /media-plugins/live
parentdigest fix (diff)
downloadgentoo-2-d6f9b0d47c59d543593c9d9032bacfa67681740a.tar.gz
gentoo-2-d6f9b0d47c59d543593c9d9032bacfa67681740a.tar.bz2
gentoo-2-d6f9b0d47c59d543593c9d9032bacfa67681740a.zip
version bump
Diffstat (limited to 'media-plugins/live')
-rw-r--r--media-plugins/live/ChangeLog7
-rw-r--r--media-plugins/live/files/digest-live-2003.04.091
-rw-r--r--media-plugins/live/live-2003.04.09.ebuild54
3 files changed, 61 insertions, 1 deletions
diff --git a/media-plugins/live/ChangeLog b/media-plugins/live/ChangeLog
index 46a2533b14dd..eefc1c3e50d7 100644
--- a/media-plugins/live/ChangeLog
+++ b/media-plugins/live/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/live
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/ChangeLog,v 1.2 2003/02/12 07:19:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/ChangeLog,v 1.3 2003/04/11 03:46:16 hannes Exp $
+
+*live-2003.04.09 (11 Apr 2003)
+
+ 11 Apr 2003; Hannes Mehnert <hannes@gentoo.org> live-2003.04.09.ebuild:
+ version bump
*live-2003.01.28 (29 Jan 2003)
diff --git a/media-plugins/live/files/digest-live-2003.04.09 b/media-plugins/live/files/digest-live-2003.04.09
new file mode 100644
index 000000000000..5d6379285dd7
--- /dev/null
+++ b/media-plugins/live/files/digest-live-2003.04.09
@@ -0,0 +1 @@
+MD5 857aa6579c8b853dc2c0004f4e19c83e live.2003.04.09.tar.gz 271599
diff --git a/media-plugins/live/live-2003.04.09.ebuild b/media-plugins/live/live-2003.04.09.ebuild
new file mode 100644
index 000000000000..a6ca799fce63
--- /dev/null
+++ b/media-plugins/live/live-2003.04.09.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/live-2003.04.09.ebuild,v 1.1 2003/04/11 03:46:16 hannes Exp $
+
+DESCRIPTION="Source-code libraries for standards-based RTP/RTCP/RTSP multimedia streaming, suitable for embedded and/or low-cost streaming applications"
+
+HOMEPAGE="http://www.live.com/"
+MY_P=${P/-/.}
+SRC_URI="http://www.live.com/liveMedia/public/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i.orig -e "s:-O:${CFLAGS} -Wno-deprecated:" config.linux
+}
+
+src_compile() {
+ ./genMakefiles linux
+ # emake doesn't work
+ make || die
+}
+
+src_install() {
+ # no installer, go manual ...
+
+ # find and install libraries, mplayer needs to find
+ # each library in a subdirectory with same name as
+ # the lib
+
+ local lib
+ for lib in $(find ${S} -type f -name \*.a)
+ do
+ local dir
+ dir=$(basename $(dirname ${lib}))
+
+ insinto "/usr/lib/live/${dir}"
+ doins "${lib}"
+
+ insinto "/usr/lib/live/${dir}/include"
+ doins ${S}/${dir}/include/*h
+ done
+
+ # find and install test programs
+ exeinto /usr/bin
+ find ${S}/testProgs -type f -perm +111 -exec doexe {} \;
+
+ dodoc ${S}/README
+}