summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2008-02-25 10:08:46 +0000
committerDenis Dupeyron <calchan@gentoo.org>2008-02-25 10:08:46 +0000
commit7ef2242ec1f4123e649b5ce91bbd45a26e11085c (patch)
tree0e5c8225bef2deb3514dbc23482e49d6a927a442 /media-plugins/gimp-greycstoration
parentAdded a patch to fix compilation with USE=kdeenablefinal, fixes bug 211027. (diff)
downloadgentoo-2-7ef2242ec1f4123e649b5ce91bbd45a26e11085c.tar.gz
gentoo-2-7ef2242ec1f4123e649b5ce91bbd45a26e11085c.tar.bz2
gentoo-2-7ef2242ec1f4123e649b5ce91bbd45a26e11085c.zip
Initial commit, see bug #114577.
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-plugins/gimp-greycstoration')
-rw-r--r--media-plugins/gimp-greycstoration/ChangeLog10
-rw-r--r--media-plugins/gimp-greycstoration/Manifest4
-rw-r--r--media-plugins/gimp-greycstoration/gimp-greycstoration-1.2.7.ebuild37
-rw-r--r--media-plugins/gimp-greycstoration/metadata.xml8
4 files changed, 59 insertions, 0 deletions
diff --git a/media-plugins/gimp-greycstoration/ChangeLog b/media-plugins/gimp-greycstoration/ChangeLog
new file mode 100644
index 000000000000..a85696611d1a
--- /dev/null
+++ b/media-plugins/gimp-greycstoration/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-plugins/gimp-greycstoration
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-greycstoration/ChangeLog,v 1.1 2008/02/25 10:08:46 calchan Exp $
+
+*gimp-greycstoration-1.2.7 (25 Feb 2008)
+
+ 25 Feb 2008; Denis Dupeyron <calchan@gentoo.org> +metadata.xml,
+ +gimp-greycstoration-1.2.7.ebuild:
+ Initial commit, see bug #114577.
+
diff --git a/media-plugins/gimp-greycstoration/Manifest b/media-plugins/gimp-greycstoration/Manifest
new file mode 100644
index 000000000000..3534ea9b66d2
--- /dev/null
+++ b/media-plugins/gimp-greycstoration/Manifest
@@ -0,0 +1,4 @@
+DIST CImg-1.2.7.tar.gz 5945505 RMD160 6f6cb6c05d126c5408807c8eac5b620dea010cee SHA1 40efd983a7d95cc5dc9b08a04620211f08f29a28 SHA256 ae562feae3b6d900cc959c3bc6742485828ca6f55321e8e94a8df7be041b18f3
+EBUILD gimp-greycstoration-1.2.7.ebuild 978 RMD160 0c8d993519220e8efcd8192b2721186a8084806e SHA1 99a1959744f498cc6b6a377e739d07142f964483 SHA256 51eddb31cc5244232314a111c10995703e282db3777a6e5d4095b20360679c60
+MISC ChangeLog 315 RMD160 48ea3042b5bd6fe05d0fb1f2f2bb6aecc82f7849 SHA1 140b8669f335a1a75aaee919692e98adccce428e SHA256 b5a5aedaafdbac876ced38a07773dbbc6164a8c27519d3392bbc3f3843ff215a
+MISC metadata.xml 232 RMD160 4c7ab29da7172e74adfd87ebb5eb6fb5475a82be SHA1 7b98547e067cdaccb43f37be116d5b15befef8e9 SHA256 18d82999ae63f6a95f78867cc239598fd2eb8011c837dcbe85830d022e7e6aea
diff --git a/media-plugins/gimp-greycstoration/gimp-greycstoration-1.2.7.ebuild b/media-plugins/gimp-greycstoration/gimp-greycstoration-1.2.7.ebuild
new file mode 100644
index 000000000000..9e598432f3bf
--- /dev/null
+++ b/media-plugins/gimp-greycstoration/gimp-greycstoration-1.2.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-greycstoration/gimp-greycstoration-1.2.7.ebuild,v 1.1 2008/02/25 10:08:46 calchan Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="GIMP plug-in for denoising through image regularization"
+HOMEPAGE="http://www.greyc.ensicaen.fr/~dtschump/greycstoration/"
+SRC_URI="mirror://sourceforge/cimg/CImg-${PV}.tar.gz"
+LICENSE="CeCILL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND=">=media-gfx/gimp-2.2"
+S="${WORKDIR}/CImg-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ mv "${S}"/examples/greycstoration4gimp.cpp "${S}"
+}
+
+src_compile() {
+ $(tc-getCXX) -o greycstoration greycstoration4gimp.cpp \
+ $(gimptool-2.0 --cflags) $(gimptool-2.0 --libs) \
+ -lpthread ${CXXFLAGS} ${LDFLAGS} \
+ || die "Compilation failed"
+}
+
+src_install() {
+ exeinto $(gimptool-2.0 --gimpplugindir)/plug-ins
+ doexe greycstoration || die "Installation failed"
+}
+
+pkg_postinst() {
+ elog "The GREYCstoration plugin is accessible from the menu :"
+ elog "Filters -> Enhance -> GREYCstoration"
+}
diff --git a/media-plugins/gimp-greycstoration/metadata.xml b/media-plugins/gimp-greycstoration/metadata.xml
new file mode 100644
index 000000000000..5b12ed78d92e
--- /dev/null
+++ b/media-plugins/gimp-greycstoration/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>calchan@gentoo.org</email>
+ <name>Denis Dupeyron</name>
+</maintainer>
+</pkgmetadata>