summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-08 22:16:42 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-08 22:16:42 +0000
commitfa26552b92091fb91702401b6088f1eb25266eaa (patch)
tree41424c95805c4c2026f43c32b063ab33fb062567 /media-libs
parentRemoving 2.0.0 version and updating 2.0.0a to fix broken mirrors. Closing bu... (diff)
downloadgentoo-2-fa26552b92091fb91702401b6088f1eb25266eaa.tar.gz
gentoo-2-fa26552b92091fb91702401b6088f1eb25266eaa.tar.bz2
gentoo-2-fa26552b92091fb91702401b6088f1eb25266eaa.zip
filter fPIC
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/xine-lib/xine-lib-1_rc2.ebuild3
-rw-r--r--media-libs/xine-lib/xine-lib-1_rc3-r1.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/media-libs/xine-lib/xine-lib-1_rc2.ebuild b/media-libs/xine-lib/xine-lib-1_rc2.ebuild
index 109fab711224..889c700ce2b9 100644
--- a/media-libs/xine-lib/xine-lib-1_rc2.ebuild
+++ b/media-libs/xine-lib/xine-lib-1_rc2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc2.ebuild,v 1.10 2004/02/02 00:22:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc2.ebuild,v 1.11 2004/02/08 22:16:42 vapier Exp $
inherit eutils flag-o-matic gcc
@@ -51,6 +51,7 @@ src_unpack() {
src_compile() {
filter-flags -maltivec -mabi=altivec -fstack-protector
+ filter-flags -fPIC
# fix build errors with sse2
if [ "`gcc-version`" == "3.2" ]; then
diff --git a/media-libs/xine-lib/xine-lib-1_rc3-r1.ebuild b/media-libs/xine-lib/xine-lib-1_rc3-r1.ebuild
index baa1e920f546..d578406e0e4e 100644
--- a/media-libs/xine-lib/xine-lib-1_rc3-r1.ebuild
+++ b/media-libs/xine-lib/xine-lib-1_rc3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc3-r1.ebuild,v 1.10 2004/02/08 20:29:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc3-r1.ebuild,v 1.11 2004/02/08 22:16:42 vapier Exp $
inherit eutils flag-o-matic gcc libtool
@@ -65,6 +65,7 @@ src_unpack() {
}
src_compile() {
+ filter-flags -fPIC
filter-flags -maltivec -mabi=altivec -fstack-protector
# fix build errors with sse2