summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-04-20 21:16:29 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-04-20 21:16:29 +0000
commitc63956ed199d5c4da846819d25127d5c74d25ea9 (patch)
treee5a8b426143b697fface3274bfd5849a535af993 /media-libs
parentRevert last commit. (diff)
downloadgentoo-2-c63956ed199d5c4da846819d25127d5c74d25ea9.tar.gz
gentoo-2-c63956ed199d5c4da846819d25127d5c74d25ea9.tar.bz2
gentoo-2-c63956ed199d5c4da846819d25127d5c74d25ea9.zip
Version bump.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/taglib/ChangeLog7
-rw-r--r--media-libs/taglib/taglib-1.7.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/media-libs/taglib/ChangeLog b/media-libs/taglib/ChangeLog
index 802e393817bc..8f5ad197fdb4 100644
--- a/media-libs/taglib/ChangeLog
+++ b/media-libs/taglib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/taglib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/taglib/ChangeLog,v 1.97 2011/02/13 20:10:13 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/taglib/ChangeLog,v 1.98 2011/04/20 21:16:29 scarabeus Exp $
+
+*taglib-1.7 (20 Apr 2011)
+
+ 20 Apr 2011; Tomáš Chvátal <scarabeus@gentoo.org> +taglib-1.7.ebuild:
+ Version bump.
13 Feb 2011; Tomáš Chvátal <scarabeus@gentoo.org> -taglib-1.6.1-r1.ebuild,
-taglib-1.6.2.ebuild:
diff --git a/media-libs/taglib/taglib-1.7.ebuild b/media-libs/taglib/taglib-1.7.ebuild
new file mode 100644
index 000000000000..6fdf955a8a85
--- /dev/null
+++ b/media-libs/taglib/taglib-1.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/taglib/taglib-1.7.ebuild,v 1.1 2011/04/20 21:16:29 scarabeus Exp $
+
+EAPI=4
+inherit cmake-utils
+
+DESCRIPTION="A library for reading and editing audio meta data"
+HOMEPAGE="http://developer.kde.org/~wheeler/taglib.html"
+SRC_URI="http://developer.kde.org/~wheeler/files/src/${P}.tar.gz"
+
+LICENSE="LGPL-2 MPL-1.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+SLOT="0"
+IUSE="+asf debug examples +mp4 test"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ test? ( dev-util/cppunit )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.6.1-install-examples.patch )
+
+DOCS="AUTHORS NEWS"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build examples)
+ $(cmake-utils_use_with asf)
+ $(cmake-utils_use_with mp4)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if ! use asf; then
+ elog "You've chosen to disable the asf use flag, thus taglib won't include"
+ elog "support for Microsoft's 'advanced systems format' media container"
+ fi
+ if ! use mp4; then
+ elog "You've chosen to disable the mp4 use flag, thus taglib won't include"
+ elog "support for the MPEG-4 part 14 / MP4 media container"
+ fi
+}