summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-02-15 22:58:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-02-15 22:58:03 +0000
commitabfdfda7b4eab75d710fa33ea1c7c394d45ba131 (patch)
treee4dcf6e02902c4dd99b02a04e37dcb5c097ee1a3 /media-libs
parentadd slot dep for libpng (diff)
downloadgentoo-2-abfdfda7b4eab75d710fa33ea1c7c394d45ba131.tar.gz
gentoo-2-abfdfda7b4eab75d710fa33ea1c7c394d45ba131.tar.bz2
gentoo-2-abfdfda7b4eab75d710fa33ea1c7c394d45ba131.zip
add upstream BSD joystick patch for bug #477730
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsdl/ChangeLog8
-rw-r--r--media-libs/libsdl/files/libsdl-1.2.15-bsd-joystick.patch28
-rw-r--r--media-libs/libsdl/libsdl-1.2.15-r8.ebuild5
3 files changed, 37 insertions, 4 deletions
diff --git a/media-libs/libsdl/ChangeLog b/media-libs/libsdl/ChangeLog
index bbc4a108fc75..7a3b76a1437d 100644
--- a/media-libs/libsdl/ChangeLog
+++ b/media-libs/libsdl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libsdl
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.227 2014/10/15 09:05:24 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.228 2015/02/15 22:58:03 mr_bones_ Exp $
+
+ 15 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/libsdl-1.2.15-bsd-joystick.patch, libsdl-1.2.15-r8.ebuild:
+ add upstream BSD joystick patch for bug #477730
15 Oct 2014; Pacho Ramos <pacho@gentoo.org> libsdl-1.2.15-r8.ebuild:
amd64 stable, bug #522270
diff --git a/media-libs/libsdl/files/libsdl-1.2.15-bsd-joystick.patch b/media-libs/libsdl/files/libsdl-1.2.15-bsd-joystick.patch
new file mode 100644
index 000000000000..0f3542529ba6
--- /dev/null
+++ b/media-libs/libsdl/files/libsdl-1.2.15-bsd-joystick.patch
@@ -0,0 +1,28 @@
+
+# HG changeset patch
+# User Sam Lantinga <slouken@libsdl.org>
+# Date 1329357968 18000
+# Node ID 62ff1c0a103f685774450be2e5338824a22078bd
+# Parent 8e98c714bb2ab96de4100a335dacf042963d5068
+FreeBSD compile fix
+
+Robert Millan
+
+src/joystick/bsd/SDL_sysjoystick.c makes the invalid assumption that
+__FreeBSD_kernel__ implies presence of "ucr_data" struct member. This
+breaks recent versions of FreeBSD 10-CURRENT, FreeBSD 9-STABLE and
+Debian GNU/kFreeBSD "wheezy/sid".
+
+diff -r 8e98c714bb2a -r 62ff1c0a103f src/joystick/bsd/SDL_sysjoystick.c
+--- a/src/joystick/bsd/SDL_sysjoystick.c Sat Feb 04 18:12:20 2012 -0500
++++ b/src/joystick/bsd/SDL_sysjoystick.c Wed Feb 15 21:06:08 2012 -0500
+@@ -148,7 +148,7 @@
+ static int report_alloc(struct report *, struct report_desc *, int);
+ static void report_free(struct report *);
+
+-#if defined(USBHID_UCR_DATA) || defined(__FreeBSD_kernel__)
++#if defined(USBHID_UCR_DATA)
+ #define REP_BUF_DATA(rep) ((rep)->buf->ucr_data)
+ #elif (defined(__FREEBSD__) && (__FreeBSD_kernel_version > 800063))
+ #define REP_BUF_DATA(rep) ((rep)->buf->ugd_data)
+
diff --git a/media-libs/libsdl/libsdl-1.2.15-r8.ebuild b/media-libs/libsdl/libsdl-1.2.15-r8.ebuild
index 26d9cb361c5f..02f5c9c8cbc7 100644
--- a/media-libs/libsdl/libsdl-1.2.15-r8.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.15-r8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.15-r8.ebuild,v 1.5 2014/10/15 09:05:24 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.15-r8.ebuild,v 1.6 2015/02/15 22:58:03 mr_bones_ Exp $
EAPI=5
inherit autotools flag-o-matic multilib toolchain-funcs eutils multilib-minimal
@@ -69,6 +69,7 @@ src_prepare() {
"${FILESDIR}"/${P}-sdl-config.patch \
"${FILESDIR}"/${P}-resizing.patch \
"${FILESDIR}"/${P}-joystick.patch \
+ "${FILESDIR}"/${P}-bsd-joystick.patch \
"${FILESDIR}"/${P}-gamma.patch \
"${FILESDIR}"/${P}-const-xdata32.patch \
"${FILESDIR}"/${P}-caca.patch