summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-10-12 02:16:07 +0000
committerTim Harder <radhermit@gentoo.org>2011-10-12 02:16:07 +0000
commit9ee673c9abdbe675624621f8d197a33cf1434af3 (patch)
treeb4af03671254f6cb21d3893c4bb0cace0bb6a937 /media-libs
parentVersion bump. (diff)
downloadgentoo-2-9ee673c9abdbe675624621f8d197a33cf1434af3.tar.gz
gentoo-2-9ee673c9abdbe675624621f8d197a33cf1434af3.tar.bz2
gentoo-2-9ee673c9abdbe675624621f8d197a33cf1434af3.zip
Version bump.
(Portage version: 2.2.0_alpha66/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libraw/ChangeLog7
-rw-r--r--media-libs/libraw/libraw-0.14.1.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/media-libs/libraw/ChangeLog b/media-libs/libraw/ChangeLog
index a640c3b31e65..ac65fd34cf1e 100644
--- a/media-libs/libraw/ChangeLog
+++ b/media-libs/libraw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libraw
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libraw/ChangeLog,v 1.9 2011/09/22 19:10:54 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libraw/ChangeLog,v 1.10 2011/10/12 02:16:07 radhermit Exp $
+
+*libraw-0.14.1 (12 Oct 2011)
+
+ 12 Oct 2011; Tim Harder <radhermit@gentoo.org> +libraw-0.14.1.ebuild:
+ Version bump.
*libraw-0.14.0 (22 Sep 2011)
diff --git a/media-libs/libraw/libraw-0.14.1.ebuild b/media-libs/libraw/libraw-0.14.1.ebuild
new file mode 100644
index 000000000000..9d8818d9457a
--- /dev/null
+++ b/media-libs/libraw/libraw-0.14.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libraw/libraw-0.14.1.ebuild,v 1.1 2011/10/12 02:16:07 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils autotools
+
+MY_P="LibRaw-${PV}"
+DESCRIPTION="LibRaw is a library for reading RAW files obtained from digital photo cameras"
+HOMEPAGE="http://www.libraw.org/"
+SRC_URI="http://www.libraw.org/data/${MY_P}.tar.gz
+ demosaic? ( http://www.libraw.org/data/LibRaw-demosaic-pack-GPL2-${PV}.tar.gz
+ http://www.libraw.org/data/LibRaw-demosaic-pack-GPL3-${PV}.tar.gz )"
+
+# Libraw also has it's own license, which is a pdf file and
+# can be obtained from here:
+# http://www.libraw.org/data/LICENSE.LibRaw.pdf
+LICENSE="LGPL-2.1 CDDL GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="demosaic examples +lcms +openmp static-libs"
+
+RDEPEND="lcms? ( media-libs/lcms:2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( Changelog.txt README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.13.4-docs.patch
+ eautomake
+}
+
+src_configure() {
+ econf \
+ $(use_enable demosaic demosaic-pack-gpl2) \
+ $(use_enable demosaic demosaic-pack-gpl3) \
+ $(use_enable examples) \
+ $(use_enable lcms) \
+ $(use_enable openmp) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # Remove useless .la files
+ find "${D}" -name '*.la' -exec rm -f {} +
+}