summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-11-25 10:19:46 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-11-25 10:19:46 +0000
commit7a5e1409cfc4186ea8e73a940c210c34d3428289 (patch)
treebc4b9e5f6080bfda2f0a1e59e597ffd2ce8011d9 /media-libs
parentStable on ppc, bug #199231. (diff)
downloadgentoo-2-7a5e1409cfc4186ea8e73a940c210c34d3428289.tar.gz
gentoo-2-7a5e1409cfc4186ea8e73a940c210c34d3428289.tar.bz2
gentoo-2-7a5e1409cfc4186ea8e73a940c210c34d3428289.zip
Version bump to 0.6.1 and some QA
(Portage version: 2.1.3.19)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/atlas-c++/ChangeLog7
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.4.5.ebuild6
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.5.92.ebuild8
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.6.1.ebuild40
-rw-r--r--media-libs/atlas-c++/files/digest-atlas-c++-0.6.13
5 files changed, 56 insertions, 8 deletions
diff --git a/media-libs/atlas-c++/ChangeLog b/media-libs/atlas-c++/ChangeLog
index 7438b8cb7628..b940da228faa 100644
--- a/media-libs/atlas-c++/ChangeLog
+++ b/media-libs/atlas-c++/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/atlas-c++
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/ChangeLog,v 1.20 2007/05/15 10:25:37 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/ChangeLog,v 1.21 2007/11/25 10:19:45 tupone Exp $
+
+*atlas-c++-0.6.1 (25 Nov 2007)
+
+ 25 Nov 2007; Tupone Alfredo <tupone@gentoo.org> +atlas-c++-0.6.1.ebuild:
+ Version bump and some QA
15 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add <herd>no-herd</herd>
diff --git a/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild b/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild
index 140bd8bb17e1..656ebbdd9fe9 100644
--- a/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild
+++ b/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild,v 1.11 2007/05/06 00:28:03 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild,v 1.12 2007/11/25 10:19:45 tupone Exp $
MY_PN="Atlas-C++"
MY_P=${MY_PN}-${PV}
@@ -26,7 +26,7 @@ src_compile() {
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
- dodoc AUTHORS COPYING ChangeLog NEWS README ROADMAP THANKS TODO
+ dodoc AUTHORS ChangeLog NEWS README ROADMAP THANKS TODO
}
diff --git a/media-libs/atlas-c++/atlas-c++-0.5.92.ebuild b/media-libs/atlas-c++/atlas-c++-0.5.92.ebuild
index dae9cecdac63..43b4e4327592 100644
--- a/media-libs/atlas-c++/atlas-c++-0.5.92.ebuild
+++ b/media-libs/atlas-c++/atlas-c++-0.5.92.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.5.92.ebuild,v 1.3 2007/05/06 00:28:03 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.5.92.ebuild,v 1.4 2007/11/25 10:19:45 tupone Exp $
inherit eutils
@@ -20,10 +20,10 @@ DEPEND="virtual/libc
>=dev-libs/libsigc++-1.2"
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
#dodoc will install all these docs and a few more
- rm -rf ${D}/usr/share/doc/${My_P}
+ rm -rf "${D}"/usr/share/doc/${My_P}
#PR=r0 in this case, but don't fprget to add ${PR} here for non-zero revisions!
- dodoc AUTHORS COPYING ChangeLog NEWS README ROADMAP THANKS TODO
+ dodoc AUTHORS ChangeLog NEWS README ROADMAP THANKS TODO
}
diff --git a/media-libs/atlas-c++/atlas-c++-0.6.1.ebuild b/media-libs/atlas-c++/atlas-c++-0.6.1.ebuild
new file mode 100644
index 000000000000..6cc7bb7c7cbf
--- /dev/null
+++ b/media-libs/atlas-c++/atlas-c++-0.6.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.6.1.ebuild,v 1.1 2007/11/25 10:19:45 tupone Exp $
+
+inherit eutils
+
+MY_PN="Atlas-C++"
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Atlas protocol, used in role playing games at worldforge."
+HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/atlas_cpp"
+SRC_URI="mirror://sourceforge/worldforge/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="bzip2 doc zlib"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf \
+ $(use_enable zlib) \
+ $(use_enable bzip2 bzlib) \
+ || die "Error: econf failed!"
+ emake || die "Error: emake failed!"
+ if use doc; then
+ emake docs || die "Error: emake failed!"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ use doc && dohtml -r doc/html/*
+ use doc && doman doc/man/*
+ dodoc AUTHORS ChangeLog HACKING NEWS README ROADMAP THANKS TODO
+}
diff --git a/media-libs/atlas-c++/files/digest-atlas-c++-0.6.1 b/media-libs/atlas-c++/files/digest-atlas-c++-0.6.1
new file mode 100644
index 000000000000..187ef7aac2be
--- /dev/null
+++ b/media-libs/atlas-c++/files/digest-atlas-c++-0.6.1
@@ -0,0 +1,3 @@
+MD5 19fdcf04db01d50d57681ac3bafef7d0 Atlas-C++-0.6.1.tar.bz2 352247
+RMD160 e9a1c8c314dd7a7239a11f630d8e710f7d238c0a Atlas-C++-0.6.1.tar.bz2 352247
+SHA256 a9c4de5de6559c69bdcad21751cad15e304025037f612150a08648a88d29844e Atlas-C++-0.6.1.tar.bz2 352247