summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-02-02 05:41:50 +0000
committerTim Harder <radhermit@gentoo.org>2011-02-02 05:41:50 +0000
commit7036fd495c6424be966adc93766c2d94e16ee077 (patch)
tree3f5299600d68d55479731bffc8bfdc72ce47947c /media-libs
parentEAPI3, use array for DOCS (diff)
downloadgentoo-2-7036fd495c6424be966adc93766c2d94e16ee077.tar.gz
gentoo-2-7036fd495c6424be966adc93766c2d94e16ee077.tar.bz2
gentoo-2-7036fd495c6424be966adc93766c2d94e16ee077.zip
Version bump. Explicitly define RDEPEND, set RESTRICT="test" until more tests are fixed, and set the build directory to be where the makefile is located.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libmatroska/ChangeLog10
-rw-r--r--media-libs/libmatroska/libmatroska-1.1.0.ebuild41
2 files changed, 49 insertions, 2 deletions
diff --git a/media-libs/libmatroska/ChangeLog b/media-libs/libmatroska/ChangeLog
index c9be11db5d08..e18b8c6a276f 100644
--- a/media-libs/libmatroska/ChangeLog
+++ b/media-libs/libmatroska/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libmatroska
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmatroska/ChangeLog,v 1.87 2010/10/15 21:41:12 ranger Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmatroska/ChangeLog,v 1.88 2011/02/02 05:41:50 radhermit Exp $
+
+*libmatroska-1.1.0 (02 Feb 2011)
+
+ 02 Feb 2011; Tim Harder <radhermit@gentoo.org> +libmatroska-1.1.0.ebuild:
+ Version bump. Explicitly define RDEPEND, set RESTRICT="test" until more tests
+ are fixed, and set the build directory to be where the makefile is located.
15 Oct 2010; Brent Baude <ranger@gentoo.org> libmatroska-0.9.0.ebuild:
stable ppc, bug 329631
diff --git a/media-libs/libmatroska/libmatroska-1.1.0.ebuild b/media-libs/libmatroska/libmatroska-1.1.0.ebuild
new file mode 100644
index 000000000000..fd1628147ee0
--- /dev/null
+++ b/media-libs/libmatroska/libmatroska-1.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmatroska/libmatroska-1.1.0.ebuild,v 1.1 2011/02/02 05:41:50 radhermit Exp $
+
+EAPI="2"
+
+inherit flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="Extensible multimedia container format based on EBML"
+HOMEPAGE="http://www.matroska.org/"
+SRC_URI="http://www.bunkus.org/videotools/mkvtoolnix/sources/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+RESTRICT="test"
+
+DEPEND=">=dev-libs/libebml-1.2.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}/make/linux"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.0.0-respectflags.patch"
+}
+
+src_compile() {
+ #fixes locale for gcc3.4.0 to close bug 52385
+ append-flags $(test-flags -finput-charset=ISO8859-15)
+
+ emake PREFIX=/usr \
+ LIBEBML_INCLUDE_DIR=/usr/include/ebml \
+ LIBEBML_LIB_DIR=/usr/$(get_libdir) \
+ CXX="$(tc-getCXX)" || die "make failed"
+}
+
+src_install() {
+ emake prefix="${D}/usr" libdir="${D}/usr/$(get_libdir)" install || die "make install failed"
+ dodoc "${WORKDIR}/${P}/ChangeLog"
+}