summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-04-29 08:34:25 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-04-29 08:34:25 +0000
commit6683613059b5f1fd2a11a5df6f6a5e3b97fd60de (patch)
tree0198ea07533db8b5b733fcae833b91f585d1ad11 /media-libs
parentVersion bump closes bug #48089. (Manifest recommit) (diff)
downloadgentoo-2-6683613059b5f1fd2a11a5df6f6a5e3b97fd60de.tar.gz
gentoo-2-6683613059b5f1fd2a11a5df6f6a5e3b97fd60de.tar.bz2
gentoo-2-6683613059b5f1fd2a11a5df6f6a5e3b97fd60de.zip
USE=static now installs both static and shared libs.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/alsa-lib/ChangeLog6
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.4.ebuild25
2 files changed, 25 insertions, 6 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index 0ac46a6ac009..506385dee1a1 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/alsa-lib
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.64 2004/04/20 08:12:01 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.65 2004/04/29 08:34:25 eradicator Exp $
+
+ 29 Apr 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ alsa-lib-1.0.4.ebuild:
+ USE=static now installs both static and shared libs.
20 Apr 2004; Jeremy Huddleston <eradicator@gentoo.org>
alsa-lib-1.0.4.ebuild:
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.4.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.4.ebuild
index 2d9262ad9703..94d9b3845556 100644
--- a/media-libs/alsa-lib/alsa-lib-1.0.4.ebuild
+++ b/media-libs/alsa-lib/alsa-lib-1.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.4.ebuild,v 1.2 2004/04/20 08:12:01 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.4.ebuild,v 1.3 2004/04/29 08:34:25 eradicator Exp $
inherit libtool
@@ -27,6 +27,14 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
+ if use static; then
+ mv ${S} ${S}.static
+ unpack ${A}
+
+ cd ${S}.static
+ elibtoolize
+ fi
+
cd ${S}
elibtoolize
}
@@ -34,13 +42,15 @@ src_unpack() {
src_compile() {
local myconf=""
+ econf --enable-static=no --enable-shared=yes || die
+ emake || die
+
# Can't do both according to alsa docs and bug #48233
if use static; then
- myconf="--enable-static=yes --enable-shared=no"
+ cd ${S}.static
+ econf --enable-static=yes --enable-shared=no || die
+ emake || die
fi
-
- econf ${myconf} || die
- emake || die
}
src_install() {
@@ -54,4 +64,9 @@ src_install() {
#fixes the problem (fingers crossed)
dosym /usr/lib/libasound.so.2 /usr/lib/libasound.so.1
dodoc ChangeLog COPYING TODO
+
+ if use static; then
+ cd ${S}.static
+ make DESTDIR="${D}" install || die "make install failed"
+ fi
}