summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-28 22:21:03 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-28 22:21:03 +0000
commit54d102858510ed81bb3200454673c0c407952d03 (patch)
tree9b246c1ea540a800c8a7d0300f26a2df3c92f174 /media-libs
parentFix is_2_6_kernel. Close Bug 48060 (Manifest recommit) (diff)
downloadgentoo-2-54d102858510ed81bb3200454673c0c407952d03.tar.gz
gentoo-2-54d102858510ed81bb3200454673c0c407952d03.tar.bz2
gentoo-2-54d102858510ed81bb3200454673c0c407952d03.zip
arm KEYWORD
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/freetype/freetype-2.1.5-r1.ebuild25
1 files changed, 7 insertions, 18 deletions
diff --git a/media-libs/freetype/freetype-2.1.5-r1.ebuild b/media-libs/freetype/freetype-2.1.5-r1.ebuild
index fcc8817c4a35..ac83a65ea091 100644
--- a/media-libs/freetype/freetype-2.1.5-r1.ebuild
+++ b/media-libs/freetype/freetype-2.1.5-r1.ebuild
@@ -1,44 +1,35 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/freetype/freetype-2.1.5-r1.ebuild,v 1.8 2004/04/07 23:05:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/freetype/freetype-2.1.5-r1.ebuild,v 1.9 2004/04/28 22:16:39 vapier Exp $
inherit eutils flag-o-matic
-SPV="`echo ${PV} | cut -d. -f1,2`"
-
DESCRIPTION="A high-quality and portable font engine"
HOMEPAGE="http://www.freetype.org/"
SRC_URI="mirror://sourceforge/freetype/${P/_/}.tar.bz2"
-SLOT="2"
LICENSE="FTL | GPL-2"
-KEYWORDS="x86 ppc sparc mips alpha hppa ia64 amd64 ppc64"
-IUSE="zlib bindist cjk"
+SLOT="2"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64"
+IUSE="zlib bindist cjk doc"
DEPEND="virtual/glibc
zlib? ( sys-libs/zlib )"
src_unpack() {
+ local SPV="`echo ${PV} | cut -d. -f1,2`"
unpack ${A}
cd ${S}
# add autohint patch from http://www.kde.gr.jp/~akito/patch/freetype2/2.1.5/
use cjk && epatch ${FILESDIR}/${SPV}/${P}-autohint-cjkfonts-20031105.patch
-
}
src_compile() {
+ use bindist || append-flags -DTT_CONFIG_OPTION_BYTECODE_INTERPRETER
- local myconf
-
- use zlib \
- && myconf="${myconf} --with-zlib" \
- || myconf="${myconf} --without-zlib"
-
- use bindist || append-flags "${CFLAGS} -DTT_CONFIG_OPTION_BYTECODE_INTERPRETER"
-
- make setup CFG="--host=${CHOST} --prefix=/usr ${myconf}" unix || die
+ make setup CFG="--host=${CHOST} --prefix=/usr `use_with zlib`" unix || die
emake || die
@@ -51,12 +42,10 @@ src_compile() {
}
src_install() {
-
make prefix=${D}/usr install || die
dodoc ChangeLog README
dodoc docs/{CHANGES,CUSTOMIZE,DEBUG,*.txt,PATENTS,TODO}
use doc && dohtml -r docs/*
-
}