summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-08 17:54:48 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-08 17:54:48 +0000
commit4b59c7d84128efb2bfabfb634efe29420802a88c (patch)
tree6a69b11a746f29832440973f9d0f072cf91543f9 /media-libs
parentFix typo in ChangeLog (diff)
downloadgentoo-2-4b59c7d84128efb2bfabfb634efe29420802a88c.tar.gz
gentoo-2-4b59c7d84128efb2bfabfb634efe29420802a88c.tar.bz2
gentoo-2-4b59c7d84128efb2bfabfb634efe29420802a88c.zip
version bump
(Portage version: 2.2.0_alpha195/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/zvbi/ChangeLog10
-rw-r--r--media-libs/zvbi/files/zvbi-0.2.34-settime.patch13
-rw-r--r--media-libs/zvbi/zvbi-0.2.34.ebuild49
3 files changed, 70 insertions, 2 deletions
diff --git a/media-libs/zvbi/ChangeLog b/media-libs/zvbi/ChangeLog
index 4ce15d98134a..db36942a5072 100644
--- a/media-libs/zvbi/ChangeLog
+++ b/media-libs/zvbi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/zvbi
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/zvbi/ChangeLog,v 1.49 2012/05/29 13:44:22 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/zvbi/ChangeLog,v 1.50 2013/08/08 17:54:48 aballier Exp $
+
+*zvbi-0.2.34 (08 Aug 2013)
+
+ 08 Aug 2013; Alexis Ballier <aballier@gentoo.org> +zvbi-0.2.34.ebuild,
+ +files/zvbi-0.2.34-settime.patch:
+ version bump
29 May 2012; Alexis Ballier <aballier@gentoo.org> zvbi-0.2.33.ebuild:
keyword ~amd64-fbsd
diff --git a/media-libs/zvbi/files/zvbi-0.2.34-settime.patch b/media-libs/zvbi/files/zvbi-0.2.34-settime.patch
new file mode 100644
index 000000000000..db92fb310cb7
--- /dev/null
+++ b/media-libs/zvbi/files/zvbi-0.2.34-settime.patch
@@ -0,0 +1,13 @@
+Index: zvbi-0.2.34/test/date.c
+===================================================================
+--- zvbi-0.2.34.orig/test/date.c
++++ zvbi-0.2.34/test/date.c
+@@ -93,7 +93,7 @@ set_time (const vbi_local_time * lt)
+ ts.tv_sec = lt->time; /* UTC */
+ ts.tv_nsec = 0;
+
+- if (0 == clock_settime (CLOCK_REALTIME, ts))
++ if (0 == clock_settime (CLOCK_REALTIME, &ts))
+ return;
+ }
+ #endif
diff --git a/media-libs/zvbi/zvbi-0.2.34.ebuild b/media-libs/zvbi/zvbi-0.2.34.ebuild
new file mode 100644
index 000000000000..a3ff92281c94
--- /dev/null
+++ b/media-libs/zvbi/zvbi-0.2.34.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/zvbi/zvbi-0.2.34.ebuild,v 1.1 2013/08/08 17:54:48 aballier Exp $
+
+EAPI=5
+inherit eutils libtool
+
+DESCRIPTION="VBI Decoding Library for Zapping"
+SRC_URI="mirror://sourceforge/zapping/${P}.tar.bz2"
+HOMEPAGE="http://zapping.sourceforge.net"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc dvb nls static-libs v4l X"
+
+RDEPEND=">=media-libs/libpng-1.4
+ sys-libs/zlib
+ nls? ( virtual/libintl )
+ X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )
+ X? ( x11-libs/libXt )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-settime.patch"
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable v4l) \
+ $(use_enable dvb) \
+ $(use_enable nls) \
+ $(use_with X x) \
+ $(use_with doc doxygen)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+ use doc && dohtml -a png,gif,html,css doc/html/*
+
+ find "${D}" -name '*.la' -delete
+}