summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-03-08 16:02:34 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-03-08 16:02:34 +0000
commit0c52602302f2eb93a78642ff32dc8d9ca1657e9b (patch)
tree21c57e1889c474e59011353443e4e7ac71b62c74 /media-libs
parentamd64/x86 stable, bug #258040 (diff)
downloadgentoo-2-0c52602302f2eb93a78642ff32dc8d9ca1657e9b.tar.gz
gentoo-2-0c52602302f2eb93a78642ff32dc8d9ca1657e9b.tar.bz2
gentoo-2-0c52602302f2eb93a78642ff32dc8d9ca1657e9b.zip
version bump by Richard Ash, bug #261173
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsndfile/ChangeLog8
-rw-r--r--media-libs/libsndfile/libsndfile-1.0.19.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/media-libs/libsndfile/ChangeLog b/media-libs/libsndfile/ChangeLog
index e9dcc63992cd..bb1440e18916 100644
--- a/media-libs/libsndfile/ChangeLog
+++ b/media-libs/libsndfile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libsndfile
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsndfile/ChangeLog,v 1.88 2009/03/04 13:59:42 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsndfile/ChangeLog,v 1.89 2009/03/08 16:02:34 aballier Exp $
+
+*libsndfile-1.0.19 (08 Mar 2009)
+
+ 08 Mar 2009; Alexis Ballier <aballier@gentoo.org>
+ +libsndfile-1.0.19.ebuild:
+ version bump by Richard Ash, bug #261173
04 Mar 2009; Peter Alfredsen <loki_val@gentoo.org>
libsndfile-1.0.18-r1.ebuild:
diff --git a/media-libs/libsndfile/libsndfile-1.0.19.ebuild b/media-libs/libsndfile/libsndfile-1.0.19.ebuild
new file mode 100644
index 000000000000..a465a7cd3696
--- /dev/null
+++ b/media-libs/libsndfile/libsndfile-1.0.19.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsndfile/libsndfile-1.0.19.ebuild,v 1.1 2009/03/08 16:02:34 aballier Exp $
+
+inherit eutils libtool autotools
+
+MY_P=${P/_pre/pre}
+
+DESCRIPTION="A C library for reading and writing files containing sampled sound"
+HOMEPAGE="http://www.mega-nerd.com/libsndfile"
+if [[ "${MY_P}" == "${P}" ]]; then
+ SRC_URI="http://www.mega-nerd.com/libsndfile/${P}.tar.gz"
+else
+ SRC_URI="http://www.mega-nerd.com/tmp/${MY_P}b.tar.gz"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="sqlite alsa minimal"
+
+RDEPEND="!minimal? ( >=media-libs/flac-1.2.1
+ >=media-libs/libogg-1.1.3
+ >=media-libs/libvorbis-1.2.1_rc1 )
+ alsa? ( media-libs/alsa-lib )
+ sqlite? ( >=dev-db/sqlite-3.2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s/noinst_PROGRAMS/check_PROGRAMS/" "${S}/tests/Makefile.am" \
+ "${S}/examples/Makefile.am" || die "failed to remove forced build of test and example programs"
+ epatch "${FILESDIR}/${PN}-1.0.17-regtests-need-sqlite.patch"
+ epatch "${FILESDIR}/${PN}-1.0.18-less_strict_tests.patch"
+ rm M4/libtool.m4 M4/lt*.m4 || die "rm failed"
+
+ AT_M4DIR=M4 eautoreconf
+ epunt_cxx
+}
+
+src_compile() {
+ econf $(use_enable sqlite) \
+ $(use_enable alsa) \
+ $(use_enable !minimal external-libs) \
+ --disable-octave \
+ --disable-gcc-werror \
+ --disable-gcc-pipe \
+ --disable-dependency-tracking
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" htmldocdir="/usr/share/doc/${PF}/html" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}