summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-01-04 17:41:02 +0000
committerChris White <chriswhite@gentoo.org>2005-01-04 17:41:02 +0000
commit02380c7f963f6e223135710f2708b72c7871802e (patch)
tree219fc0439df1b0114db926bbbc244ac47743f215 /media-libs
parentStable on hppa. (Manifest recommit) (diff)
downloadgentoo-2-02380c7f963f6e223135710f2708b72c7871802e.tar.gz
gentoo-2-02380c7f963f6e223135710f2708b72c7871802e.tar.bz2
gentoo-2-02380c7f963f6e223135710f2708b72c7871802e.zip
Re-fix bug #706220 with a correct patch for xine-lib_rc8-r1. Thanks to James Stockton for the patch.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/xine-lib/ChangeLog7
-rw-r--r--media-libs/xine-lib/files/xine-lib-1_rc8-configure.ac.patch92
-rw-r--r--media-libs/xine-lib/xine-lib-1_rc8-r1.ebuild4
3 files changed, 100 insertions, 3 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index 9d4baf411cc0..c06502f35dca 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/xine-lib
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.185 2005/01/04 10:32:02 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.186 2005/01/04 17:41:02 chriswhite Exp $
+
+ 05 Jan 2005; Chris White <chriswhite@gentoo.org>
+ +files/xine-lib-1_rc8-configure.ac.patch, xine-lib-1_rc8-r1.ebuild:
+ Re-fix bug #706220 with a correct patch for xine-lib_rc8-r1. Thanks to James
+ Stockton for the patch.
04 Jan 2005; Hardave Riar <hardave@gentoo.org> xine-lib-1_rc8-r1.ebuild:
Stable on mips, bug #74475.
diff --git a/media-libs/xine-lib/files/xine-lib-1_rc8-configure.ac.patch b/media-libs/xine-lib/files/xine-lib-1_rc8-configure.ac.patch
new file mode 100644
index 000000000000..5dc2a3316ef4
--- /dev/null
+++ b/media-libs/xine-lib/files/xine-lib-1_rc8-configure.ac.patch
@@ -0,0 +1,92 @@
+--- xine-lib-1-rc8/configure.ac 2004-12-14 22:06:47.000000000 +0000
++++ xine-lib/configure.ac 2004-12-30 09:55:16.000000000 +0000
+@@ -18,6 +18,11 @@
+ XINE_MINOR=0
+ XINE_SUB=0
+
++if test $XINE_SUB -eq 0 ; then
++ XINE_SUBPART="";
++else
++ XINE_SUBPART=".$XINE_SUB"
++fi
+
+ dnl The libtool version numbers (LT_*); Don't even think about faking this!
+ dnl
+@@ -45,14 +50,14 @@
+ dnl libname.so.(LT_CURRENT - LT_AGE).LT_AGE.LT_REVISION
+
+ LT_CURRENT=12
+-LT_REVISION=0
++LT_REVISION=1
+ LT_AGE=11
+
+ dnl for a release tarball do "rm .cvsversion" before "make dist"
+ if test -f .cvsversion; then
+ XINE_PRE="cvs"
+ else
+- XINE_PRE="rc8"
++ XINE_PRE=""
+ fi
+
+ AC_SUBST(XINE_MAJOR)
+@@ -69,10 +74,10 @@
+ AC_SUBST(LT_REVISION)
+ AC_SUBST(LT_AGE)
+
+-dnl TAR_NAME="xine-lib-"$XINE_MAJOR.$XINE_MINOR.$XINE_SUB$XINE_PRE
+-dnl SPEC_VERSION=$XINE_MAJOR.$XINE_MINOR.$XINE_SUB$XINE_PRE
+-TAR_NAME="xine-lib-"$XINE_MAJOR-$XINE_PRE
+-SPEC_VERSION=${XINE_MAJOR}_$XINE_PRE
++SPEC_VERSION=$XINE_MAJOR.$XINE_MINOR${XINE_SUBPART}$XINE_PRE
++TAR_NAME="xine-lib-"$SPEC_VERSION
++dnl TAR_NAME="xine-lib-"$XINE_MAJOR-$XINE_PRE
++dnl SPEC_VERSION=${XINE_MAJOR}_$XINE_PRE
+
+ AC_SUBST(TAR_NAME)
+ AC_SUBST(SPEC_VERSION)
+@@ -84,8 +89,8 @@
+ AC_CANONICAL_TARGET
+
+ dnl
+-dnl AM_INIT_AUTOMAKE("xine-lib", $XINE_MAJOR.$XINE_MINOR.$XINE_SUB$XINE_PRE)
+-AM_INIT_AUTOMAKE("xine-lib", $XINE_MAJOR-$XINE_PRE)
++AM_INIT_AUTOMAKE("xine-lib", $SPEC_VERSION)
++dnl AM_INIT_AUTOMAKE("xine-lib", $XINE_MAJOR-$XINE_PRE)
+
+
+ dnl ---------------------------------------------
+@@ -487,28 +492,21 @@
+ dnl Check for Xv and XvMC support (iconv is also tested here?)
+ dnl ----------------------------------------------
+
+-dnl static linking is preferred!
+-dnl but only dynamic linking is possible when using libtool < 1.4.0
++dnl With recent XFree86 or Xorg, dynamic linking is preferred!
++dnl Only dynamic linking is possible when using libtool < 1.4.0
+
+-dnl ----------------------------------------------
+-dnl SECTION: Check for Xv and XvMC support (iconv is also tested here?)
+-dnl ----------------------------------------------
+ AC_ARG_WITH(xv-path, AC_HELP_STRING([--with-xv-path=path], [where libXv is installed]),
+ xv_path="$withval",)
+
+ AC_ARG_ENABLE(shared-xv,
+- AC_HELP_STRING([--enable-shared-xv],[Enable this to force linking against libXv.so]),
+- xv_prefer_shared="yes",
+- xv_prefer_shared="no")
++ AC_HELP_STRING([--enable-static-xv],[Enable this to force linking against libXv.a]),
++ xv_prefer_shared="no",
++ xv_prefer_shared="yes")
+
+ if test x"$no_x" != "xyes"; then
+-
+- dnl -----------------------------------------------
+- dnl Finding install Xv library
+- dnl -----------------------------------------------
+ AC_FIND_LIBXV
+-
+ fi
++AM_CONDITIONAL(HAVE_XV, test x$ac_have_xv = "xyes")
+
+
+ host_or_hostalias="$host"
diff --git a/media-libs/xine-lib/xine-lib-1_rc8-r1.ebuild b/media-libs/xine-lib/xine-lib-1_rc8-r1.ebuild
index 3a8e92331cd7..7b2da6eae899 100644
--- a/media-libs/xine-lib/xine-lib-1_rc8-r1.ebuild
+++ b/media-libs/xine-lib/xine-lib-1_rc8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc8-r1.ebuild,v 1.15 2005/01/04 10:32:02 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc8-r1.ebuild,v 1.16 2005/01/04 17:41:02 chriswhite Exp $
inherit eutils flag-o-matic gcc libtool
@@ -64,7 +64,7 @@ src_unpack() {
epatch ${FILESDIR}/${PN}-x11.patch
# fixes bad xv checking
- epatch ${FILESDIR}/${PN}-configure.ac.patch
+ epatch ${FILESDIR}/${P}-configure.ac.patch
# Fix building on amd64, #49569
#use amd64 && epatch ${FILESDIR}/configure-64bit-define.patch