summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-05-30 12:19:10 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-05-30 12:19:10 +0000
commit6760f9df97745ac8dbce03722f42ee5c5aa0d39e (patch)
tree352b1ebfc68d7a5bdbe888011362e7dc90234c4c /media-libs/xvid
parentDrop old ebuild (src not available anymore upstream) and fails building again... (diff)
downloadgentoo-2-6760f9df97745ac8dbce03722f42ee5c5aa0d39e.tar.gz
gentoo-2-6760f9df97745ac8dbce03722f42ee5c5aa0d39e.tar.bz2
gentoo-2-6760f9df97745ac8dbce03722f42ee5c5aa0d39e.zip
Version bump wrt #511780 by "Nikoli"
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-libs/xvid')
-rw-r--r--media-libs/xvid/ChangeLog9
-rw-r--r--media-libs/xvid/xvid-1.3.3.ebuild70
2 files changed, 77 insertions, 2 deletions
diff --git a/media-libs/xvid/ChangeLog b/media-libs/xvid/ChangeLog
index 0f81051dbb39..3da0df5547d6 100644
--- a/media-libs/xvid/ChangeLog
+++ b/media-libs/xvid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/xvid
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xvid/ChangeLog,v 1.138 2013/07/28 19:07:38 aballier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xvid/ChangeLog,v 1.139 2014/05/30 12:19:10 ssuominen Exp $
+
+*xvid-1.3.3 (30 May 2014)
+
+ 30 May 2014; Samuli Suominen <ssuominen@gentoo.org> +xvid-1.3.3.ebuild:
+ Version bump wrt #511780 by "Nikoli"
28 Jul 2013; Alexis Ballier <aballier@gentoo.org> xvid-1.3.2-r1.ebuild:
Force using nasm on FreeBSD as it doesnt build with yasm, bug
diff --git a/media-libs/xvid/xvid-1.3.3.ebuild b/media-libs/xvid/xvid-1.3.3.ebuild
new file mode 100644
index 000000000000..eef8ebbf7126
--- /dev/null
+++ b/media-libs/xvid/xvid-1.3.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xvid/xvid-1.3.3.ebuild,v 1.1 2014/05/30 12:19:10 ssuominen Exp $
+
+EAPI=5
+inherit flag-o-matic multilib multilib-minimal
+
+MY_PN=${PN}core
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="XviD, a high performance/quality MPEG-4 video de-/encoding solution"
+HOMEPAGE="http://www.xvid.org/"
+SRC_URI="http://downloads.xvid.org/downloads/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="examples elibc_FreeBSD +threads pic"
+
+NASM=">=dev-lang/nasm-2"
+YASM=">=dev-lang/yasm-1"
+
+DEPEND="amd64? ( || ( ${YASM} ${NASM} ) )
+ amd64-fbsd? ( ${NASM} )
+ x86? ( || ( ${YASM} ${NASM} ) )
+ x86-fbsd? ( ${NASM} )"
+RDEPEND="abi_x86_32? ( !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+
+S=${WORKDIR}/${MY_PN}/build/generic
+
+src_prepare() {
+ # make build verbose
+ sed \
+ -e 's/@$(CC)/$(CC)/' \
+ -e 's/@$(AS)/$(AS)/' \
+ -e 's/@$(RM)/$(RM)/' \
+ -e 's/@$(INSTALL)/$(INSTALL)/' \
+ -e 's/@cd/cd/' \
+ -i Makefile || die
+ # Since only the build system is in $S, this will only copy it but not the
+ # entire sources.
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ use sparc && append-cflags -mno-vis #357149
+ use elibc_FreeBSD && export ac_cv_prog_ac_yasm=no #477736
+
+ local myconf
+ if use pic || [[ ${ABI} == "x32" ]] ; then #421841
+ myconf="--disable-assembly"
+ fi
+
+ econf \
+ $(use_enable threads pthread) \
+ ${myconf}
+}
+
+#multilib_src_install() {
+# emake DESTDIR="${D}" install
+#}
+
+multilib_src_install_all() {
+ dodoc "${S}"/../../{AUTHORS,ChangeLog*,CodingStyle,README,TODO}
+
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r "${S}"/../../examples
+ fi
+}