summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-03-08 00:00:43 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-03-08 00:00:43 +0000
commitefebcbbbdb4599dbc249290082a2115a403d2371 (patch)
treeb99273be2cc6acf66ce613c597eecb8bd34e4849 /media-libs/xine-lib
parentRemoved the HTTP mirror of ftp.tu-clausthal.de as it is becoming annoying. (diff)
downloadgentoo-2-efebcbbbdb4599dbc249290082a2115a403d2371.tar.gz
gentoo-2-efebcbbbdb4599dbc249290082a2115a403d2371.tar.bz2
gentoo-2-efebcbbbdb4599dbc249290082a2115a403d2371.zip
Refuse to compile if libxine.so.0 is present.
Closes #15081.
Diffstat (limited to 'media-libs/xine-lib')
-rw-r--r--media-libs/xine-lib/ChangeLog5
-rw-r--r--media-libs/xine-lib/xine-lib-1_beta2.ebuild10
-rw-r--r--media-libs/xine-lib/xine-lib-1_beta4.ebuild10
-rw-r--r--media-libs/xine-lib/xine-lib-1_beta6.ebuild11
4 files changed, 32 insertions, 4 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index e52d9b4df485..2d7aa2c5f2cc 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,12 +1,13 @@
# ChangeLog for media-libs/xine-lib
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.43 2003/03/07 23:25:49 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.44 2003/03/08 00:00:43 agenkin Exp $
*xine-lib-1_beta6 (25 Feb 2003)
07 Mar 2003; Arcady Genkin <agenkin@gentoo.org> :
Fixed installation problem for portage >=2.0.47 (bug #16841).
Filter out k6 optimization flags (bug #16085).
+ Refuse to compile if libxine.so.0 is present (bug #15081).
27 Feb 2003; Mark Guertin <gerk@gentoo.org> xine-lib-1_beta6.ebuild :
set ~ppc in keywords
@@ -34,6 +35,7 @@
07 Mar 2003; Arcady Genkin <agenkin@gentoo.org> :
Fixed installation problem for portage >=2.0.47 (bug #16841).
Filter out k6 optimization flags (bug #16085).
+ Refuse to compile if libxine.so.0 is present (bug #15081).
13 Feb 2003; Arcady Genkin <agenkin@gentoo.org> :
Removed dependency on kdelibs (bug 15595).
@@ -54,6 +56,7 @@
07 Mar 2003; Arcady Genkin <agenkin@gentoo.org> :
Fixed installation problem for portage >=2.0.47 (bug #16841).
Filter out k6 optimization flags (bug #16085).
+ Refuse to compile if libxine.so.0 is present (bug #15081).
08 Jan 2003; Nick Hadaway <raker@gentoo.org> xine-lib-1_beta2.ebuild :
Marked stable.
diff --git a/media-libs/xine-lib/xine-lib-1_beta2.ebuild b/media-libs/xine-lib/xine-lib-1_beta2.ebuild
index 511340aacaa2..f611e4d1c810 100644
--- a/media-libs/xine-lib/xine-lib-1_beta2.ebuild
+++ b/media-libs/xine-lib/xine-lib-1_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_beta2.ebuild,v 1.6 2003/03/07 23:25:49 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_beta2.ebuild,v 1.7 2003/03/08 00:00:43 agenkin Exp $
DESCRIPTION="Core libraries for Xine movie player."
HOMEPAGE="http://xine.sourceforge.net/"
@@ -39,6 +39,14 @@ replace-flags k6 i686
src_compile() {
+ # Make sure that the older libraries are not installed (bug #15081).
+ if [ -f /usr/lib/libxine.so.0 ]
+ then
+ einfo "Please uninstall older xine libraries.";
+ einfo "The compilation cannot procede.";
+ die
+ fi
+
# Most of these are not working currently, but are here for completeness
# don't use the --disable-XXXtest because that defaults to ON not OFF
local myconf
diff --git a/media-libs/xine-lib/xine-lib-1_beta4.ebuild b/media-libs/xine-lib/xine-lib-1_beta4.ebuild
index d6afbae442b8..6747afd129ee 100644
--- a/media-libs/xine-lib/xine-lib-1_beta4.ebuild
+++ b/media-libs/xine-lib/xine-lib-1_beta4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_beta4.ebuild,v 1.6 2003/03/07 23:25:49 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_beta4.ebuild,v 1.7 2003/03/08 00:00:43 agenkin Exp $
DESCRIPTION="Core libraries for Xine movie player."
HOMEPAGE="http://xine.sourceforge.net/"
@@ -41,6 +41,14 @@ replace-flags k6 i686
src_compile() {
+ # Make sure that the older libraries are not installed (bug #15081).
+ if [ -f /usr/lib/libxine.so.0 ]
+ then
+ einfo "Please uninstall older xine libraries.";
+ einfo "The compilation cannot procede.";
+ die
+ fi
+
# Use the built-in dvdnav plugin.
local myconf="--with-included-dvdnav"
diff --git a/media-libs/xine-lib/xine-lib-1_beta6.ebuild b/media-libs/xine-lib/xine-lib-1_beta6.ebuild
index 9b7fec140de7..80b3c0549e89 100644
--- a/media-libs/xine-lib/xine-lib-1_beta6.ebuild
+++ b/media-libs/xine-lib/xine-lib-1_beta6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_beta6.ebuild,v 1.4 2003/03/07 23:25:49 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_beta6.ebuild,v 1.5 2003/03/08 00:00:43 agenkin Exp $
DESCRIPTION="Core libraries for Xine movie player."
HOMEPAGE="http://xine.sourceforge.net/"
@@ -41,8 +41,17 @@ replace-flags k6-3 i686
replace-flags k6-2 i686
replace-flags k6 i686
+
src_compile() {
+ # Make sure that the older libraries are not installed (bug #15081).
+ if [ -f /usr/lib/libxine.so.0 ]
+ then
+ einfo "Please uninstall older xine libraries.";
+ einfo "The compilation cannot procede.";
+ die
+ fi
+
# Use the built-in dvdnav plugin.
local myconf="--with-included-dvdnav"