summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2011-09-07 23:17:44 +0000
committerPatrick McLean <chutzpah@gentoo.org>2011-09-07 23:17:44 +0000
commit2a902722ac1d6af8fa15b89b2185b3b9a687d089 (patch)
tree20201a5b67fe6dd5f4413b0fbf1268bec9663985 /media-libs/x264
parentVersion bump; drop old version (diff)
downloadgentoo-2-2a902722ac1d6af8fa15b89b2185b3b9a687d089.tar.gz
gentoo-2-2a902722ac1d6af8fa15b89b2185b3b9a687d089.tar.bz2
gentoo-2-2a902722ac1d6af8fa15b89b2185b3b9a687d089.zip
Revision bump, merge in 9999 ebuild stuff from multimedia overlay, add 10bit USE flag and use stable tarball rather than the unstable one.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/x264')
-rw-r--r--media-libs/x264/ChangeLog9
-rw-r--r--media-libs/x264/metadata.xml1
-rw-r--r--media-libs/x264/x264-0.0.20110825-r1.ebuild (renamed from media-libs/x264/x264-0.0.20110825.ebuild)39
3 files changed, 38 insertions, 11 deletions
diff --git a/media-libs/x264/ChangeLog b/media-libs/x264/ChangeLog
index c1cc68f2c3ee..aeedb4d89f29 100644
--- a/media-libs/x264/ChangeLog
+++ b/media-libs/x264/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/x264
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.60 2011/09/07 17:56:15 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.61 2011/09/07 23:17:44 chutzpah Exp $
+
+*x264-0.0.20110825-r1 (07 Sep 2011)
+
+ 07 Sep 2011; Patrick McLean <chutzpah@gentoo.org> -x264-0.0.20110825.ebuild,
+ +x264-0.0.20110825-r1.ebuild, metadata.xml:
+ Revision bump, merge in 9999 ebuild stuff from multimedia overlay, add 10bit
+ USE flag and use stable tarball rather than the unstable one.
07 Sep 2011; Patrick McLean <chutzpah@gentoo.org> x264-0.0.20110825.ebuild,
metadata.xml:
diff --git a/media-libs/x264/metadata.xml b/media-libs/x264/metadata.xml
index 321f7b28784f..c2547438ec91 100644
--- a/media-libs/x264/metadata.xml
+++ b/media-libs/x264/metadata.xml
@@ -8,5 +8,6 @@
<use>
<flag name="pic">disable optimized assembly code that is not PIC friendly</flag>
<flag name="interlaced">enable interlaced encoding support, this can decrease encoding speed by up to 2%</flag>
+ <flag name="10bit">Set output bit depth to 10, this may not be compatible with all decoders</flag>
</use>
</pkgmetadata>
diff --git a/media-libs/x264/x264-0.0.20110825.ebuild b/media-libs/x264/x264-0.0.20110825-r1.ebuild
index 01612d74cd4d..410c03044abc 100644
--- a/media-libs/x264/x264-0.0.20110825.ebuild
+++ b/media-libs/x264/x264-0.0.20110825-r1.ebuild
@@ -1,27 +1,46 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20110825.ebuild,v 1.3 2011/09/07 17:56:15 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20110825-r1.ebuild,v 1.1 2011/09/07 23:17:44 chutzpah Exp $
EAPI=4
-inherit eutils flag-o-matic multilib toolchain-funcs versionator
-MY_P=x264-snapshot-$(get_version_component_range 3)-2245
+if [ "${PV#9999}" != "${PV}" ] ; then
+ V_ECLASS="git-2"
+else
+ V_ECLASS="versionator"
+fi
+inherit multilib toolchain-funcs flag-o-matic ${V_ECLASS}
+
+if [ "${PV#9999}" = "${PV}" ]; then
+ MY_P="x264-snapshot-$(get_version_component_range 3)-2245-stable"
+fi
DESCRIPTION="A free library for encoding X264/AVC streams"
HOMEPAGE="http://www.videolan.org/developers/x264.html"
-SRC_URI="ftp://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ EGIT_REPO_URI="git://git.videolan.org/x264.git"
+ SRC_URI=""
+else
+ SRC_URI="http://download.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+fi
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="custom-cflags debug +interlaced pic static-libs +threads"
+if [ "${PV#9999}" != "${PV}" ]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+fi
+IUSE="10bit custom-cflags debug +interlaced pic static-libs +threads"
RDEPEND=""
DEPEND="amd64? ( >=dev-lang/yasm-0.6.2 )
x86? ( >=dev-lang/yasm-0.6.2 )
x86-fbsd? ( >=dev-lang/yasm-0.6.2 )"
-S=${WORKDIR}/${MY_P}
+if [ "${PV#9999}" = "${PV}" ]; then
+ S="${WORKDIR}/${MY_P}"
+fi
DOCS="AUTHORS doc/*.txt"
@@ -29,10 +48,11 @@ src_configure() {
tc-export CC
local myconf=""
+ use 10bit && myconf+=" --bit-depth=10"
use debug && myconf+=" --enable-debug"
+ use interlaced || myconf+=" --disable-interlaced"
use static-libs && myconf+=" --enable-static"
use threads || myconf+=" --disable-thread"
- use interlaced || myconf+=" --disable-interlaced"
# let upstream pick the optimization level by default
use custom-cflags || filter-flags -O?
@@ -53,8 +73,7 @@ src_configure() {
--enable-pic \
--enable-shared \
--host="${CHOST}" \
- ${myconf} \
- || die
+ ${myconf} || die
# this is a nasty workaround for bug #376925 as upstream doesn't like us
# fiddling with their CFLAGS