summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-09-09 08:57:19 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-09-09 08:57:19 +0000
commit0e98abdc883bdf831e29397ad17c2df25ebe2da8 (patch)
tree0d68d836a4cb2b535b1b16e898c35e68d2a46ce3 /media-libs/x264
parentVersion bump, this version has a workaround for people who saw the browser cr... (diff)
downloadgentoo-2-0e98abdc883bdf831e29397ad17c2df25ebe2da8.tar.gz
gentoo-2-0e98abdc883bdf831e29397ad17c2df25ebe2da8.tar.bz2
gentoo-2-0e98abdc883bdf831e29397ad17c2df25ebe2da8.zip
Version bump.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/x264')
-rw-r--r--media-libs/x264/ChangeLog8
-rw-r--r--media-libs/x264/x264-0.0.20090908.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/media-libs/x264/ChangeLog b/media-libs/x264/ChangeLog
index 178291f39275..b19a203e8df6 100644
--- a/media-libs/x264/ChangeLog
+++ b/media-libs/x264/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/x264
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.22 2009/06/29 21:37:28 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.23 2009/09/09 08:57:19 ssuominen Exp $
+
+*x264-0.0.20090908 (09 Sep 2009)
+
+ 09 Sep 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +x264-0.0.20090908.ebuild:
+ Version bump.
*x264-0.0.20090629 (29 Jun 2009)
diff --git a/media-libs/x264/x264-0.0.20090908.ebuild b/media-libs/x264/x264-0.0.20090908.ebuild
new file mode 100644
index 000000000000..b5162e64b7c4
--- /dev/null
+++ b/media-libs/x264/x264-0.0.20090908.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20090908.ebuild,v 1.1 2009/09/09 08:57:19 ssuominen Exp $
+
+EAPI=2
+inherit eutils multilib toolchain-funcs versionator
+
+MY_P=x264-snapshot-$(get_version_component_range 3)-2245
+
+DESCRIPTION="A free library for encoding X264/AVC streams"
+HOMEPAGE="http://www.videolan.org/developers/x264.html"
+SRC_URI="ftp://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +threads"
+# pic
+
+RDEPEND=""
+DEPEND="amd64? ( >=dev-lang/yasm-0.6.2 )
+ x86? ( >=dev-lang/yasm-0.6.2 )
+ x86-fbsd? ( >=dev-lang/yasm-0.6.2 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-nostrip.patch \
+ "${FILESDIR}"/${PN}-onlylib-20090408.patch
+}
+
+src_configure() {
+ tc-export CC
+
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debug"
+
+# if use x86 && use pic; then
+# myconf="${myconf} --disable-asm"
+# fi
+
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --disable-avis-input \
+ --disable-mp4-output \
+ $(use_enable threads pthread) \
+ --enable-pic \
+ --enable-shared \
+ --extra-asflags="${ASFLAGS}" \
+ --extra-cflags="${CFLAGS}" \
+ --extra-ldflags="${LDFLAGS}" \
+ --host="${CHOST}" \
+ ${myconf} \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS doc/*.txt
+}