summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-02-22 07:51:44 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-02-22 07:51:44 +0000
commita392125a025c7297ef285c9e52f92301672f2678 (patch)
treebd207495648d9603f4bd7821f5c1b2f1f9c90f5f /media-libs/smpeg2
parentStable for HPPA (bug #540976). (diff)
downloadgentoo-2-a392125a025c7297ef285c9e52f92301672f2678.tar.gz
gentoo-2-a392125a025c7297ef285c9e52f92301672f2678.tar.bz2
gentoo-2-a392125a025c7297ef285c9e52f92301672f2678.zip
add the patch from smpeg to work around bug #538876; rev bump to push out diffs
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'media-libs/smpeg2')
-rw-r--r--media-libs/smpeg2/ChangeLog9
-rw-r--r--media-libs/smpeg2/files/smpeg2-2.0.0-smpeg2-config.patch14
-rw-r--r--media-libs/smpeg2/smpeg2-2.0.0-r3.ebuild51
3 files changed, 69 insertions, 5 deletions
diff --git a/media-libs/smpeg2/ChangeLog b/media-libs/smpeg2/ChangeLog
index 6faeb598cc6a..d9d0ccdd6165 100644
--- a/media-libs/smpeg2/ChangeLog
+++ b/media-libs/smpeg2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/smpeg2
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg2/ChangeLog,v 1.6 2015/01/29 17:58:22 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg2/ChangeLog,v 1.7 2015/02/22 07:51:44 mr_bones_ Exp $
+
+*smpeg2-2.0.0-r3 (22 Feb 2015)
+
+ 22 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org> +smpeg2-2.0.0-r3.ebuild,
+ files/smpeg2-2.0.0-smpeg2-config.patch:
+ add the patch from smpeg to work around bug #538876; rev bump to push out
+ diffs
29 Jan 2015; Michał Górny <mgorny@gentoo.org> smpeg2-2.0.0-r2.ebuild:
Switch to CPU_FLAGS_X86.
diff --git a/media-libs/smpeg2/files/smpeg2-2.0.0-smpeg2-config.patch b/media-libs/smpeg2/files/smpeg2-2.0.0-smpeg2-config.patch
index 2018968e195e..66c246f08cca 100644
--- a/media-libs/smpeg2/files/smpeg2-2.0.0-smpeg2-config.patch
+++ b/media-libs/smpeg2/files/smpeg2-2.0.0-smpeg2-config.patch
@@ -4,9 +4,14 @@ Subject: fix smpeg2-config.in
SDL_CONFIG is now SDL2_CONFIG in the new sdl2.m4
---- smpeg-2.0.0/smpeg2-config.in
+--------------------------------------CUT---------------------------------------
+also
+
+Only dump -L/-rpath if libdir is non-standard; cribbed from smpeg patches
+
+--- smpeg-2.0.0.orig/smpeg2-config.in
+++ smpeg-2.0.0/smpeg2-config.in
-@@ -42,7 +42,7 @@
+@@ -42,15 +42,17 @@
if test @includedir@ != /usr/include ; then
includes=-I@includedir@
fi
@@ -14,14 +19,15 @@ SDL_CONFIG is now SDL2_CONFIG in the new sdl2.m4
+ echo $includes -I@includedir@/smpeg2 `@SDL2_CONFIG@ --cflags`
;;
--libs)
++ if [ "@libdir@" != "/usr/lib" ]; then
if [ "`uname`" = "SunOS" ]; then
-@@ -50,7 +50,7 @@
+ libdirs="-L@libdir@ -R@libdir@"
else
libdirs="-L@libdir@ @SMPEG_RLD_FLAGS@"
fi
- echo $libdirs -lsmpeg2 `@SDL_CONFIG@ --libs`
++ fi
+ echo $libdirs -lsmpeg2 `@SDL2_CONFIG@ --libs`
;;
*)
echo "${usage}" 1>&2
-
diff --git a/media-libs/smpeg2/smpeg2-2.0.0-r3.ebuild b/media-libs/smpeg2/smpeg2-2.0.0-r3.ebuild
new file mode 100644
index 000000000000..c18bfee3b43b
--- /dev/null
+++ b/media-libs/smpeg2/smpeg2-2.0.0-r3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg2/smpeg2-2.0.0-r3.ebuild,v 1.1 2015/02/22 07:51:44 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs autotools multilib-minimal
+
+MY_P=smpeg-${PV}
+DESCRIPTION="SDL MPEG Player Library"
+HOMEPAGE="http://icculus.org/smpeg/"
+SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug cpu_flags_x86_mmx static-libs"
+
+DEPEND=">=media-libs/libsdl2-2.0.1-r1[${MULTILIB_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGES README README.SDL_mixer TODO )
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-smpeg2-config.patch
+
+ # avoid file collision with media-libs/smpeg
+ sed -i \
+ -e '/plaympeg/d' \
+ Makefile.am || die
+
+ mv configure.in configure.ac || die
+ AT_M4DIR="/usr/share/aclocal acinclude" eautoreconf
+}
+
+multilib_src_configure() {
+ # the debug option is bogus ... all it does is add extra
+ # optimizations if you pass --disable-debug
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ --disable-rpath \
+ --enable-debug \
+ --disable-sdltest \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ $(use_enable debug assertions)
+}
+
+multilib_src_install_all() {
+ use static-libs || prune_libtool_files
+}