summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-05-03 10:34:42 +0000
committerMichał Górny <mgorny@gentoo.org>2014-05-03 10:34:42 +0000
commitcce402e9aa3da50efb34f49c45e33cb454ba62a2 (patch)
tree939f13af4110c6decf3685b3af0cfd9e7c5fa7a2 /media-libs/sdl-mixer
parentEnable multilib support. (diff)
downloadgentoo-2-cce402e9aa3da50efb34f49c45e33cb454ba62a2.tar.gz
gentoo-2-cce402e9aa3da50efb34f49c45e33cb454ba62a2.tar.bz2
gentoo-2-cce402e9aa3da50efb34f49c45e33cb454ba62a2.zip
Enable multilib support.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-libs/sdl-mixer')
-rw-r--r--media-libs/sdl-mixer/ChangeLog9
-rw-r--r--media-libs/sdl-mixer/sdl-mixer-1.2.12-r4.ebuild115
2 files changed, 122 insertions, 2 deletions
diff --git a/media-libs/sdl-mixer/ChangeLog b/media-libs/sdl-mixer/ChangeLog
index ae85e91ffe2a..4e100922ee23 100644
--- a/media-libs/sdl-mixer/ChangeLog
+++ b/media-libs/sdl-mixer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/sdl-mixer
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/ChangeLog,v 1.124 2013/02/24 18:04:28 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/ChangeLog,v 1.125 2014/05/03 10:34:42 mgorny Exp $
+
+*sdl-mixer-1.2.12-r4 (03 May 2014)
+
+ 03 May 2014; Michał Górny <mgorny@gentoo.org> +sdl-mixer-1.2.12-r4.ebuild:
+ Enable multilib support.
24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> sdl-mixer-1.2.12-r3.ebuild:
Stable for sh, wrt bug #455490
diff --git a/media-libs/sdl-mixer/sdl-mixer-1.2.12-r4.ebuild b/media-libs/sdl-mixer/sdl-mixer-1.2.12-r4.ebuild
new file mode 100644
index 000000000000..fff08f066fea
--- /dev/null
+++ b/media-libs/sdl-mixer/sdl-mixer-1.2.12-r4.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/sdl-mixer-1.2.12-r4.ebuild,v 1.1 2014/05/03 10:34:42 mgorny Exp $
+
+EAPI=5
+inherit eutils multilib-minimal
+
+MY_P=${P/sdl-/SDL_}
+DESCRIPTION="Simple Direct Media Layer Mixer Library"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_mixer/"
+SRC_URI="http://www.libsdl.org/projects/SDL_mixer/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="flac fluidsynth mad midi mikmod mod modplug mp3 playtools smpeg static-libs timidity vorbis +wav"
+REQUIRED_USE="
+ midi? ( || ( timidity fluidsynth ) )
+ timidity? ( midi )
+ fluidsynth? ( midi )
+ mp3? ( || ( smpeg mad ) )
+ smpeg? ( mp3 )
+ mad? ( mp3 )
+ mod? ( || ( mikmod modplug ) )
+ mikmod? ( mod )
+ modplug? ( mod )
+ "
+
+RDEPEND=">=media-libs/libsdl-1.2.10[${MULTILIB_USEDEP}]
+ flac? ( media-libs/flac[${MULTILIB_USEDEP}] )
+ midi? (
+ fluidsynth? ( media-sound/fluidsynth[${MULTILIB_USEDEP}] )
+ timidity? ( media-sound/timidity++ )
+ )
+ mp3? (
+ mad? ( media-libs/libmad[${MULTILIB_USEDEP}] )
+ smpeg? ( >=media-libs/smpeg-0.4.4-r1[${MULTILIB_USEDEP}] )
+ )
+ mod? (
+ modplug? ( media-libs/libmodplug[${MULTILIB_USEDEP}] )
+ mikmod? ( >=media-libs/libmikmod-3.1.10[${MULTILIB_USEDEP}] )
+ )
+ vorbis? (
+ media-libs/libvorbis[${MULTILIB_USEDEP}]
+ media-libs/libogg[${MULTILIB_USEDEP}] )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-sdl-20140406-r1
+ !app-emulation/emul-linux-x86-sdl[-abi_x86_32(-)]
+ )"
+DEPEND=${RDEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-wav.patch \
+ "${FILESDIR}"/${P}-clang.patch \
+ "${FILESDIR}"/${P}-mikmod-r58{7,8}.patch #445980
+ sed -i \
+ -e '/link.*play/s/-o/$(LDFLAGS) -o/' \
+ Makefile.in || die
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-dependency-tracking \
+ --disable-music-flac-shared \
+ --disable-music-fluidsynth-shared \
+ --disable-music-mod-shared \
+ --disable-music-mp3-shared \
+ --disable-music-ogg-shared \
+ $(use_enable wav music-wave) \
+ $(use_enable vorbis music-ogg) \
+ $(use_enable mikmod music-mod) \
+ $(use_enable modplug music-mod-modplug) \
+ $(use_enable flac music-flac) \
+ $(use_enable static-libs static) \
+ $(use_enable smpeg music-mp3) \
+ $(use_enable mad music-mp3-mad-gpl) \
+ $(use_enable timidity music-timidity-midi) \
+ $(use_enable fluidsynth music-fluidsynth-midi)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ if multilib_is_native_abi && use playtools; then
+ emake DESTDIR="${D}" install-bin
+ fi
+}
+
+multilib_src_install_all() {
+ dodoc CHANGES README
+ if ! use static-libs ; then
+ remove_libtool_files --all
+ fi
+}
+
+pkg_postinst() {
+ # bug 412035
+ # https://bugs.gentoo.org/show_bug.cgi?id=412035
+ if use midi ; then
+ if use fluidsynth; then
+ ewarn "FluidSynth support requires you to set the SDL_SOUNDFONTS"
+ ewarn "environment variable to the location of a SoundFont file"
+ ewarn "unless the game or application happens to do this for you."
+
+ if use timidity; then
+ ewarn "Failing to do so will result in Timidity being used instead."
+ else
+ ewarn "Failing to do so will result in silence."
+ fi
+ fi
+ fi
+}