summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-08-30 18:14:42 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-08-30 18:14:42 +0000
commit066936fedc740223631e4ab45bc215735b44adab (patch)
treeb5da8c686e0e948a2bbc963f898def0095233530 /media-libs/sdl-gfx/sdl-gfx-2.0.12.ebuild
parentKeyworded ~sparc in preparation for the future (Manifest recommit) (diff)
downloadgentoo-2-066936fedc740223631e4ab45bc215735b44adab.tar.gz
gentoo-2-066936fedc740223631e4ab45bc215735b44adab.tar.bz2
gentoo-2-066936fedc740223631e4ab45bc215735b44adab.zip
version bump
Diffstat (limited to 'media-libs/sdl-gfx/sdl-gfx-2.0.12.ebuild')
-rw-r--r--media-libs/sdl-gfx/sdl-gfx-2.0.12.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/sdl-gfx/sdl-gfx-2.0.12.ebuild b/media-libs/sdl-gfx/sdl-gfx-2.0.12.ebuild
new file mode 100644
index 000000000000..abb2772c37f0
--- /dev/null
+++ b/media-libs/sdl-gfx/sdl-gfx-2.0.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-gfx/sdl-gfx-2.0.12.ebuild,v 1.1 2004/08/30 18:14:42 mr_bones_ Exp $
+
+inherit flag-o-matic
+
+MY_P="${P/sdl-/SDL_}"
+DESCRIPTION="Graphics drawing primitives library for SDL"
+HOMEPAGE="http://www.ferzkopp.net/~aschiffler/Software/SDL_gfx-2.0/index.html"
+SRC_URI="http://www.ferzkopp.net/~aschiffler/Software/SDL_gfx-2.0/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc alpha ~hppa ~amd64"
+IUSE="mmx"
+
+DEPEND=">=media-libs/libsdl-1.2"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ local myconf
+
+ replace-flags "-O?" "-O2"
+
+ if use ppc || use sparc || use alpha || use amd64
+ then
+ myconf="--disable-mmx"
+ else
+ use mmx || myconf="--disable-mmx"
+ fi
+
+ econf ${myconf} || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README
+ dohtml -r Docs/*
+}