summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-03-30 04:45:14 +0000
committerTim Harder <radhermit@gentoo.org>2011-03-30 04:45:14 +0000
commit99785a9a1cf561fd8a4dd5c195254264913cfdaa (patch)
treee5b05d4df35ce39fba6ee36279e598d32a0baa9c /media-libs/quvi
parentalign prefix keywords (diff)
downloadgentoo-2-99785a9a1cf561fd8a4dd5c195254264913cfdaa.tar.gz
gentoo-2-99785a9a1cf561fd8a4dd5c195254264913cfdaa.tar.bz2
gentoo-2-99785a9a1cf561fd8a4dd5c195254264913cfdaa.zip
Revision bump. Update to EAPI 4, apply upstream patch to fix totem-pl-parser and youtube videos (bug #360643 by Pacho Ramos), use bash syntax instead of versionator eclass for SRC_URI, and remove empty doc directory.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/quvi')
-rw-r--r--media-libs/quvi/ChangeLog10
-rw-r--r--media-libs/quvi/files/quvi-0.2.14-docs.patch15
-rw-r--r--media-libs/quvi/files/quvi-0.2.14-youtube-video-ids.patch57
-rw-r--r--media-libs/quvi/quvi-0.2.14-r1.ebuild45
4 files changed, 126 insertions, 1 deletions
diff --git a/media-libs/quvi/ChangeLog b/media-libs/quvi/ChangeLog
index cd9e39b1e24e..fd52235f0a36 100644
--- a/media-libs/quvi/ChangeLog
+++ b/media-libs/quvi/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/quvi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/quvi/ChangeLog,v 1.20 2011/03/13 21:00:32 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/quvi/ChangeLog,v 1.21 2011/03/30 04:45:14 radhermit Exp $
+
+*quvi-0.2.14-r1 (30 Mar 2011)
+
+ 30 Mar 2011; Tim Harder <radhermit@gentoo.org> +quvi-0.2.14-r1.ebuild,
+ +files/quvi-0.2.14-docs.patch, +files/quvi-0.2.14-youtube-video-ids.patch:
+ Revision bump. Update to EAPI 4, apply upstream patch to fix totem-pl-parser
+ and youtube videos (bug #360643 by Pacho Ramos), use bash syntax instead of
+ versionator eclass for SRC_URI, and remove empty doc directory.
13 Mar 2011; Tim Harder <radhermit@gentoo.org> -quvi-0.2.11.ebuild,
-quvi-0.2.12.ebuild:
diff --git a/media-libs/quvi/files/quvi-0.2.14-docs.patch b/media-libs/quvi/files/quvi-0.2.14-docs.patch
new file mode 100644
index 000000000000..522b8f059530
--- /dev/null
+++ b/media-libs/quvi/files/quvi-0.2.14-docs.patch
@@ -0,0 +1,15 @@
+--- quvi-0.2.14/Makefile.am.orig
++++ quvi-0.2.14/Makefile.am
+@@ -10,7 +10,11 @@
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = libquvi.pc
+
+-SUBDIRS = include lib man1 src examples share doc scripts
++SUBDIRS = include lib man1 src examples share scripts
++
++if WITH_DOC
++SUBDIRS += doc
++endif
+
+ if ENABLE_TESTS
+ SUBDIRS += tests
diff --git a/media-libs/quvi/files/quvi-0.2.14-youtube-video-ids.patch b/media-libs/quvi/files/quvi-0.2.14-youtube-video-ids.patch
new file mode 100644
index 000000000000..1ddd79cc6627
--- /dev/null
+++ b/media-libs/quvi/files/quvi-0.2.14-youtube-video-ids.patch
@@ -0,0 +1,57 @@
+From 54fd2afbc1596cbb21a96adab89525ac65e06df4 Mon Sep 17 00:00:00 2001
+From: Bastien Nocera <hadess@hadess.net>
+Date: Wed, 16 Mar 2011 23:56:19 +0000
+Subject: [PATCH] youtube: Only accept URLs with video IDs in them
+
+---
+ share/lua/website/youtube.lua | 23 +++++++++++++++++------
+ 1 files changed, 17 insertions(+), 6 deletions(-)
+
+--- a/share/lua/website/youtube.lua
++++ b/share/lua/website/youtube.lua
+@@ -45,17 +45,28 @@ local domains = {
+ "youtu.be"
+ }
+
+--- Check whether the domain is handled
+-function is_handled (page_url)
++-- Return the video ID
++function get_video_id (page_url)
+ if page_url == nil then
+- return false
++ return nil
+ end
+ for k,domain in pairs(domains) do
+ if page_url:find(domain) ~= nil then
+- return true
++ page_url = youtubify(page_url)
++ local _,_,s = page_url:find("v=([%w-_]+)")
++ return s
+ end
+ end
+- return false
++ return nil
++end
++
++-- Check whether the domain is handled
++function is_handled (page_url)
++ local id = get_video_id(page_url)
++ if id == nil then
++ return false
++ end
++ return true
+ end
+
+ -- Identify the script.
+@@ -81,7 +92,7 @@ function parse (self)
+ self.host_id = "youtube"
+ local page_url = youtubify(self.page_url)
+
+- local _,_,s = page_url:find("v=([%w-_]+)")
++ local s = get_video_id(page_url)
+ self.id = s or error ("no match: video id")
+
+ local _,_,s = page_url:find('#t=(.+)')
+--
+1.7.4.1
+
diff --git a/media-libs/quvi/quvi-0.2.14-r1.ebuild b/media-libs/quvi/quvi-0.2.14-r1.ebuild
new file mode 100644
index 000000000000..417d8567e46a
--- /dev/null
+++ b/media-libs/quvi/quvi-0.2.14-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/quvi/quvi-0.2.14-r1.ebuild,v 1.1 2011/03/30 04:45:14 radhermit Exp $
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="library for parsing video download links"
+HOMEPAGE="http://quvi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PV:0:3}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc examples test offensive static-libs"
+
+RDEPEND=">=net-misc/curl-7.18.0
+ dev-lang/lua[deprecated]"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+# tests fetch data from live websites, so it's rather normal that they
+# will fail
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-youtube-video-ids.patch \
+ "${FILESDIR}"/${P}-docs.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-doc \
+ $(use_enable examples) \
+ $(use_enable offensive nsfw) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use doc && dodoc doc/How*
+ find "${D}" -name '*.la' -delete
+}