summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefaan De Roeck <stefaan@gentoo.org>2006-01-20 21:19:22 +0000
committerStefaan De Roeck <stefaan@gentoo.org>2006-01-20 21:19:22 +0000
commitcadd14741f19c29f0495b73158416240b37f2cc6 (patch)
treede3ccb8cc9dcea76ae9d8afd28cf095c41667fe6 /media-libs/openinventor
parentStable on ppc64; bug #108262 (diff)
downloadgentoo-2-cadd14741f19c29f0495b73158416240b37f2cc6.tar.gz
gentoo-2-cadd14741f19c29f0495b73158416240b37f2cc6.tar.bz2
gentoo-2-cadd14741f19c29f0495b73158416240b37f2cc6.zip
Porting to modular X
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'media-libs/openinventor')
-rw-r--r--media-libs/openinventor/ChangeLog10
-rw-r--r--media-libs/openinventor/Manifest2
-rw-r--r--media-libs/openinventor/files/digest-openinventor-2.1.5.10-r21
-rw-r--r--media-libs/openinventor/openinventor-2.1.5.10-r2.ebuild89
4 files changed, 100 insertions, 2 deletions
diff --git a/media-libs/openinventor/ChangeLog b/media-libs/openinventor/ChangeLog
index 72cd8aa819c5..c168449b6af5 100644
--- a/media-libs/openinventor/ChangeLog
+++ b/media-libs/openinventor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/openinventor
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openinventor/ChangeLog,v 1.9 2005/12/26 14:36:01 stefaan Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openinventor/ChangeLog,v 1.10 2006/01/20 21:19:22 stefaan Exp $
+
+*openinventor-2.1.5.10-r2 (20 Jan 2006)
+
+ 20 Jan 2006; Stefaan De Roeck <stefaan@gentoo.org>
+ +openinventor-2.1.5.10-r2.ebuild:
+ Porting to modular X
26 Dec 2005; Stefaan De Roeck <stefaan@gentoo.org>
-openinventor-2.1.5.10.ebuild:
diff --git a/media-libs/openinventor/Manifest b/media-libs/openinventor/Manifest
index 8a3ebaa38b7d..79a0cb481d81 100644
--- a/media-libs/openinventor/Manifest
+++ b/media-libs/openinventor/Manifest
@@ -1,5 +1,6 @@
MD5 d664b5c8536b2e04055e346e7feb17cd ChangeLog 1669
MD5 8ce8331fdab79fb938507af45228210f files/digest-openinventor-2.1.5.10-r1 74
+MD5 8ce8331fdab79fb938507af45228210f files/digest-openinventor-2.1.5.10-r2 74
MD5 481f4b44d5f9f6b9af804116c4d2bcc0 files/freetype2-activate.patch 261
MD5 1a742e312c436314783b6b91b8a485d4 files/freetype2-includes.patch 291
MD5 bd1dcb17d80481152c4856c899b21144 files/gcc4-support.patch 4155
@@ -10,3 +11,4 @@ MD5 3514d32986d95c1a1edd9c8503913121 files/support-archs.patch 1116
MD5 3b720d5d1e432dec6ec597f5391caef1 files/use-byacc.patch 1444
MD5 0f7895c10f859b7a86f1df293a1e602b metadata.xml 515
MD5 551d61e193abd8390f25ec74e3139fa6 openinventor-2.1.5.10-r1.ebuild 2656
+MD5 f7d429215fa0b252e24e3e2fb22f9968 openinventor-2.1.5.10-r2.ebuild 2655
diff --git a/media-libs/openinventor/files/digest-openinventor-2.1.5.10-r2 b/media-libs/openinventor/files/digest-openinventor-2.1.5.10-r2
new file mode 100644
index 000000000000..95d1053b6fb2
--- /dev/null
+++ b/media-libs/openinventor/files/digest-openinventor-2.1.5.10-r2
@@ -0,0 +1 @@
+MD5 82208096f1e0b111160e864e239c3a51 inventor-2.1.5-10.src.tar.gz 8282780
diff --git a/media-libs/openinventor/openinventor-2.1.5.10-r2.ebuild b/media-libs/openinventor/openinventor-2.1.5.10-r2.ebuild
new file mode 100644
index 000000000000..ff67b607068d
--- /dev/null
+++ b/media-libs/openinventor/openinventor-2.1.5.10-r2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openinventor/openinventor-2.1.5.10-r2.ebuild,v 1.1 2006/01/20 21:19:22 stefaan Exp $
+
+inherit eutils versionator
+
+MY_PV=$(replace_version_separator 3 '-')
+MY_PN="inventor"
+
+DESCRIPTION="SGI OpenInventor Toolkit and Utilities"
+HOMEPAGE="http://oss.sgi.com/projects/inventor/"
+SRC_URI="ftp://oss.sgi.com/projects/${MY_PN}/download/${MY_PN}-${MY_PV}.src.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ virtual/motif
+ >=media-libs/jpeg-6b
+ >=media-libs/freetype-2.0"
+DEPEND="dev-util/byacc
+ ${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # ordinary yacc fails
+ epatch ${FILESDIR}/use-byacc.patch
+ # support for amd64, sparc and alpha
+ epatch ${FILESDIR}/support-archs.patch
+ # freetype2 wasn't enabled by default
+ epatch ${FILESDIR}/freetype2-activate.patch
+ # extra #include statement necessary for freetype2
+ epatch ${FILESDIR}/freetype2-includes.patch
+ # script aiding in manual installation required csh
+ epatch ${FILESDIR}/no-csh.patch
+ # put files in sane places
+ epatch ${FILESDIR}/gentoo-paths-v2.patch
+ # fix compilation with gcc-4
+ epatch ${FILESDIR}/gcc4-support.patch
+}
+
+src_compile() {
+ # VLDOPTS: find libraries during linking of executables
+ # VLDDSOOPTS: find libraries during linking of libraries
+ # VCFLAGS / VCXXFLAGS: pass user-chosen compiler flags
+ # OPTIMIZER: do not override user-chosen compiler flags
+ # system
+ emake \
+ VLDOPTS="-L${S}/lib -L${S}/libSoXt" \
+ VLDDSOOPTS="-L${S}/lib -L${S}/libSoXt" \
+ VCFLAGS="${CFLAGS}" VCXXFLAGS="${CXXFLAGS}" \
+ OPTIMIZER= \
+ || die "Build failed"
+
+ # fix RUNME-scripts in the demos directory for new paths
+ sed -i \
+ -e 's:/usr/share/:/usr/share/openinventor/:g' \
+ -e 's:/usr/demos/:/usr/share/openinventor/demos/:g' \
+ $(find apps/demos -name *.RUNME)
+}
+
+src_install() {
+ # IVROOT: serves as DESTDIR
+ # LLDOPTS: delete, so it won't go linking with libraries already on the
+ # system
+ # IVLIBDIR: multilib-strict compliance
+ # LD_LIBRARY_PATH: support executables ran during install
+ make \
+ IVROOT="${D}" \
+ LLDOPTS= \
+ IVLIBDIR="${D}usr/$(get_libdir)" \
+ LD_LIBRARY_PATH="${D}usr/$(get_libdir)" \
+ install \
+ || die "Install failed"
+
+ # OpenInventor aliases for TrueType fonts
+ local FONTDIR=/usr/share/fonts/corefonts
+ local ALIASDIR=/usr/share/${PN}/fonts
+ dodir ${ALIASDIR}
+ dosym ${FONTDIR}/times.ttf ${ALIASDIR}/Times-Roman
+ dosym ${FONTDIR}/arial.ttf ${ALIASDIR}/Helvetica
+ dosym ${FONTDIR}/cour.ttf ${ALIASDIR}/Utopia-Regular
+}
+