summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-07-23 09:42:23 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-07-23 09:42:23 +0000
commit765f2d127e39dccefd131ecff5dabe399f84c5b8 (patch)
tree5f4c98cc039e21b26b1f0675b97e12bc7be2c568 /media-libs/openexr_ctl
parentbump (diff)
downloadgentoo-2-765f2d127e39dccefd131ecff5dabe399f84c5b8.tar.gz
gentoo-2-765f2d127e39dccefd131ecff5dabe399f84c5b8.tar.bz2
gentoo-2-765f2d127e39dccefd131ecff5dabe399f84c5b8.zip
Fix namespace handling with OpenEXR >= 2.0.1 wrt http://lists.gnu.org/archive/html/openexr-devel/2013-04/msg00031.html
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-libs/openexr_ctl')
-rw-r--r--media-libs/openexr_ctl/ChangeLog9
-rw-r--r--media-libs/openexr_ctl/files/openexr_ctl-1.0.1-namespace.patch18
-rw-r--r--media-libs/openexr_ctl/openexr_ctl-1.0.1-r2.ebuild41
3 files changed, 67 insertions, 1 deletions
diff --git a/media-libs/openexr_ctl/ChangeLog b/media-libs/openexr_ctl/ChangeLog
index 8921bcdf4d09..9b8dd345f619 100644
--- a/media-libs/openexr_ctl/ChangeLog
+++ b/media-libs/openexr_ctl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/openexr_ctl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openexr_ctl/ChangeLog,v 1.25 2013/03/21 04:01:31 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openexr_ctl/ChangeLog,v 1.26 2013/07/23 09:42:23 ssuominen Exp $
+
+*openexr_ctl-1.0.1-r2 (23 Jul 2013)
+
+ 23 Jul 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +openexr_ctl-1.0.1-r2.ebuild, +files/openexr_ctl-1.0.1-namespace.patch:
+ Fix namespace handling with OpenEXR >= 2.0.1 wrt
+ http://lists.gnu.org/archive/html/openexr-devel/2013-04/msg00031.html
21 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
openexr_ctl-1.0.1-r1.ebuild:
diff --git a/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-namespace.patch b/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-namespace.patch
new file mode 100644
index 000000000000..7c30515f122d
--- /dev/null
+++ b/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-namespace.patch
@@ -0,0 +1,18 @@
+http://lists.gnu.org/archive/html/openexr-devel/2013-04/msg00031.html
+
+--- IlmImfCtl/ImfCtlApplyTransforms.h
++++ IlmImfCtl/ImfCtlApplyTransforms.h
+@@ -186,12 +186,7 @@
+ #include <vector>
+ #include <ImathBox.h>
+ #include <ImfThreading.h>
+-
+-namespace Imf
+-{
+- class Header;
+- class FrameBuffer;
+-}
++#include <ImfForward.h>
+
+ namespace Ctl
+ {
diff --git a/media-libs/openexr_ctl/openexr_ctl-1.0.1-r2.ebuild b/media-libs/openexr_ctl/openexr_ctl-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..cb3b31db6d4e
--- /dev/null
+++ b/media-libs/openexr_ctl/openexr_ctl-1.0.1-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openexr_ctl/openexr_ctl-1.0.1-r2.ebuild,v 1.1 2013/07/23 09:42:23 ssuominen Exp $
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="OpenEXR CTL libraries"
+HOMEPAGE="http://sourceforge.net/projects/ampasctl"
+SRC_URI="mirror://sourceforge/ampasctl/${P}.tar.gz"
+
+LICENSE="AMPAS"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="static-libs"
+
+RDEPEND=">=media-libs/ilmbase-2.0.1:=
+ >=media-libs/openexr-2.0.1:=
+ media-libs/ctl:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-{,configure_}gcc43.patch \
+ "${FILESDIR}"/${P}-pkgconfig.patch \
+ "${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-namespace.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}