summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-01-09 00:09:13 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-01-09 00:09:13 +0000
commit61ce2f0966bfcc99a9d96cd6f19515def19773b9 (patch)
treecbd543f8730b31c65b1a1d26a522ae3c3d40b5ec /media-libs/ming
parentImplement PHP_EXT_OPTIONAL_USE as a way to make the PHP dependency optional f... (diff)
downloadgentoo-2-61ce2f0966bfcc99a9d96cd6f19515def19773b9.tar.gz
gentoo-2-61ce2f0966bfcc99a9d96cd6f19515def19773b9.tar.bz2
gentoo-2-61ce2f0966bfcc99a9d96cd6f19515def19773b9.zip
Bug #351098: Use the new PHP_EXT_OPTIONAL_USE optional to make PHP support properly optional.
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/ming')
-rw-r--r--media-libs/ming/ChangeLog6
-rw-r--r--media-libs/ming/ming-0.4.3-r1.ebuild9
2 files changed, 10 insertions, 5 deletions
diff --git a/media-libs/ming/ChangeLog b/media-libs/ming/ChangeLog
index 84888afbfa20..c3a6eb929645 100644
--- a/media-libs/ming/ChangeLog
+++ b/media-libs/ming/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/ming
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ming/ChangeLog,v 1.75 2011/01/08 06:59:18 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ming/ChangeLog,v 1.76 2011/01/09 00:09:13 robbat2 Exp $
+
+ 09 Jan 2011; Robin H. Johnson <robbat2@gentoo.org> ming-0.4.3-r1.ebuild:
+ Bug #351098: Use the new PHP_EXT_OPTIONAL_USE optional to make PHP support
+ properly optional.
*ming-0.4.3-r1 (08 Jan 2011)
diff --git a/media-libs/ming/ming-0.4.3-r1.ebuild b/media-libs/ming/ming-0.4.3-r1.ebuild
index 72d801741c09..00bb3b0e6de9 100644
--- a/media-libs/ming/ming-0.4.3-r1.ebuild
+++ b/media-libs/ming/ming-0.4.3-r1.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ming/ming-0.4.3-r1.ebuild,v 1.1 2011/01/08 06:59:18 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ming/ming-0.4.3-r1.ebuild,v 1.2 2011/01/09 00:09:13 robbat2 Exp $
EAPI="3"
PHP_EXT_NAME=ming
+PHP_EXT_OPTIONAL_USE=php
PYTHON_DEPEND="python? 2"
inherit eutils autotools flag-o-matic multilib php-ext-source-r2 perl-module python
@@ -48,7 +49,7 @@ src_prepare() {
if use php; then
cd "${S}/php_ext"
- php-ext-source-r1_phpize
+ php-ext-source-r2_phpize
cd "${S}"
fi
@@ -70,7 +71,7 @@ src_compile() {
myconf="--disable-rpath
--disable-static
--with-ming"
- php-ext-source-r1_src_compile
+ php-ext-source-r2_src_compile
fi
}
@@ -88,7 +89,7 @@ src_install() {
if use php; then
cd "${S}"/php_ext
- php-ext-source-r1_src_install
+ php-ext-source-r2_src_install
fi
}