summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-05-17 19:37:19 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-05-17 19:37:19 +0000
commit459adc4199541a86ccd13fb55c44909adabd729a (patch)
tree9fa9cf0917bf25407bb6cae4505824953cb788ab /media-libs/mesa
parentx86 stable wrt bug #318189 (diff)
downloadgentoo-2-459adc4199541a86ccd13fb55c44909adabd729a.tar.gz
gentoo-2-459adc4199541a86ccd13fb55c44909adabd729a.tar.bz2
gentoo-2-459adc4199541a86ccd13fb55c44909adabd729a.zip
Add cross-compile fixes. Thx solar. (force due to not updated cvs tree)
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/ChangeLog5
-rw-r--r--media-libs/mesa/mesa-7.8.1.ebuild18
2 files changed, 20 insertions, 3 deletions
diff --git a/media-libs/mesa/ChangeLog b/media-libs/mesa/ChangeLog
index 103123a86303..4b3da1fd1084 100644
--- a/media-libs/mesa/ChangeLog
+++ b/media-libs/mesa/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/mesa
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.270 2010/05/12 18:21:43 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.271 2010/05/17 19:37:19 scarabeus Exp $
+
+ 17 May 2010; Tomáš Chvátal <scarabeus@gentoo.org> mesa-7.8.1.ebuild:
+ Add cross-compile fixes. Thx solar.
12 May 2010; Brent Baude <ranger@gentoo.org> mesa-7.7.1.ebuild:
Marking mesa-7.7.1 ppc64 stable for bug 308521
diff --git a/media-libs/mesa/mesa-7.8.1.ebuild b/media-libs/mesa/mesa-7.8.1.ebuild
index f501e7a8017a..86cdc820988d 100644
--- a/media-libs/mesa/mesa-7.8.1.ebuild
+++ b/media-libs/mesa/mesa-7.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-7.8.1.ebuild,v 1.1 2010/04/06 08:43:11 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-7.8.1.ebuild,v 1.2 2010/05/17 19:37:19 scarabeus Exp $
EAPI=3
@@ -11,7 +11,7 @@ if [[ ${PV} = 9999* ]]; then
EXPERIMENTAL="true"
fi
-inherit autotools multilib flag-o-matic ${GIT_ECLASS} portability
+inherit autotools multilib flag-o-matic toolchain-funcs ${GIT_ECLASS} portability
OPENGL_DIR="xorg-x11"
@@ -104,6 +104,14 @@ src_prepare() {
[[ ${CHOST} == *-freebsd6.* ]] && \
sed -i -e "s/-DHAVE_POSIX_MEMALIGN//" configure.ac
+ # In order for mesa to complete it's build process we need to use a tool
+ # that it compiles. When we cross compile this clearly does not work
+ # so we require mesa to be built on the host system first. -solar
+ if tc-is-cross-compiler; then
+ sed -i -e "s#^GLSL_CL = .*\$#GLSL_CL = glsl-compile#g" \
+ "${S}"/src/mesa/shader/slang/library/Makefile || die
+ fi
+
eautoreconf
}
@@ -169,6 +177,12 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install || die "Installation failed"
+ # Save the glsl-compiler for later use
+ if ! tc-is-cross-compiler; then
+ dodir /usr/bin/
+ cp "${S}"/src/glsl/apps/compile "${D}"/usr/bin/glsl-compile \
+ || die "failed to copy the glsl compiler."
+ fi
# Remove redundant headers
# GLUT thing
rm -f "${D}"/usr/include/GL/glut*.h || die "Removing glut include failed."