summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-10-19 10:56:15 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-10-19 10:56:15 +0000
commit0bfc379a7699a57838090c14966d7b5f823a9497 (patch)
tree34f20b76c6fa36a47f9675ad9c76a01b5a626fc4 /media-libs/mesa
parentStable on amd64 wrt bug #341621 (diff)
downloadgentoo-2-0bfc379a7699a57838090c14966d7b5f823a9497.tar.gz
gentoo-2-0bfc379a7699a57838090c14966d7b5f823a9497.tar.bz2
gentoo-2-0bfc379a7699a57838090c14966d7b5f823a9497.zip
Get rid of radeonhd videocard.
(Portage version: 2.2_rc98/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/ChangeLog6
-rw-r--r--media-libs/mesa/mesa-7.7.1.ebuild7
-rw-r--r--media-libs/mesa/mesa-7.8.2.ebuild7
3 files changed, 11 insertions, 9 deletions
diff --git a/media-libs/mesa/ChangeLog b/media-libs/mesa/ChangeLog
index 1cb3b7805458..c275a63899b9 100644
--- a/media-libs/mesa/ChangeLog
+++ b/media-libs/mesa/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/mesa
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.292 2010/10/10 18:40:59 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.293 2010/10/19 10:56:15 scarabeus Exp $
+
+ 19 Oct 2010; Tomáš Chvátal <scarabeus@gentoo.org> mesa-7.7.1.ebuild,
+ mesa-7.8.2.ebuild:
+ Get rid of radeonhd videocard.
10 Oct 2010; Ulrich Mueller <ulm@gentoo.org> mesa-7.7.1.ebuild,
mesa-7.8.2.ebuild:
diff --git a/media-libs/mesa/mesa-7.7.1.ebuild b/media-libs/mesa/mesa-7.7.1.ebuild
index 392264334417..5bd6ca890437 100644
--- a/media-libs/mesa/mesa-7.7.1.ebuild
+++ b/media-libs/mesa/mesa-7.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-7.7.1.ebuild,v 1.14 2010/10/10 18:40:59 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-7.7.1.ebuild,v 1.15 2010/10/19 10:56:15 scarabeus Exp $
EAPI="2"
@@ -34,7 +34,7 @@ LICENSE="LGPL-2 kilgard"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd"
-VIDEO_CARDS="intel mach64 mga nouveau r128 radeon radeonhd savage sis sunffb svga tdfx via"
+VIDEO_CARDS="intel mach64 mga nouveau r128 radeon savage sis sunffb svga tdfx via"
for card in ${VIDEO_CARDS}; do
IUSE_VIDEO_CARDS+=" video_cards_${card}"
done
@@ -114,7 +114,6 @@ src_configure() {
driver_enable video_cards_r128 r128
# ATI has two implementations as video_cards
driver_enable video_cards_radeon radeon r200 r300 r600
- driver_enable video_cards_radeonhd r300 r600
driver_enable video_cards_savage savage
driver_enable video_cards_sis sis
driver_enable video_cards_sunffb ffb
@@ -136,7 +135,7 @@ src_configure() {
$(use_enable video_cards_svga gallium-svga)
$(use_enable video_cards_nouveau gallium-nouveau)"
#$(use_enable video_cards_intel gallium-intel)"
- if use video_cards_radeon || use video_cards_radeonhd; then
+ if use video_cards_radeon; then
myconf="${myconf} --enable-gallium-radeon"
else
myconf="${myconf} --disable-gallium-radeon"
diff --git a/media-libs/mesa/mesa-7.8.2.ebuild b/media-libs/mesa/mesa-7.8.2.ebuild
index 43d43d5417b7..fa002c8a7794 100644
--- a/media-libs/mesa/mesa-7.8.2.ebuild
+++ b/media-libs/mesa/mesa-7.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-7.8.2.ebuild,v 1.19 2010/10/10 18:40:59 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-7.8.2.ebuild,v 1.20 2010/10/19 10:56:15 scarabeus Exp $
EAPI=3
@@ -33,7 +33,7 @@ LICENSE="LGPL-2 kilgard"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ~ppc ppc64 sh sparc x86 ~x86-fbsd"
-VIDEO_CARDS="intel mach64 mga nouveau r128 radeon radeonhd savage sis svga tdfx via"
+VIDEO_CARDS="intel mach64 mga nouveau r128 radeon savage sis svga tdfx via"
for card in ${VIDEO_CARDS}; do
IUSE_VIDEO_CARDS+=" video_cards_${card}"
done
@@ -129,7 +129,6 @@ src_configure() {
driver_enable video_cards_r128 r128
# ATI has two implementations as video_cards
driver_enable video_cards_radeon radeon r200 r300 r600
- driver_enable video_cards_radeonhd r300 r600
driver_enable video_cards_savage savage
driver_enable video_cards_sis sis
driver_enable video_cards_tdfx tdfx
@@ -149,7 +148,7 @@ src_configure() {
$(use_enable video_cards_svga gallium-svga)
$(use_enable video_cards_nouveau gallium-nouveau)
$(use_enable video_cards_intel gallium-intel)"
- if use video_cards_radeon || use video_cards_radeonhd; then
+ if use video_cards_radeon; then
myconf="${myconf} --enable-gallium-radeon"
else
myconf="${myconf} --disable-gallium-radeon"