summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-08-12 05:12:36 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-08-12 05:12:36 +0000
commit42255bb2f9d34d851fa34407c1f377094a3078ad (patch)
treedfb6c2c7cb1031931eaeaff6914f37a6a4c9bd9c /media-libs/mesa/mesa-6.5.3.ebuild
parentRemoving old version. (diff)
downloadgentoo-2-42255bb2f9d34d851fa34407c1f377094a3078ad.tar.gz
gentoo-2-42255bb2f9d34d851fa34407c1f377094a3078ad.tar.bz2
gentoo-2-42255bb2f9d34d851fa34407c1f377094a3078ad.zip
Backport GCC 4.2 -O2 workaround for ivopts bug from 7.0.1.
(Portage version: 2.1.3.3)
Diffstat (limited to 'media-libs/mesa/mesa-6.5.3.ebuild')
-rw-r--r--media-libs/mesa/mesa-6.5.3.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/media-libs/mesa/mesa-6.5.3.ebuild b/media-libs/mesa/mesa-6.5.3.ebuild
index 66c1a8faa3c9..7a12411f9477 100644
--- a/media-libs/mesa/mesa-6.5.3.ebuild
+++ b/media-libs/mesa/mesa-6.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.5.3.ebuild,v 1.5 2007/08/01 21:48:29 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.5.3.ebuild,v 1.6 2007/08/12 05:12:36 dberkholz Exp $
inherit eutils toolchain-funcs multilib flag-o-matic portability versionator
@@ -85,6 +85,11 @@ pkg_setup() {
append-flags -fno-strict-aliasing
+ # gcc 4.2 has buggy ivopts
+ if [[ $(gcc-version) = "4.2" ]]; then
+ append-flags -fno-ivopts
+ fi
+
if use x86-fbsd; then
CONFIG="freebsd-dri-x86"
elif use amd64-fbsd; then