summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-03 11:50:06 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-03 11:50:06 +0000
commita4b7908fe1bd6a25ffae66f0645507f667bdacaa (patch)
treecd3baf3dc4d3bd93ad6c2efc946b5f20af9a027a /media-libs/lilv
parentsparc stable wrt bug #459448 (diff)
downloadgentoo-2-a4b7908fe1bd6a25ffae66f0645507f667bdacaa.tar.gz
gentoo-2-a4b7908fe1bd6a25ffae66f0645507f667bdacaa.tar.bz2
gentoo-2-a4b7908fe1bd6a25ffae66f0645507f667bdacaa.zip
Use python-any-r1 for waf.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-libs/lilv')
-rw-r--r--media-libs/lilv/ChangeLog9
-rw-r--r--media-libs/lilv/lilv-0.18.0.ebuild10
-rw-r--r--media-libs/lilv/lilv-0.20.0.ebuild10
3 files changed, 20 insertions, 9 deletions
diff --git a/media-libs/lilv/ChangeLog b/media-libs/lilv/ChangeLog
index 9748e7543826..4d8c876f02ab 100644
--- a/media-libs/lilv/ChangeLog
+++ b/media-libs/lilv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/lilv
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lilv/ChangeLog,v 1.14 2014/11/02 18:48:26 aballier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lilv/ChangeLog,v 1.15 2015/01/03 11:50:06 mgorny Exp $
+
+ 03 Jan 2015; Michał Górny <mgorny@gentoo.org> lilv-0.18.0.ebuild,
+ lilv-0.20.0.ebuild:
+ Use python-any-r1 for waf.
*lilv-0.20.0 (02 Nov 2014)
@@ -60,4 +64,3 @@
07 Dec 2011; Alexis Ballier <aballier@gentoo.org> +lilv-0.5.0.ebuild,
+files/ldconfig.patch, +metadata.xml:
initial import, ebuild by me
-
diff --git a/media-libs/lilv/lilv-0.18.0.ebuild b/media-libs/lilv/lilv-0.18.0.ebuild
index 56262839c0e6..5b538ba0a7da 100644
--- a/media-libs/lilv/lilv-0.18.0.ebuild
+++ b/media-libs/lilv/lilv-0.18.0.ebuild
@@ -1,10 +1,13 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lilv/lilv-0.18.0.ebuild,v 1.1 2014/01/18 12:22:58 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lilv/lilv-0.18.0.ebuild,v 1.2 2015/01/03 11:50:06 mgorny Exp $
EAPI=4
-inherit base waf-utils bash-completion-r1
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit base python-any-r1 waf-utils bash-completion-r1
DESCRIPTION="Library to make the use of LV2 plugins as simple as possible for applications"
HOMEPAGE="http://drobilla.net/software/lilv/"
@@ -20,6 +23,7 @@ RDEPEND="media-libs/lv2
>=dev-libs/serd-0.14.0
>=dev-libs/sord-0.12.0"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
doc? ( app-doc/doxygen )
virtual/pkgconfig"
diff --git a/media-libs/lilv/lilv-0.20.0.ebuild b/media-libs/lilv/lilv-0.20.0.ebuild
index 6dc5813eaf5f..54f014c7790b 100644
--- a/media-libs/lilv/lilv-0.20.0.ebuild
+++ b/media-libs/lilv/lilv-0.20.0.ebuild
@@ -1,10 +1,13 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lilv/lilv-0.20.0.ebuild,v 1.1 2014/11/02 18:48:26 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lilv/lilv-0.20.0.ebuild,v 1.2 2015/01/03 11:50:06 mgorny Exp $
EAPI=4
-inherit base waf-utils bash-completion-r1
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit base python-any-r1 waf-utils bash-completion-r1
DESCRIPTION="Library to make the use of LV2 plugins as simple as possible for applications"
HOMEPAGE="http://drobilla.net/software/lilv/"
@@ -20,6 +23,7 @@ RDEPEND="media-libs/lv2
>=dev-libs/serd-0.14.0
>=dev-libs/sord-0.12.0"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
doc? ( app-doc/doxygen )
virtual/pkgconfig"