summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-06-27 16:22:31 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-06-27 16:22:31 +0000
commitc2240d212f40494ec7598791191b8f1ae14e2136 (patch)
tree224f79dedbc2c5b9303e3399f98b8a2305f2a0c6 /media-libs/libtheora
parentgo multilib (diff)
downloadgentoo-2-c2240d212f40494ec7598791191b8f1ae14e2136.tar.gz
gentoo-2-c2240d212f40494ec7598791191b8f1ae14e2136.tar.bz2
gentoo-2-c2240d212f40494ec7598791191b8f1ae14e2136.zip
go multilib
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/libtheora')
-rw-r--r--media-libs/libtheora/ChangeLog7
-rw-r--r--media-libs/libtheora/libtheora-1.1.1-r1.ebuild87
2 files changed, 93 insertions, 1 deletions
diff --git a/media-libs/libtheora/ChangeLog b/media-libs/libtheora/ChangeLog
index be3b46dfe408..884b8f5caf7f 100644
--- a/media-libs/libtheora/ChangeLog
+++ b/media-libs/libtheora/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libtheora
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.110 2013/04/25 18:54:13 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.111 2013/06/27 16:22:31 aballier Exp $
+
+*libtheora-1.1.1-r1 (27 Jun 2013)
+
+ 27 Jun 2013; Alexis Ballier <aballier@gentoo.org> +libtheora-1.1.1-r1.ebuild:
+ go multilib
25 Apr 2013; Tim Harder <radhermit@gentoo.org> libtheora-1.1.1.ebuild:
Fix autoreconf failures with automake-1.13 (bug #467006).
diff --git a/media-libs/libtheora/libtheora-1.1.1-r1.ebuild b/media-libs/libtheora/libtheora-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..668f7e3650b8
--- /dev/null
+++ b/media-libs/libtheora/libtheora-1.1.1-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.1.1-r1.ebuild,v 1.1 2013/06/27 16:22:31 aballier Exp $
+
+EAPI=5
+inherit autotools eutils flag-o-matic multilib-minimal
+
+DESCRIPTION="The Theora Video Compression Codec"
+HOMEPAGE="http://www.theora.org"
+SRC_URI="http://downloads.xiph.org/releases/theora/${P/_}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc +encode examples static-libs"
+
+RDEPEND="media-libs/libogg:=[${MULTILIB_USEDEP}]
+ encode? ( media-libs/libvorbis:=[${MULTILIB_USEDEP}] )
+ examples? (
+ media-libs/libpng:0=
+ >=media-libs/libsdl-0.11.0
+ media-libs/libvorbis:=
+ )
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r1
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+REQUIRED_USE="examples? ( encode )" #285895
+
+S=${WORKDIR}/${P/_}
+
+VARTEXFONTS=${T}/fonts
+
+DOCS=( AUTHORS CHANGES README )
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.0_beta2-flags.patch \
+ "${FILESDIR}"/${P}-libpng16.patch #465450
+
+ # bug 467006
+ sed -i "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" configure.ac || die
+
+ AT_M4DIR=m4 eautoreconf
+}
+
+multilib_src_configure() {
+ use x86 && filter-flags -fforce-addr -frename-registers #200549
+ use doc || export ac_cv_prog_HAVE_DOXYGEN=false
+
+ local myconf
+ if [ "${ABI}" = "${DEFAULT_ABI}" ] ; then
+ myconf=" $(use_enable examples)"
+ else
+ # those will be overwritten anyway
+ myconf=" --disable-examples"
+ fi
+
+ # --disable-spec because LaTeX documentation has been prebuilt
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ --disable-spec \
+ $(use_enable encode) \
+ ${myconf}
+}
+
+multilib_src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ install
+
+ if use examples && [ "${ABI}" = "${DEFAULT_ABI}" ]; then
+ if use doc; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.[ch]
+ fi
+
+ dobin examples/.libs/png2theora
+ for bin in dump_{psnr,video} {encoder,player}_example; do
+ newbin examples/.libs/${bin} theora_${bin}
+ done
+ fi
+
+ prune_libtool_files
+}