summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-04 15:56:33 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-04 15:56:33 +0000
commit536adf167e0f67f7c3e9445729aab31493733d95 (patch)
treecc5b33052399993abe205d62ee28c5a24f90f9f9 /media-libs/libsoundtouch
parentStable on amd64/x86 wrt bug #150049. (diff)
downloadgentoo-2-536adf167e0f67f7c3e9445729aab31493733d95.tar.gz
gentoo-2-536adf167e0f67f7c3e9445729aab31493733d95.tar.bz2
gentoo-2-536adf167e0f67f7c3e9445729aab31493733d95.zip
Add check for sse useflag. Thanks to Salah Coronya for reporting and Christian Faulhammer for testing (bug #148695).
(Portage version: 2.1.2_pre2-r3)
Diffstat (limited to 'media-libs/libsoundtouch')
-rw-r--r--media-libs/libsoundtouch/ChangeLog7
-rw-r--r--media-libs/libsoundtouch/libsoundtouch-1.3.1.ebuild16
2 files changed, 18 insertions, 5 deletions
diff --git a/media-libs/libsoundtouch/ChangeLog b/media-libs/libsoundtouch/ChangeLog
index 95104b8cfb54..e47e0f5406f6 100644
--- a/media-libs/libsoundtouch/ChangeLog
+++ b/media-libs/libsoundtouch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libsoundtouch
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsoundtouch/ChangeLog,v 1.8 2006/08/24 06:20:53 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsoundtouch/ChangeLog,v 1.9 2006/10/04 15:56:33 flameeyes Exp $
+
+ 04 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
+ libsoundtouch-1.3.1.ebuild:
+ Add check for sse useflag. Thanks to Salah Coronya for reporting and
+ Christian Faulhammer for testing (bug #148695).
*libsoundtouch-1.3.1 (24 Aug 2006)
diff --git a/media-libs/libsoundtouch/libsoundtouch-1.3.1.ebuild b/media-libs/libsoundtouch/libsoundtouch-1.3.1.ebuild
index 39f3bf83d20c..abbb4fe793b7 100644
--- a/media-libs/libsoundtouch/libsoundtouch-1.3.1.ebuild
+++ b/media-libs/libsoundtouch/libsoundtouch-1.3.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsoundtouch/libsoundtouch-1.3.1.ebuild,v 1.1 2006/08/24 06:20:53 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsoundtouch/libsoundtouch-1.3.1.ebuild,v 1.2 2006/10/04 15:56:33 flameeyes Exp $
-inherit autotools
+inherit autotools toolchain-funcs
-IUSE="static"
+IUSE="static sse"
MY_P="${P/lib}"
@@ -21,6 +21,14 @@ DEPEND="app-arch/unzip"
S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ if [[ $(tc-arch) == "x86" ]] && ! use sse; then
+ eerror "You asked not to use SSE, but this package cannot be compiled on"
+ eerror "your architecture without those instructions enabled."
+ die "We're sorry, but you cannot use this package without SSE."
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"
@@ -39,5 +47,5 @@ src_compile() {
src_install() {
make DESTDIR="${D}" pkgdocdir="/usr/share/doc/${PF}" install || die
- rm -f ${D}/usr/share/doc/${PF}/COPYING.TXT # remove obsolete LICENCE file
+ rm -f ${D}/usr/share/doc/${PF}/COPYING.TXT # remove obsolete LICENCE file
}