summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-10-21 00:34:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-10-21 00:34:03 +0000
commit8e799df8bef7c08e595bd3f9c421389858e43c67 (patch)
tree7806c1d9cf03dfa8748b62513217b298b92e8908 /media-libs/libsdl
parentnew gnome-base/libgnomeui needs masked x11-libs/gtk+ (diff)
downloadgentoo-2-8e799df8bef7c08e595bd3f9c421389858e43c67.tar.gz
gentoo-2-8e799df8bef7c08e595bd3f9c421389858e43c67.tar.bz2
gentoo-2-8e799df8bef7c08e595bd3f9c421389858e43c67.zip
add patch from upstream CVS to fix c++ comments in header file (bug #193404)
(Portage version: 2.1.3.9)
Diffstat (limited to 'media-libs/libsdl')
-rw-r--r--media-libs/libsdl/ChangeLog6
-rw-r--r--media-libs/libsdl/files/libsdl-1.2.12-c90-comments.patch19
-rw-r--r--media-libs/libsdl/libsdl-1.2.12.ebuild3
3 files changed, 26 insertions, 2 deletions
diff --git a/media-libs/libsdl/ChangeLog b/media-libs/libsdl/ChangeLog
index 0a3194f73dd5..67a348b643a1 100644
--- a/media-libs/libsdl/ChangeLog
+++ b/media-libs/libsdl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libsdl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.135 2007/07/23 20:02:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.136 2007/10/21 00:34:02 mr_bones_ Exp $
+
+ 21 Oct 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/libsdl-1.2.12-c90-comments.patch, libsdl-1.2.12.ebuild:
+ add patch from upstream CVS to fix c++ comments in header file (bug #193404)
*libsdl-1.2.12 (23 Jul 2007)
diff --git a/media-libs/libsdl/files/libsdl-1.2.12-c90-comments.patch b/media-libs/libsdl/files/libsdl-1.2.12-c90-comments.patch
new file mode 100644
index 000000000000..cd484c1ffdf3
--- /dev/null
+++ b/media-libs/libsdl/files/libsdl-1.2.12-c90-comments.patch
@@ -0,0 +1,19 @@
+http://bugs.gentoo.org/193404
+
+Revision 3386
+Motified Sun Aug 5 03:21:18 2007 UTC by icculus
+Removed some C++ style comments from the public headers.
+
+--- branches/SDL-1.2/include/begin_code.h 2007/08/03 04:13:03 3385
++++ branches/SDL-1.2/include/begin_code.h 2007/08/05 03:21:18 3386
+@@ -90,8 +90,8 @@
+ #elif !defined(__WINS__)
+ #undef DECLSPEC
+ #define DECLSPEC __declspec(dllexport)
+-#endif //EKA2
+-#endif //__SYMBIAN32__
++#endif /* !EKA2 */
++#endif /* __SYMBIAN32__ */
+
+ /* Force structure packing at 4 byte alignment.
+ This is necessary if the header is included in code which has structure
diff --git a/media-libs/libsdl/libsdl-1.2.12.ebuild b/media-libs/libsdl/libsdl-1.2.12.ebuild
index a02dd145c783..7e91b7bff4de 100644
--- a/media-libs/libsdl/libsdl-1.2.12.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.12.ebuild,v 1.1 2007/07/23 20:02:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.12.ebuild,v 1.2 2007/10/21 00:34:02 mr_bones_ Exp $
inherit flag-o-matic toolchain-funcs eutils libtool
@@ -74,6 +74,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-1.2.11-libcaca-new-api.patch #40224
epatch "${FILESDIR}"/${PN}-1.2.11-sdl-config.patch
epatch "${FILESDIR}"/${PN}-1.2.11-xinerama-head-0.patch #145917
+ epatch "${FILESDIR}"/${P}-c90-comments.patch #193404
./autogen.sh || die "autogen failed"
elibtoolize