summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2004-06-06 19:58:02 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2004-06-06 19:58:02 +0000
commit2e2b0aaea056a7b0ffe3f67be88f5566c0c4b5be (patch)
treed5419fadb117589eb36334e8bfe424d31d4821c1 /media-libs/libmpeg2/files
parentSparc me like a hurricane. (Manifest recommit) (diff)
downloadgentoo-2-2e2b0aaea056a7b0ffe3f67be88f5566c0c4b5be.tar.gz
gentoo-2-2e2b0aaea056a7b0ffe3f67be88f5566c0c4b5be.tar.bz2
gentoo-2-2e2b0aaea056a7b0ffe3f67be88f5566c0c4b5be.zip
Fixed a compilation-error when Altivec is disabled on PowerPC.
Diffstat (limited to 'media-libs/libmpeg2/files')
-rw-r--r--media-libs/libmpeg2/files/altivec-fix-0.4.0b.diff25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-libs/libmpeg2/files/altivec-fix-0.4.0b.diff b/media-libs/libmpeg2/files/altivec-fix-0.4.0b.diff
new file mode 100644
index 000000000000..1f5361396eda
--- /dev/null
+++ b/media-libs/libmpeg2/files/altivec-fix-0.4.0b.diff
@@ -0,0 +1,25 @@
+--- configure.in 2003-12-23 10:14:56.000000000 +0100
++++ /root/configure.in 2004-06-06 02:13:29.182121072 +0200
+@@ -71,9 +71,19 @@
+ AC_CHECK_HEADER([altivec.h],
+ [TRY_CFLAGS="$ARCH_OPT_CFLAGS -maltivec"],
+ [TRY_CFLAGS="$ARCH_OPT_CFLAGS -faltivec"])
+- AC_TRY_CFLAGS([$OPT_CFLAGS $TRY_CFLAGS $CFLAGS],
+- [ARCH_OPT_CFLAGS="$TRY_CFLAGS"
+- AC_DEFINE([ARCH_PPC],,[ppc architecture])]);;
++ CFLAGS="$OPT_CFLAGS"
++ AC_TRY_COMPILE([
++ #ifdef HAVE_ALTIVEC_H
++ #include <altivec.h>
++ #endif
++ ], [
++ vector float v = (vector float) { 0.0, 0.0, 0.0, 0.0 };
++ vec_andc((vector float)v, (vector float)v);
++ ], [ AC_TRY_CFLAGS([$OPT_CFLAGS $TRY_CFLAGS $CFLAGS],
++ [ARCH_OPT_CFLAGS="$TRY_CFLAGS"
++ AC_DEFINE([ARCH_PPC],,[ppc architecture])])
++ ] )
++ ;;
+ sparc-* | sparc64-*)
+ AC_DEFINE([ARCH_SPARC],,[sparc architecture])
+ TRY_CFLAGS="$OPT_CFLAGS -mcpu=ultrasparc -mvis"