summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-09-17 21:38:13 +0000
committerTim Harder <radhermit@gentoo.org>2013-09-17 21:38:13 +0000
commit42c10ede84bed6d7b3fc210d5794a285fe6c4ebd (patch)
tree8a5294f8ec31b218a774e37db6afa59cebf6ac41 /media-libs/libmatroska
parentSecurity bump wrt bug 308033. (diff)
downloadgentoo-2-42c10ede84bed6d7b3fc210d5794a285fe6c4ebd.tar.gz
gentoo-2-42c10ede84bed6d7b3fc210d5794a285fe6c4ebd.tar.bz2
gentoo-2-42c10ede84bed6d7b3fc210d5794a285fe6c4ebd.zip
Version bump.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-libs/libmatroska')
-rw-r--r--media-libs/libmatroska/ChangeLog8
-rw-r--r--media-libs/libmatroska/files/libmatroska-1.4.1-flags.patch11
-rw-r--r--media-libs/libmatroska/libmatroska-1.4.1.ebuild49
3 files changed, 67 insertions, 1 deletions
diff --git a/media-libs/libmatroska/ChangeLog b/media-libs/libmatroska/ChangeLog
index a3a2d1d02071..4348c8042934 100644
--- a/media-libs/libmatroska/ChangeLog
+++ b/media-libs/libmatroska/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libmatroska
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmatroska/ChangeLog,v 1.109 2013/03/21 09:11:22 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmatroska/ChangeLog,v 1.110 2013/09/17 21:38:13 radhermit Exp $
+
+*libmatroska-1.4.1 (17 Sep 2013)
+
+ 17 Sep 2013; Tim Harder <radhermit@gentoo.org> +libmatroska-1.4.1.ebuild,
+ +files/libmatroska-1.4.1-flags.patch:
+ Version bump.
*libmatroska-1.4.0 (21 Mar 2013)
diff --git a/media-libs/libmatroska/files/libmatroska-1.4.1-flags.patch b/media-libs/libmatroska/files/libmatroska-1.4.1-flags.patch
new file mode 100644
index 000000000000..1b00cd23440c
--- /dev/null
+++ b/media-libs/libmatroska/files/libmatroska-1.4.1-flags.patch
@@ -0,0 +1,11 @@
+--- libmatroska-release-1.4.1/make/linux/Makefile
++++ libmatroska-release-1.4.1/make/linux/Makefile
+@@ -104,7 +104,7 @@
+ $(RANLIB) $@
+
+ $(LIBRARY_SO): $(objects_so)
+- $(CXX) -shared -Wl,-soname,$(LIBRARY_SO_VER) -o $(LIBRARY_SO_VER) $(objects_so) -lebml
++ $(CXX) $(LINKFLAGS) -shared -Wl,-soname,$(LIBRARY_SO_VER) -o $(LIBRARY_SO_VER) $(objects_so) -lebml
+ rm -f $(LIBRARY_SO)
+ ln -s $(LIBRARY_SO_VER) $(LIBRARY_SO)
+
diff --git a/media-libs/libmatroska/libmatroska-1.4.1.ebuild b/media-libs/libmatroska/libmatroska-1.4.1.ebuild
new file mode 100644
index 000000000000..668737323bcb
--- /dev/null
+++ b/media-libs/libmatroska/libmatroska-1.4.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmatroska/libmatroska-1.4.1.ebuild,v 1.1 2013/09/17 21:38:13 radhermit Exp $
+
+EAPI=5
+
+inherit flag-o-matic eutils multilib toolchain-funcs
+
+DESCRIPTION="Extensible multimedia container format based on EBML"
+HOMEPAGE="http://www.matroska.org/ https://github.com/Matroska-Org/libmatroska/"
+SRC_URI="https://github.com/Matroska-Org/libmatroska/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/6" # subslot = soname major version
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-linux"
+IUSE="static-libs"
+RESTRICT="test"
+
+DEPEND=">=dev-libs/libebml-1.3.0:="
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}-release-${PV}/make/linux
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-flags.patch
+}
+
+src_compile() {
+ local targets="sharedlib"
+ use static-libs && targets+=" staticlib"
+
+ #fixes locale for gcc3.4.0 to close bug 52385
+ append-flags $(test-flags -finput-charset=ISO8859-15)
+
+ emake PREFIX="${EPREFIX}"/usr \
+ LIBEBML_INCLUDE_DIR="${EPREFIX}"/usr/include/ebml \
+ LIBEBML_LIB_DIR="${EPREFIX}"/usr/$(get_libdir) \
+ CXX="$(tc-getCXX)" \
+ AR="$(tc-getAR)" \
+ ${targets}
+}
+
+src_install() {
+ local targets="install_sharedlib install_headers"
+ use static-libs && targets+=" install_staticlib"
+
+ emake DESTDIR="${D}" prefix="${EPREFIX}"/usr libdir="${EPREFIX}"/usr/$(get_libdir) ${targets}
+ dodoc "${WORKDIR}"/${PN}-release-${PV}/ChangeLog
+}