summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2009-04-26 16:02:08 +0000
committerOlivier Crête <tester@gentoo.org>2009-04-26 16:02:08 +0000
commitedb02b0e5328c83a482b38a60a01729d7a55c0e8 (patch)
tree9a9566c963756a9835a9b14d5d531ca5ddd810b3 /media-libs/libgpod
parentstable amd64/sparc, bug 267439 (diff)
downloadgentoo-2-edb02b0e5328c83a482b38a60a01729d7a55c0e8.tar.gz
gentoo-2-edb02b0e5328c83a482b38a60a01729d7a55c0e8.tar.bz2
gentoo-2-edb02b0e5328c83a482b38a60a01729d7a55c0e8.zip
Version bump, always require hal (it does not build without it), recommend GTK+ (for artwork support)
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libgpod')
-rw-r--r--media-libs/libgpod/ChangeLog9
-rw-r--r--media-libs/libgpod/libgpod-0.7.2.ebuild42
-rw-r--r--media-libs/libgpod/metadata.xml3
3 files changed, 53 insertions, 1 deletions
diff --git a/media-libs/libgpod/ChangeLog b/media-libs/libgpod/ChangeLog
index 2aafbf86a54b..306a991c39b2 100644
--- a/media-libs/libgpod/ChangeLog
+++ b/media-libs/libgpod/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/libgpod
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/ChangeLog,v 1.57 2009/03/29 01:23:36 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/ChangeLog,v 1.58 2009/04/26 16:02:08 tester Exp $
+
+*libgpod-0.7.2 (26 Apr 2009)
+
+ 26 Apr 2009; Olivier Crête <tester@gentoo.org> metadata.xml,
+ +libgpod-0.7.2.ebuild:
+ Version bump, always require hal (it does not build without it), recommend
+ GTK+ (for artwork support)
29 Mar 2009; Olivier Crête <tester@gentoo.org> libgpod-0.7.0.ebuild:
Always require pygobject if python bindings are required, really fixes bug
diff --git a/media-libs/libgpod/libgpod-0.7.2.ebuild b/media-libs/libgpod/libgpod-0.7.2.ebuild
new file mode 100644
index 000000000000..07d9922e5815
--- /dev/null
+++ b/media-libs/libgpod/libgpod-0.7.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/libgpod-0.7.2.ebuild,v 1.1 2009/04/26 16:02:08 tester Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Shared library to access the contents of an iPod"
+HOMEPAGE="http://www.gtkpod.org/libgpod.html"
+SRC_URI="mirror://sourceforge/gtkpod/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+gtk python test"
+
+RDEPEND=">=dev-libs/glib-2.16
+ sys-apps/sg3_utils
+ dev-libs/libxml2
+ =sys-apps/hal-0.5*
+ gtk? ( >=x11-libs/gtk+-2.6 )
+ python? ( >=dev-lang/python-2.3
+ >=media-libs/mutagen-1.8
+ >=dev-python/pygobject-2.8 )
+ test? ( media-libs/taglib )"
+DEPEND="${RDEPEND}
+ python? ( >=dev-lang/swig-1.3.24 )
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --with-hal \
+ $(use_enable gtk gdk-pixbuf) \
+ $(use_enable python pygobject) \
+ $(use_with python) || die "configure failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc README TROUBLESHOOTING AUTHORS NEWS README.SysInfo
+}
diff --git a/media-libs/libgpod/metadata.xml b/media-libs/libgpod/metadata.xml
index 10d90693498d..b793b2668a2a 100644
--- a/media-libs/libgpod/metadata.xml
+++ b/media-libs/libgpod/metadata.xml
@@ -10,4 +10,7 @@
libgpod is a shared library to access the contents of an iPod. This
library is based on code used in the gtkpod project.
</longdescription>
+ <use>
+ <flag name="gtk">Enables ArtWorkDB support (including Photos and album covers)</flag>
+ </use>
</pkgmetadata>