summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-12-27 17:11:47 +0000
committerJeremy Olexa <darkside@gentoo.org>2008-12-27 17:11:47 +0000
commite6da288d15e0efbdf2a09df8a2848d7c6a3b497f (patch)
tree4d15ed8222c96d926192d79c4972cf2797d35269 /media-libs/hamlib
parentAdd note to configure a default mail storage location when using maildir (#24... (diff)
downloadgentoo-2-e6da288d15e0efbdf2a09df8a2848d7c6a3b497f.tar.gz
gentoo-2-e6da288d15e0efbdf2a09df8a2848d7c6a3b497f.tar.bz2
gentoo-2-e6da288d15e0efbdf2a09df8a2848d7c6a3b497f.zip
Add patch to allow hamlib to use the system libltdl instead of a bundled one, patch by Thomas Beierlein. bug 252326
(Portage version: 2.2_rc19/cvs/Linux 2.6.27.10 x86_64)
Diffstat (limited to 'media-libs/hamlib')
-rw-r--r--media-libs/hamlib/ChangeLog9
-rw-r--r--media-libs/hamlib/files/hamlib-ltdl.diff36
-rw-r--r--media-libs/hamlib/hamlib-1.2.8-r1.ebuild (renamed from media-libs/hamlib/hamlib-1.2.8.ebuild)19
3 files changed, 55 insertions, 9 deletions
diff --git a/media-libs/hamlib/ChangeLog b/media-libs/hamlib/ChangeLog
index e6acf353a94e..16d1150d9d4b 100644
--- a/media-libs/hamlib/ChangeLog
+++ b/media-libs/hamlib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/hamlib
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/ChangeLog,v 1.29 2008/12/04 17:58:18 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/ChangeLog,v 1.30 2008/12/27 17:11:47 darkside Exp $
+
+*hamlib-1.2.8-r1 (27 Dec 2008)
+
+ 27 Dec 2008; Jeremy Olexa <darkside@gentoo.org> +files/hamlib-ltdl.diff,
+ -hamlib-1.2.8.ebuild, +hamlib-1.2.8-r1.ebuild:
+ Add patch to allow hamlib to use the system libltdl instead of a bundled
+ one, patch by Thomas Beierlein. bug 252326
*hamlib-1.2.8 (04 Dec 2008)
diff --git a/media-libs/hamlib/files/hamlib-ltdl.diff b/media-libs/hamlib/files/hamlib-ltdl.diff
new file mode 100644
index 000000000000..4bf14ac1189e
--- /dev/null
+++ b/media-libs/hamlib/files/hamlib-ltdl.diff
@@ -0,0 +1,36 @@
+--- Makefile.am.orig 2008-12-27 15:31:15.000000000 +0100
++++ Makefile.am 2008-12-27 15:31:47.000000000 +0100
+@@ -10,11 +10,11 @@
+ README.betatester README.win32 hamlib.spec
+
+ # BINDINGS_LIST subdirs are no longer built
+-SUBDIRS = macros include lib libltdl src @BACKEND_LIST@ @ROT_BACKEND_LIST@ \
++SUBDIRS = macros include lib src @BACKEND_LIST@ @ROT_BACKEND_LIST@ \
+ @BINDINGS@ tests doc
+
+ # tcl, perl, and kylix subdirs are no longer distributed
+-DIST_SUBDIRS = macros include lib libltdl src c++ bindings tests doc \
++DIST_SUBDIRS = macros include lib src c++ bindings tests doc \
+ icom kenwood aor yaesu dummy pcr alinco uniden tentec kachina jrc \
+ rpcrig winradio easycomm fodtrack rpcrot gnuradio drake rotorez \
+ flexradio sartek lowe rft tapr kit skanti wj racal tuner \
+--- configure.ac.orig 2008-12-27 12:59:03.000000000 +0100
++++ configure.ac 2008-12-27 12:59:48.000000000 +0100
+@@ -174,7 +174,7 @@
+ ## ------------------------ ##
+ dnl Enable building of the convenience library
+ dnl and set LIBLTDL accordingly
+-AC_LIBLTDL_CONVENIENCE
++AC_LIBLTDL_INSTALLABLE
+ dnl Substitute INCLTDL and LIBLTDL in the Makefiles
+ AC_SUBST([INCLTDL])
+ AC_SUBST([LIBLTDL])
+@@ -187,7 +187,7 @@
+ AC_SUBST([LIBTOOL_DEPS])
+ AC_LIB_LTDL
+ dnl Configure libltdl
+-AC_CONFIG_SUBDIRS(libltdl)
++#AC_CONFIG_SUBDIRS(libltdl)
+
+ case "$host_os" in
+ darwin* | rhapsody*)
diff --git a/media-libs/hamlib/hamlib-1.2.8.ebuild b/media-libs/hamlib/hamlib-1.2.8-r1.ebuild
index 9c94e3a287a7..45031f0f290d 100644
--- a/media-libs/hamlib/hamlib-1.2.8.ebuild
+++ b/media-libs/hamlib/hamlib-1.2.8-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/hamlib-1.2.8.ebuild,v 1.1 2008/12/04 17:58:18 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/hamlib-1.2.8-r1.ebuild,v 1.1 2008/12/27 17:11:47 darkside Exp $
-inherit eutils multilib libtool
+inherit autotools eutils libtool multilib
DESCRIPTION="Ham radio backend rig control libraries"
HOMEPAGE="http://hamlib.sourceforge.net/"
@@ -16,12 +16,13 @@ IUSE="doc python tcl"
RESTRICT="test"
RDEPEND="virtual/libc
+ >=sys-devel/libtool-1.5
+ dev-libs/libusb
python? ( dev-lang/python
dev-lang/tcl )
tcl? ( dev-lang/tcl )"
DEPEND=" ${RDEPEND}
- >=sys-devel/libtool-1.5
>=dev-util/pkgconfig-0.15
>=dev-lang/swig-1.3.14
dev-libs/libxml2
@@ -31,17 +32,19 @@ src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${PN}-pkgconfig-fix.diff
-
- # Needed for FreeBSD - Please do not remove
- elibtoolize
+ epatch "${FILESDIR}"/${PN}-pkgconfig-fix.diff \
+ "${FILESDIR}"/${PN}-ltdl.diff
+
+ # remove bundled libltdl copy
+ rm -rf libltdl
+
+ eautoreconf
}
src_compile() {
econf \
--libdir=/usr/$(get_libdir)/hamlib \
--disable-static \
- --with-microtune \
--with-rpc-backends \
--without-perl-binding \
$(use_with python python-binding) \