summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-07-23 08:36:44 +0000
committerMichał Górny <mgorny@gentoo.org>2013-07-23 08:36:44 +0000
commit140446aec83452b92e02a81135a68a219bee1421 (patch)
treeadf36ef86da363fa0af912b86682f916484b94ad /media-libs/glu
parentMask the new media-libs/glu multilib revbump. (diff)
downloadgentoo-2-140446aec83452b92e02a81135a68a219bee1421.tar.gz
gentoo-2-140446aec83452b92e02a81135a68a219bee1421.tar.bz2
gentoo-2-140446aec83452b92e02a81135a68a219bee1421.zip
Switch to autotools-multilib for USE-flag-based multilib support.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'media-libs/glu')
-rw-r--r--media-libs/glu/ChangeLog7
-rw-r--r--media-libs/glu/glu-9.0.0-r1.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/media-libs/glu/ChangeLog b/media-libs/glu/ChangeLog
index acc722bb9b5a..a0c1a43414c1 100644
--- a/media-libs/glu/ChangeLog
+++ b/media-libs/glu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/glu
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/glu/ChangeLog,v 1.15 2013/03/03 11:51:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/glu/ChangeLog,v 1.16 2013/07/23 08:36:44 mgorny Exp $
+
+*glu-9.0.0-r1 (23 Jul 2013)
+
+ 23 Jul 2013; Michał Górny <mgorny@gentoo.org> +glu-9.0.0-r1.ebuild:
+ Switch to autotools-multilib for USE-flag-based multilib support.
03 Mar 2013; Mike Frysinger <vapier@gentoo.org> glu-9.0.0.ebuild:
Add s390 lovin.
diff --git a/media-libs/glu/glu-9.0.0-r1.ebuild b/media-libs/glu/glu-9.0.0-r1.ebuild
new file mode 100644
index 000000000000..a88f7fc19562
--- /dev/null
+++ b/media-libs/glu/glu-9.0.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/glu/glu-9.0.0-r1.ebuild,v 1.1 2013/07/23 08:36:44 mgorny Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/mesa/glu"
+
+if [[ ${PV} = 9999* ]]; then
+ AUTOTOOLS_AUTORECONF=1
+ GIT_ECLASS="git-2"
+ EXPERIMENTAL="true"
+fi
+
+inherit autotools-multilib multilib ${GIT_ECLASS}
+
+DESCRIPTION="The OpenGL Utility Library"
+HOMEPAGE="http://cgit.freedesktop.org/mesa/glu/"
+
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="ftp://ftp.freedesktop.org/pub/mesa/${PN}/${P}.tar.bz2"
+fi
+
+LICENSE="SGI-B-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+DEPEND="virtual/opengl"
+RDEPEND="${DEPEND}
+ !<media-libs/mesa-9
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-opengl-20130224 )"
+
+src_unpack() {
+ default
+ [[ $PV = 9999* ]] && git-2_src_unpack
+}
+
+src_test() {
+ :;
+}