summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-05-01 16:22:03 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-05-01 16:22:03 +0000
commit62e60589f8c7776b1494b3b35142693206b7f925 (patch)
tree60d75bf51af9ddf9a14cc1de58182b86291b5636 /media-libs/gegl
parentAdd libcanberra-0.28-r1 from the gnome overlay (diff)
downloadgentoo-2-62e60589f8c7776b1494b3b35142693206b7f925.tar.gz
gentoo-2-62e60589f8c7776b1494b3b35142693206b7f925.tar.bz2
gentoo-2-62e60589f8c7776b1494b3b35142693206b7f925.zip
Add patch to compile even with latest ffmpeg api.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/gegl')
-rw-r--r--media-libs/gegl/ChangeLog6
-rw-r--r--media-libs/gegl/files/0.1.6-ffmpeg.patch30
-rw-r--r--media-libs/gegl/gegl-0.1.6.ebuild5
3 files changed, 39 insertions, 2 deletions
diff --git a/media-libs/gegl/ChangeLog b/media-libs/gegl/ChangeLog
index 0833cd09c74c..94eb63bf8e14 100644
--- a/media-libs/gegl/ChangeLog
+++ b/media-libs/gegl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/gegl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gegl/ChangeLog,v 1.51 2011/04/23 17:59:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gegl/ChangeLog,v 1.52 2011/05/01 16:22:03 scarabeus Exp $
+
+ 01 May 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/0.1.6-ffmpeg.patch, gegl-0.1.6.ebuild:
+ Add patch to compile even with latest ffmpeg api.
23 Apr 2011; Raúl Porcel <armin76@gentoo.org> gegl-0.1.6.ebuild:
alpha/ia64/sparc stable wrt #360595
diff --git a/media-libs/gegl/files/0.1.6-ffmpeg.patch b/media-libs/gegl/files/0.1.6-ffmpeg.patch
new file mode 100644
index 000000000000..98169c721b0c
--- /dev/null
+++ b/media-libs/gegl/files/0.1.6-ffmpeg.patch
@@ -0,0 +1,30 @@
+diff -urN gegl-0.1.6.old/operations/external/ff-load.c gegl-0.1.6/operations/external/ff-load.c
+--- gegl-0.1.6.old/operations/external/ff-load.c 2011-05-01 18:10:42.000000000 +0200
++++ gegl-0.1.6/operations/external/ff-load.c 2011-05-01 18:15:58.000000000 +0200
+@@ -69,7 +69,7 @@
+ {
+ switch (err)
+ {
+- case AVERROR_NUMEXPECTED:
++ case AVERROR(EINVAL):
+ g_warning ("%s: Incorrect image filename syntax.\n"
+ "Use '%%d' to specify the image number:\n"
+ " for img1.jpg, img2.jpg, ..., use 'img%%d.jpg';\n"
+@@ -79,7 +79,7 @@
+ case AVERROR_INVALIDDATA:
+ g_warning ("%s: Error while parsing header\n", filename);
+ break;
+- case AVERROR_NOFMT:
++ case AVERROR(EILSEQ):
+ g_warning ("%s: Unknown format\n", filename);
+ break;
+ default:
+@@ -278,7 +278,7 @@
+ for (i = 0; i< p->ic->nb_streams; i++)
+ {
+ AVCodecContext *c = p->ic->streams[i]->codec;
+- if (c->codec_type == CODEC_TYPE_VIDEO)
++ if (c->codec_type == AVMEDIA_TYPE_VIDEO)
+ {
+ p->video_st = p->ic->streams[i];
+ p->video_stream = i;
diff --git a/media-libs/gegl/gegl-0.1.6.ebuild b/media-libs/gegl/gegl-0.1.6.ebuild
index f745b215212a..fab48f0eb2a4 100644
--- a/media-libs/gegl/gegl-0.1.6.ebuild
+++ b/media-libs/gegl/gegl-0.1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gegl/gegl-0.1.6.ebuild,v 1.15 2011/04/23 17:59:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gegl/gegl-0.1.6.ebuild,v 1.16 2011/05/01 16:22:03 scarabeus Exp $
EAPI=4
@@ -47,6 +47,9 @@ src_prepare() {
# https://bugzilla.gnome.org/show_bug.cgi?id=642494
epatch "${FILESDIR}"/gegl-doubledestdir.diff
+ # new ffmpeg api
+ epatch "${FILESDIR}/${PV}-ffmpeg.patch"
+
# fix OSX loadable module filename extension
sed -i -e 's/\.dylib/.bundle/' configure.ac || die
eautoreconf