summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-04-11 02:12:48 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-04-11 02:12:48 +0000
commitcc06497dcd53db8838a8587e71a8b9b7ca520c20 (patch)
treeb6947b1d9dfe4506128c3fdc3352bb0c9be6ef3b /media-libs/fontconfig
parentVersion bump to 3.7.3, adding media-gfx/graphicsmagick to the deps. (diff)
downloadgentoo-2-cc06497dcd53db8838a8587e71a8b9b7ca520c20.tar.gz
gentoo-2-cc06497dcd53db8838a8587e71a8b9b7ca520c20.tar.bz2
gentoo-2-cc06497dcd53db8838a8587e71a8b9b7ca520c20.zip
- Add alias for ZapfDingbats to fix display of some pdfs in poppler-based
readers. (bug #303591 by Rafał Mużyło, thanks to Paul Bredbury) - Add virtual/ttf-fonts to PDEPEND. (bug #260019 by Doruk Fisek) (Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/fontconfig')
-rw-r--r--media-libs/fontconfig/ChangeLog10
-rw-r--r--media-libs/fontconfig/files/fontconfig-2.8.0-urw-aliases.patch18
-rw-r--r--media-libs/fontconfig/fontconfig-2.8.0-r1.ebuild129
3 files changed, 156 insertions, 1 deletions
diff --git a/media-libs/fontconfig/ChangeLog b/media-libs/fontconfig/ChangeLog
index b9a7ceccdaa6..89f818c1a129 100644
--- a/media-libs/fontconfig/ChangeLog
+++ b/media-libs/fontconfig/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/fontconfig
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.146 2010/04/11 01:00:59 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.147 2010/04/11 02:12:48 dirtyepic Exp $
+
+*fontconfig-2.8.0-r1 (11 Apr 2010)
+
+ 11 Apr 2010; Ryan Hill <dirtyepic@gentoo.org> +fontconfig-2.8.0-r1.ebuild,
+ +files/fontconfig-2.8.0-urw-aliases.patch:
+ - Add alias for ZapfDingbats to fix display of some pdfs in poppler-based
+ readers. (bug #303591 by Rafał Mużyło, thanks to Paul Bredbury)
+ - Add virtual/ttf-fonts to PDEPEND. (bug #260019 by Doruk Fisek)
11 Apr 2010; Ryan Hill <dirtyepic@gentoo.org> -fontconfig-2.5.0-r1.ebuild,
-files/fontconfig-2.5.0-libtool-2.2.patch, -fontconfig-2.7.1-r1.ebuild,
diff --git a/media-libs/fontconfig/files/fontconfig-2.8.0-urw-aliases.patch b/media-libs/fontconfig/files/fontconfig-2.8.0-urw-aliases.patch
new file mode 100644
index 000000000000..76a4aaafb0ce
--- /dev/null
+++ b/media-libs/fontconfig/files/fontconfig-2.8.0-urw-aliases.patch
@@ -0,0 +1,18 @@
+http://bugs.freedesktop.org/19128
+http://bugs.gentoo.org/303591
+http://bugzilla.redhat.com/468565
+http://bugzilla.gnome.org/502664
+
+--- a/conf.d/30-urw-aliases.conf
++++ b/conf.d/30-urw-aliases.conf
+@@ -29,6 +29,10 @@
+ <family>Zapf Dingbats</family>
+ <accept><family>Dingbats</family></accept>
+ </alias>
++ <alias binding="same">
++ <family>ZapfDingbats</family>
++ <accept><family>Dingbats</family></accept>
++ </alias>
+ <match target="pattern">
+ <test name="family">
+ <string>Symbol</string>
diff --git a/media-libs/fontconfig/fontconfig-2.8.0-r1.ebuild b/media-libs/fontconfig/fontconfig-2.8.0-r1.ebuild
new file mode 100644
index 000000000000..643a0e15be5d
--- /dev/null
+++ b/media-libs/fontconfig/fontconfig-2.8.0-r1.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.8.0-r1.ebuild,v 1.1 2010/04/11 02:12:48 dirtyepic Exp $
+
+EAPI="2"
+
+inherit autotools eutils libtool toolchain-funcs flag-o-matic
+
+DESCRIPTION="A library for configuring and customizing font access"
+HOMEPAGE="http://fontconfig.org/"
+SRC_URI="http://fontconfig.org/release/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="doc"
+
+# Purposefully dropped the xml USE flag and libxml2 support. Expat is the
+# default and used by every distro. See bug #283191.
+
+RDEPEND=">=media-libs/freetype-2.2.1
+ >=dev-libs/expat-1.95.3"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? (
+ app-text/docbook-sgml-utils[jadetex]
+ =app-text/docbook-sgml-dtd-3.1*
+ )"
+PDEPEND="app-admin/eselect-fontconfig
+ virtual/ttf-fonts"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.7.1-latin-reorder.patch # 130466
+ epatch "${FILESDIR}"/${PN}-2.3.2-docbook.patch # 310157
+ epatch "${FILESDIR}"/${PN}-2.8.0-urw-aliases.patch # 303591
+
+ eautoreconf
+
+ # Needed to get a sane .so versioning on fbsd, please dont drop
+ # If you have to run eautoreconf, you can also leave the elibtoolize call as
+ # it will be a no-op.
+ elibtoolize
+}
+
+src_configure() {
+ local myconf
+ if tc-is-cross-compiler; then
+ myconf="--with-arch=${ARCH}"
+ replace-flags -mtune=* -DMTUNE_CENSORED
+ replace-flags -march=* -DMARCH_CENSORED
+ fi
+ econf \
+ $(use_enable doc docs) \
+ $(use_enable doc docbook) \
+ --localstatedir=/var \
+ --with-default-fonts=/usr/share/fonts \
+ --with-add-fonts=/usr/local/share/fonts \
+ ${myconf} || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install"
+ emake DESTDIR="${D}" -C doc install-man || die "emake install-man"
+
+ #fc-lang directory contains language coverage datafiles
+ #which are needed to test the coverage of fonts.
+ insinto /usr/share/fc-lang
+ doins fc-lang/*.orth
+
+ insinto /etc/fonts
+ doins "${S}"/fonts.conf
+
+ dodoc doc/fontconfig-user.{txt,pdf}
+ dodoc AUTHORS ChangeLog README
+
+ if [[ -e ${D}usr/share/doc/fontconfig/ ]]; then
+ mv "${D}"usr/share/doc/fontconfig/* "${D}"/usr/share/doc/${P}
+ rm -rf "${D}"usr/share/doc/fontconfig
+ fi
+
+ # Changes should be made to /etc/fonts/local.conf, and as we had
+ # too much problems with broken fonts.conf, we force update it ...
+ # <azarah@gentoo.org> (11 Dec 2002)
+ echo 'CONFIG_PROTECT_MASK="/etc/fonts/fonts.conf"' > "${T}"/37fontconfig
+ doenvd "${T}"/37fontconfig
+
+ # As of fontconfig 2.7, everything sticks their noses in here.
+ dodir /etc/sandbox.d
+ echo 'SANDBOX_PREDICT="/var/cache/fontconfig"' > "${D}"/etc/sandbox.d/37fontconfig
+}
+
+pkg_preinst() {
+ # Bug #193476
+ # /etc/fonts/conf.d/ contains symlinks to ../conf.avail/ to include various
+ # config files. If we install as-is, we'll blow away user settings.
+ ebegin "Syncing fontconfig configuration to system"
+ if [[ -e ${ROOT}/etc/fonts/conf.d ]]; then
+ for file in "${ROOT}"/etc/fonts/conf.avail/*; do
+ f=${file##*/}
+ if [[ -L ${ROOT}/etc/fonts/conf.d/${f} ]]; then
+ [[ -f ${D}etc/fonts/conf.avail/${f} ]] \
+ && ln -sf ../conf.avail/"${f}" "${D}"etc/fonts/conf.d/ &>/dev/null
+ else
+ [[ -f ${D}etc/fonts/conf.avail/${f} ]] \
+ && rm "${D}"etc/fonts/conf.d/"${f}" &>/dev/null
+ fi
+ done
+ fi
+ eend $?
+}
+
+pkg_postinst() {
+ einfo "Cleaning broken symlinks in "${ROOT}"etc/fonts/conf.d/"
+ find -L "${ROOT}"etc/fonts/conf.d/ -type l -delete
+
+ echo
+ ewarn "Please make fontconfig configuration changes using \`eselect fontconfig\`"
+ ewarn "Any changes made to /etc/fonts/fonts.conf will be overwritten."
+ ewarn
+ ewarn "If you need to reset your configuration to upstream defaults, delete"
+ ewarn "the directory ${ROOT}etc/fonts/conf.d/ and re-emerge fontconfig."
+ echo
+
+ if [[ ${ROOT} = / ]]; then
+ ebegin "Creating global font cache"
+ /usr/bin/fc-cache -srf
+ eend $?
+ fi
+}