summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJungmin Seo <seo@gentoo.org>2003-03-12 19:48:03 +0000
committerJungmin Seo <seo@gentoo.org>2003-03-12 19:48:03 +0000
commit82a5633ace98e4b3e5804feb166d17bacfc11a50 (patch)
tree0c17c32491691e2ac196aa9a18e9039de21dfabf /media-libs/fontconfig
parentbump (diff)
downloadgentoo-2-82a5633ace98e4b3e5804feb166d17bacfc11a50.tar.gz
gentoo-2-82a5633ace98e4b3e5804feb166d17bacfc11a50.tar.bz2
gentoo-2-82a5633ace98e4b3e5804feb166d17bacfc11a50.zip
added a patch for cjk
Diffstat (limited to 'media-libs/fontconfig')
-rw-r--r--media-libs/fontconfig/ChangeLog9
-rw-r--r--media-libs/fontconfig/files/patch/fontconfig-2.1-fixedwidth.patch52
-rw-r--r--media-libs/fontconfig/fontconfig-2.1-r1.ebuild4
3 files changed, 63 insertions, 2 deletions
diff --git a/media-libs/fontconfig/ChangeLog b/media-libs/fontconfig/ChangeLog
index 802d33ddff9c..fef61624378b 100644
--- a/media-libs/fontconfig/ChangeLog
+++ b/media-libs/fontconfig/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for media-libs/fontconfig
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.20 2003/03/12 19:07:02 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.21 2003/03/12 19:48:03 seo Exp $
08 Feb 2003; Jason Wever <weeve@gentoo.org> fontconfig-2.1-r1.ebuild :
Changed ~sparc keyword to sparc
@@ -16,6 +16,13 @@
*fontconfig-2.1-r1 (23 Dec 2002)
+ 12 Mar 2003; Jungmin Seo <seo@gentoo.org> fontconfig-2.1-r1.ebuild,
+ files/patch/fontconfig-2.1-fixedwidth.patch:
+
+ the patch fixes a font fixedwith bug, it has been applied in cvs,
+ so not required for the next version. Thanks to ganadist@mizi.com for
+ the patch.
+
12 Mar 2003; Zach Welch <zwelch@gentoo.org> fontconfig-2.1-r1.ebuild:
add arm keyword
diff --git a/media-libs/fontconfig/files/patch/fontconfig-2.1-fixedwidth.patch b/media-libs/fontconfig/files/patch/fontconfig-2.1-fixedwidth.patch
new file mode 100644
index 000000000000..1228d36170c5
--- /dev/null
+++ b/media-libs/fontconfig/files/patch/fontconfig-2.1-fixedwidth.patch
@@ -0,0 +1,52 @@
+diff -u -r1.18 -r1.20
+--- fontconfig/fonts.conf.in 2003/02/24 17:18:50 1.18
++++ fontconfig/fonts.conf.in 2003/02/27 08:12:13 1.20
+@@ -140,6 +140,31 @@
+ </match>
+
+ <!--
++ Some Asian fonts misadvertise themselves as monospaced when
++ in fact they are dual-spaced (half and full). This makes
++ FreeType very confused as it forces all widths to match.
++ Undo this magic by disabling the width forcing code -->
++ <match target="font">
++ <test name="family"><string>GulimChe</string></test>
++ <edit name="globaladvance"><bool>false</bool></edit>
++ </match>
++
++ <match target="font">
++ <test name="family"><string>DotumChe</string></test>
++ <edit name="globaladvance"><bool>false</bool></edit>
++ </match>
++
++ <match target="font">
++ <test name="family"><string>BatangChe</string></test>
++ <edit name="globaladvance"><bool>false</bool></edit>
++ </match>
++
++ <match target="font">
++ <test name="family"><string>GungsuhChe</string></test>
++ <edit name="globaladvance"><bool>false</bool></edit>
++ </match>
++
++<!--
+ Load per-user customization file
+ -->
+ <include ignore_missing="yes">~/.fonts.conf</include>
+diff -u -r1.13 -r1.14
+--- fontconfig/src/fcfreetype.c 2003/02/06 17:46:06 1.13
++++ fontconfig/src/fcfreetype.c 2003/02/27 07:04:59 1.14
+@@ -467,7 +467,12 @@
+ if (!FcPatternAddString (pat, FC_SOURCE, (FcChar8 *) "FreeType"))
+ goto bail1;
+
+-#if 1
++#if 0
++ /*
++ * don't even try this -- CJK 'monospace' fonts are really
++ * dual width, and most other fonts don't bother to set
++ * the attribute. Sigh.
++ */
+ if ((face->face_flags & FT_FACE_FLAG_FIXED_WIDTH) != 0)
+ if (!FcPatternAddInteger (pat, FC_SPACING, FC_MONO))
+ goto bail1;
diff --git a/media-libs/fontconfig/fontconfig-2.1-r1.ebuild b/media-libs/fontconfig/fontconfig-2.1-r1.ebuild
index 5da0ceb12154..45ccab8a328e 100644
--- a/media-libs/fontconfig/fontconfig-2.1-r1.ebuild
+++ b/media-libs/fontconfig/fontconfig-2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.1-r1.ebuild,v 1.8 2003/03/12 19:07:02 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.1-r1.ebuild,v 1.9 2003/03/12 19:48:03 seo Exp $
inherit debug eutils
@@ -40,6 +40,8 @@ src_unpack() {
epatch ${PPREFIX}-0.0.1.020826.1330-blacklist.patch
# Fix config script to alway include X11 fontpath and remove date
epatch ${PPREFIX}-${PV}-x11fontpath-date-configure-v2.patch
+ # fix font width bug with cjk fonts
+ epatch ${PPREFIX}-${PV}-fixedwidth.patch
}
src_compile() {