summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Peterson <lavajoe@gentoo.org>2008-05-08 12:08:06 +0000
committerJoe Peterson <lavajoe@gentoo.org>2008-05-08 12:08:06 +0000
commit1edc18863969ef99b3eba9a152607822999ffc63 (patch)
tree0097dc346b20401988a95b68ca10b33747dab1d3 /media-libs/faad2
parentNew version (diff)
downloadgentoo-2-1edc18863969ef99b3eba9a152607822999ffc63.tar.gz
gentoo-2-1edc18863969ef99b3eba9a152607822999ffc63.tar.bz2
gentoo-2-1edc18863969ef99b3eba9a152607822999ffc63.zip
Patched to detect writes to a broken pipe (bug #204227)
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-libs/faad2')
-rw-r--r--media-libs/faad2/ChangeLog8
-rw-r--r--media-libs/faad2/faad2-2.6.1-r1.ebuild52
-rw-r--r--media-libs/faad2/files/faad2-2.6.1-broken-pipe.patch22
3 files changed, 81 insertions, 1 deletions
diff --git a/media-libs/faad2/ChangeLog b/media-libs/faad2/ChangeLog
index 455710876dc3..e7516bd01cf3 100644
--- a/media-libs/faad2/ChangeLog
+++ b/media-libs/faad2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/faad2
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/faad2/ChangeLog,v 1.95 2008/03/09 10:34:12 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/faad2/ChangeLog,v 1.96 2008/05/08 12:08:06 lavajoe Exp $
+
+*faad2-2.6.1-r1 (08 May 2008)
+
+ 08 May 2008; Joe Peterson <lavajoe@gentoo.org>
+ +files/faad2-2.6.1-broken-pipe.patch, +faad2-2.6.1-r1.ebuild:
+ Patched to detect writes to a broken pipe (bug #204227)
09 Mar 2008; Alexis Ballier <aballier@gentoo.org>
+files/faad2-2.6.1-libtool22.patch, faad2-2.6.1.ebuild:
diff --git a/media-libs/faad2/faad2-2.6.1-r1.ebuild b/media-libs/faad2/faad2-2.6.1-r1.ebuild
new file mode 100644
index 000000000000..e40f77f18152
--- /dev/null
+++ b/media-libs/faad2/faad2-2.6.1-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/faad2/faad2-2.6.1-r1.ebuild,v 1.1 2008/05/08 12:08:06 lavajoe Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="AAC audio decoding library"
+HOMEPAGE="http://www.audiocoding.com/"
+SRC_URI="mirror://sourceforge/faac/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="drm"
+
+RDEPEND=""
+DEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-abi_has_changed.patch"
+ epatch "${FILESDIR}/${P}-libtool22.patch"
+ epatch "${FILESDIR}/${P}-broken-pipe.patch"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_with drm)\
+ --without-xmms \
+ || die "econf failed"
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README README.linux TODO
+}
+
+pkg_postinst() {
+ elog "Please note that from ${PN}-2.0* to ${P}, ABI has changed"
+ elog "So if you are upgrading from those versions, you need to rebuild"
+ elog "all the packages linked against ${PN}."
+ elog "You can use revdep-rebuild from app-portage/gentoolkit if you are"
+ elog "using portage or reconcilio if you are using paludis, or ..."
+}
diff --git a/media-libs/faad2/files/faad2-2.6.1-broken-pipe.patch b/media-libs/faad2/files/faad2-2.6.1-broken-pipe.patch
new file mode 100644
index 000000000000..428d7dd8ad2e
--- /dev/null
+++ b/media-libs/faad2/files/faad2-2.6.1-broken-pipe.patch
@@ -0,0 +1,22 @@
+--- faad2/frontend/main.c~ 2007-11-01 06:33:29.000000000 -0600
++++ faad2/frontend/main.c 2008-01-03 18:05:10.000000000 -0700
+@@ -640,7 +640,8 @@
+
+ if ((frameInfo.error == 0) && (frameInfo.samples > 0) && (!adts_out))
+ {
+- write_audio_file(aufile, sample_buffer, frameInfo.samples, 0);
++ if (write_audio_file(aufile, sample_buffer, frameInfo.samples, 0) == 0)
++ break;
+ }
+
+ /* fill buffer */
+@@ -976,7 +977,8 @@
+
+ if ((frameInfo.error == 0) && (sample_count > 0) && (!adts_out))
+ {
+- write_audio_file(aufile, sample_buffer, sample_count, delay);
++ if (write_audio_file(aufile, sample_buffer, sample_count, delay) == 0)
++ break;
+ }
+
+ if (frameInfo.error > 0)