summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-03-23 10:21:27 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-03-23 10:21:27 +0000
commit7b5edb335d6bbf7852f4c86762df7fba905d9986 (patch)
tree4ecd95e0f091709d51e718c5ac5e6498271b1e3d /media-libs/clutter-gst
parentold. the last one with bad USE hal vs. udev handling. this breaks thunar, pcm... (diff)
downloadgentoo-2-7b5edb335d6bbf7852f4c86762df7fba905d9986.tar.gz
gentoo-2-7b5edb335d6bbf7852f4c86762df7fba905d9986.tar.bz2
gentoo-2-7b5edb335d6bbf7852f4c86762df7fba905d9986.zip
Fix introspection, gstreamer, clutter-related access violations
(Portage version: 2.1.9.44/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/clutter-gst')
-rw-r--r--media-libs/clutter-gst/ChangeLog6
-rw-r--r--media-libs/clutter-gst/clutter-gst-1.3.4-r1.ebuild37
-rw-r--r--media-libs/clutter-gst/clutter-gst-1.3.6.ebuild12
3 files changed, 15 insertions, 40 deletions
diff --git a/media-libs/clutter-gst/ChangeLog b/media-libs/clutter-gst/ChangeLog
index 3aeee04b4a83..9904ff202bc5 100644
--- a/media-libs/clutter-gst/ChangeLog
+++ b/media-libs/clutter-gst/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/clutter-gst
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter-gst/ChangeLog,v 1.6 2011/03/05 15:07:19 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter-gst/ChangeLog,v 1.7 2011/03/23 10:21:27 nirbheek Exp $
+
+ 23 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ -clutter-gst-1.3.4-r1.ebuild, clutter-gst-1.3.6.ebuild:
+ Fix introspection, gstreamer, clutter-related access violations
*clutter-gst-1.3.6 (05 Mar 2011)
diff --git a/media-libs/clutter-gst/clutter-gst-1.3.4-r1.ebuild b/media-libs/clutter-gst/clutter-gst-1.3.4-r1.ebuild
deleted file mode 100644
index 6ca61da0adbd..000000000000
--- a/media-libs/clutter-gst/clutter-gst-1.3.4-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter-gst/clutter-gst-1.3.4-r1.ebuild,v 1.2 2011/02/18 06:44:43 nirbheek Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2" # Just a build-time dependency
-CLUTTER_LA_PUNT="yes"
-
-# inherit clutter after gnome2 so that defaults aren't overriden
-inherit python gnome2 clutter
-
-DESCRIPTION="GStreamer Integration library for Clutter"
-
-SLOT="1.0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc examples +introspection"
-
-RDEPEND="
- >=dev-libs/glib-2.20
- >=media-libs/clutter-1.4.0:1.0[introspection?]
- media-libs/gstreamer:0.10[introspection?]
- media-libs/gst-plugins-base:0.10[introspection?]
- introspection? ( >=dev-libs/gobject-introspection-0.6.8 )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-util/gtk-doc-1.8 )"
-
-DOCS="AUTHORS NEWS README"
-EXAMPLES="examples/{*.c,*.png,README}"
-
-src_prepare() {
- # XXX: debug default is "minimum" in even releases; "yes" in odd releases
- G2CONF="${G2CONF}
- $(use_enable introspection)"
-
- gnome2_src_prepare
- python_convert_shebangs 2 "${S}"/scripts/pso2h.py
-}
diff --git a/media-libs/clutter-gst/clutter-gst-1.3.6.ebuild b/media-libs/clutter-gst/clutter-gst-1.3.6.ebuild
index b87943d4f586..d03397f35469 100644
--- a/media-libs/clutter-gst/clutter-gst-1.3.6.ebuild
+++ b/media-libs/clutter-gst/clutter-gst-1.3.6.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter-gst/clutter-gst-1.3.6.ebuild,v 1.1 2011/03/05 15:07:19 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter-gst/clutter-gst-1.3.6.ebuild,v 1.2 2011/03/23 10:21:27 nirbheek Exp $
EAPI="3"
PYTHON_DEPEND="2" # Just a build-time dependency
CLUTTER_LA_PUNT="yes"
# inherit clutter after gnome2 so that defaults aren't overriden
-inherit python gnome2 clutter
+inherit python gnome2 clutter virtualx
DESCRIPTION="GStreamer Integration library for Clutter"
@@ -35,3 +35,11 @@ src_prepare() {
gnome2_src_prepare
python_convert_shebangs 2 "${S}"/scripts/pso2h.py
}
+
+src_compile() {
+ # Avoid sandbox violation with USE="introspection", bug #356283
+ export GST_REGISTRY=${T}/registry.cache.xml
+ # Clutter tries to access dri without userpriv
+ addpredict /dev/dri/card0
+ emake || die "emake failed"
+}