summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-05-07 22:33:18 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-05-07 22:33:18 +0000
commit7992d66a26ef5cc8643428eeef660175351d5fa8 (patch)
tree066cc8e5c32b967a987fc00d8c933c9bf2dcbcb7 /media-libs/atlas-c++
parentRemove old. (diff)
downloadgentoo-2-7992d66a26ef5cc8643428eeef660175351d5fa8.tar.gz
gentoo-2-7992d66a26ef5cc8643428eeef660175351d5fa8.tar.bz2
gentoo-2-7992d66a26ef5cc8643428eeef660175351d5fa8.zip
Remove old.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'media-libs/atlas-c++')
-rw-r--r--media-libs/atlas-c++/ChangeLog8
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.6.0.ebuild40
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild45
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.6.1.ebuild48
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.6.2.ebuild42
5 files changed, 6 insertions, 177 deletions
diff --git a/media-libs/atlas-c++/ChangeLog b/media-libs/atlas-c++/ChangeLog
index 94ca0724193c..cbee65f640c7 100644
--- a/media-libs/atlas-c++/ChangeLog
+++ b/media-libs/atlas-c++/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/atlas-c++
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/ChangeLog,v 1.42 2014/08/10 21:07:33 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/ChangeLog,v 1.43 2015/05/07 22:33:18 mrueg Exp $
+
+ 07 May 2015; Manuel Rüger <mrueg@gentoo.org> -atlas-c++-0.6.0.ebuild,
+ -atlas-c++-0.6.1-r1.ebuild, -atlas-c++-0.6.1.ebuild, -atlas-c++-0.6.2.ebuild:
+ Remove old.
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> atlas-c++-0.6.0.ebuild,
atlas-c++-0.6.1-r1.ebuild, atlas-c++-0.6.1.ebuild, atlas-c++-0.6.2.ebuild,
diff --git a/media-libs/atlas-c++/atlas-c++-0.6.0.ebuild b/media-libs/atlas-c++/atlas-c++-0.6.0.ebuild
deleted file mode 100644
index a3d643a7c158..000000000000
--- a/media-libs/atlas-c++/atlas-c++-0.6.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.6.0.ebuild,v 1.9 2014/08/10 21:07:33 slyfox Exp $
-
-inherit eutils
-
-MY_PN="Atlas-C++"
-MY_P=${MY_PN}-${PV}
-DESCRIPTION="Atlas protocol, used in role playing games at worldforge"
-HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/atlas_cpp"
-SRC_URI="mirror://sourceforge/worldforge/${MY_P}.tar.bz2"
-
-SLOT="0"
-LICENSE="LGPL-2.1"
-KEYWORDS="~amd64 ~x86"
-IUSE="bzip2 doc zlib"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-S=${WORKDIR}/${MY_P}
-
-src_compile() {
- econf \
- $(use_enable zlib) \
- $(use_enable bzip2 bzlib) \
- || die "Error: econf failed!"
- emake || die "Error: emake failed!"
- if use doc; then
- emake docs || die "Error: emake failed!"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- use doc && dohtml -r doc/html/*
- use doc && doman doc/man/*
- dodoc AUTHORS ChangeLog HACKING NEWS README ROADMAP THANKS TODO
-}
diff --git a/media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild b/media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild
deleted file mode 100644
index 2179b215f960..000000000000
--- a/media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild,v 1.5 2014/08/10 21:07:33 slyfox Exp $
-EAPI=2
-
-inherit eutils autotools
-
-MY_PN="Atlas-C++"
-MY_P=${MY_PN}-${PV}
-DESCRIPTION="Atlas protocol, used in role playing games at worldforge"
-HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/atlas_cpp"
-SRC_URI="mirror://sourceforge/worldforge/${MY_P}.tar.bz2"
-
-SLOT="0"
-LICENSE="LGPL-2.1"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-strict-aliasing.patch \
- "${FILESDIR}"/${P}-gcc-4.3.patch \
- "${FILESDIR}"/${P}-gcc-4.4.patch \
- "${FILESDIR}"/${P}-as-needed.patch
- eautoreconf
-}
-
-src_compile() {
- emake || die "Error: emake failed!"
- if use doc; then
- emake docs || die "Error: emake failed!"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- use doc && dohtml -r doc/html/*
- use doc && doman doc/man/*
- dodoc AUTHORS ChangeLog HACKING NEWS README ROADMAP THANKS TODO
-}
diff --git a/media-libs/atlas-c++/atlas-c++-0.6.1.ebuild b/media-libs/atlas-c++/atlas-c++-0.6.1.ebuild
deleted file mode 100644
index cfe6605445d1..000000000000
--- a/media-libs/atlas-c++/atlas-c++-0.6.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.6.1.ebuild,v 1.8 2014/08/10 21:07:33 slyfox Exp $
-
-inherit eutils autotools
-
-MY_PN="Atlas-C++"
-MY_P=${MY_PN}-${PV}
-DESCRIPTION="Atlas protocol, used in role playing games at worldforge"
-HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/atlas_cpp"
-SRC_URI="mirror://sourceforge/worldforge/${MY_P}.tar.bz2"
-
-SLOT="0"
-LICENSE="LGPL-2.1"
-KEYWORDS="amd64 x86"
-IUSE="bzip2 doc zlib"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-strict-aliasing.patch \
- "${FILESDIR}"/${P}-gcc-4.3.patch
- eautoreconf
-}
-
-src_compile() {
- econf \
- $(use_enable zlib) \
- $(use_enable bzip2 bzlib) \
- || die "Error: econf failed!"
- emake || die "Error: emake failed!"
- if use doc; then
- emake docs || die "Error: emake failed!"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- use doc && dohtml -r doc/html/*
- use doc && doman doc/man/*
- dodoc AUTHORS ChangeLog HACKING NEWS README ROADMAP THANKS TODO
-}
diff --git a/media-libs/atlas-c++/atlas-c++-0.6.2.ebuild b/media-libs/atlas-c++/atlas-c++-0.6.2.ebuild
deleted file mode 100644
index d336b195be63..000000000000
--- a/media-libs/atlas-c++/atlas-c++-0.6.2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.6.2.ebuild,v 1.8 2014/08/10 21:07:33 slyfox Exp $
-EAPI=2
-
-inherit eutils autotools
-
-MY_PN="Atlas-C++"
-MY_P=${MY_PN}-${PV}
-DESCRIPTION="Atlas protocol, used in role playing games at worldforge"
-HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/atlas_cpp"
-SRC_URI="mirror://sourceforge/worldforge/${MY_P}.tar.bz2"
-
-SLOT="0"
-LICENSE="LGPL-2.1"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-Werror.patch
- eautoreconf
-}
-
-src_compile() {
- emake || die "Error: emake failed!"
- if use doc; then
- emake docs || die "Error: emake docs failed!"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- use doc && dohtml -r doc/html/*
- use doc && doman doc/man/man3/[^i]*
- dodoc AUTHORS ChangeLog HACKING NEWS README ROADMAP THANKS TODO
-}