summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-10-01 20:26:07 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-10-01 20:26:07 +0000
commitb180c7117b01f33f4282006667d8282744af7eae (patch)
treeed11f8eee00f766e67a830d4e080f18416ff8ce3 /media-libs/atlas-c++/atlas-c++-0.4.5.ebuild
parentnew bugfix release (diff)
downloadgentoo-2-b180c7117b01f33f4282006667d8282744af7eae.tar.gz
gentoo-2-b180c7117b01f33f4282006667d8282744af7eae.tar.bz2
gentoo-2-b180c7117b01f33f4282006667d8282744af7eae.zip
new version
Diffstat (limited to 'media-libs/atlas-c++/atlas-c++-0.4.5.ebuild')
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.4.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild b/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild
new file mode 100644
index 000000000000..38b97564e76c
--- /dev/null
+++ b/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild,v 1.1 2002/10/01 20:26:07 verwilst Exp $
+
+MY_PN="Atlas-C++"
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Atlas protocol standard implementation in C++. Atlas protocol is used in role playing games at worldforge."
+HOMEPAGE="http://www.worldforge.net"
+SRC_URI="ftp://victor.worldforge.org/pub/worldforge/libs/${MY_PN}/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc
+ =dev-libs/libsigc++-1.0*"
+
+src_compile() {
+
+ econf || die
+ emake || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README ROADMAP THANKS TODO
+}