summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-01-13 22:08:59 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-01-13 22:08:59 +0000
commita1af08b28e054a5b7ec37758befc7ab59a1a55c8 (patch)
tree3180778d3a2fa66627ef08432a26fe522376afc3 /media-libs/allegro
parentmarking sparc x86 stable (diff)
downloadgentoo-2-a1af08b28e054a5b7ec37758befc7ab59a1a55c8.tar.gz
gentoo-2-a1af08b28e054a5b7ec37758befc7ab59a1a55c8.tar.bz2
gentoo-2-a1af08b28e054a5b7ec37758befc7ab59a1a55c8.zip
Add modular depends
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'media-libs/allegro')
-rw-r--r--media-libs/allegro/ChangeLog7
-rw-r--r--media-libs/allegro/allegro-4.2.0.ebuild29
2 files changed, 30 insertions, 6 deletions
diff --git a/media-libs/allegro/ChangeLog b/media-libs/allegro/ChangeLog
index ad7268fbb348..8f2677ba20c4 100644
--- a/media-libs/allegro/ChangeLog
+++ b/media-libs/allegro/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/allegro
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/ChangeLog,v 1.46 2005/12/03 07:25:06 mr_bones_ Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/ChangeLog,v 1.47 2006/01/13 22:06:26 genstef Exp $
+
+ 13 Jan 2006; Stefan Schweizer <genstef@gentoo.org> allegro-4.2.0.ebuild:
+ Add modular depends
*allegro-4.2.0 (03 Dec 2005)
diff --git a/media-libs/allegro/allegro-4.2.0.ebuild b/media-libs/allegro/allegro-4.2.0.ebuild
index 572683b7af9d..3c4f7c22d5cb 100644
--- a/media-libs/allegro/allegro-4.2.0.ebuild
+++ b/media-libs/allegro/allegro-4.2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.2.0.ebuild,v 1.1 2005/12/03 07:25:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.2.0.ebuild,v 1.2 2006/01/13 22:06:26 genstef Exp $
inherit flag-o-matic eutils
@@ -16,11 +16,32 @@ IUSE="static mmx sse oss alsa esd arts X fbcon svga tetex doc"
RDEPEND="alsa? ( media-libs/alsa-lib )
esd? ( media-sound/esound )
arts? ( kde-base/arts )
- X? ( virtual/x11 )
+ alsa? ( media-libs/alsa-lib )
+ X? (
+ || (
+ ( x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm )
+ virtual/x11
+ )
+ )
svga? ( media-libs/svgalib )"
DEPEND="${RDEPEND}
- tetex? ( virtual/tetex )"
+ tetex? ( virtual/tetex )
+ X? (
+ || (
+ ( x11-libs/libXt
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xproto )
+ virtual/x11
+ )
+ )"
src_compile() {
filter-flags -fPIC -fprefetch-loop-arrays