summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-09-18 05:49:29 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-09-18 05:49:29 +0000
commitdae025738d63d063bbfbb528c418c7076c354d5d (patch)
tree81adaa8439cf0e344886f6104ac4104a5ad3ce77 /media-gfx
parentRespect LDFLAGS (bug #335985), CC. (diff)
downloadgentoo-2-dae025738d63d063bbfbb528c418c7076c354d5d.tar.gz
gentoo-2-dae025738d63d063bbfbb528c418c7076c354d5d.tar.bz2
gentoo-2-dae025738d63d063bbfbb528c418c7076c354d5d.zip
Respect LDFLAGS (bug #337614 by Diego).
(Portage version: 2.2_rc83/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/cfe/ChangeLog8
-rw-r--r--media-gfx/cfe/cfe-0.12.ebuild12
-rw-r--r--media-gfx/cfe/files/cfe-0.12-LDFLAGS.patch21
3 files changed, 34 insertions, 7 deletions
diff --git a/media-gfx/cfe/ChangeLog b/media-gfx/cfe/ChangeLog
index bda69472d421..31269c0c159a 100644
--- a/media-gfx/cfe/ChangeLog
+++ b/media-gfx/cfe/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/cfe
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/cfe/ChangeLog,v 1.5 2009/06/09 02:17:13 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/cfe/ChangeLog,v 1.6 2010/09/18 05:49:29 dirtyepic Exp $
+
+ 18 Sep 2010; Ryan Hill <dirtyepic@gentoo.org> cfe-0.12.ebuild,
+ +files/cfe-0.12-LDFLAGS.patch:
+ Respect LDFLAGS (bug #337614 by Diego).
09 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org> cfe-0.12.ebuild:
Remove autoconf 2.1 requirement, package builds fine with 2.63.
diff --git a/media-gfx/cfe/cfe-0.12.ebuild b/media-gfx/cfe/cfe-0.12.ebuild
index 50858f4837d5..9c689fe84810 100644
--- a/media-gfx/cfe/cfe-0.12.ebuild
+++ b/media-gfx/cfe/cfe-0.12.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/cfe/cfe-0.12.ebuild,v 1.4 2009/06/09 02:17:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/cfe/cfe-0.12.ebuild,v 1.5 2010/09/18 05:49:29 dirtyepic Exp $
+
+EAPI="3"
inherit eutils autotools
@@ -15,10 +17,10 @@ KEYWORDS="~ppc ~x86"
IUSE=""
DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-LDFLAGS.patch
# Remove unconditional assignment of CFLAGS
sed -i -e '/GCC = yes/d' configure.in
diff --git a/media-gfx/cfe/files/cfe-0.12-LDFLAGS.patch b/media-gfx/cfe/files/cfe-0.12-LDFLAGS.patch
new file mode 100644
index 000000000000..6a645be0f970
--- /dev/null
+++ b/media-gfx/cfe/files/cfe-0.12-LDFLAGS.patch
@@ -0,0 +1,21 @@
+diff --git a/Makefile.in b/Makefile.in
+index 726d224..e65c1b5 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -12,6 +12,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ INSTALL_DATA = @INSTALL_DATA@
+ CC = @CC@
+ CFLAGS = @CFLAGS@
++LDFLAGS = @LDFLAGS@
+
+ OBJS = cfe.o font.o help.o keyb.o scr.o undo.o
+
+@@ -20,7 +21,7 @@ OBJS = cfe.o font.o help.o keyb.o scr.o undo.o
+ all: cfe
+
+ cfe: $(OBJS)
+- $(CC) -o $@ $(OBJS) -l@CURSES_LIB@
++ $(CC) -o $@ $(OBJS) $(LDFLAGS) -l@CURSES_LIB@
+
+ install: cfe
+ $(INSTALL_PROGRAM) cfe $(bindir)