summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-29 10:03:01 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-29 10:03:01 +0000
commitcf30f7774e015e9227d89af9eec56794beec8ec2 (patch)
treedf0d873acacd450ce60394e0e0aabdcd95e64222 /media-gfx
parentInitial commit of this extension wrt bug#463536. (diff)
downloadgentoo-2-cf30f7774e015e9227d89af9eec56794beec8ec2.tar.gz
gentoo-2-cf30f7774e015e9227d89af9eec56794beec8ec2.tar.bz2
gentoo-2-cf30f7774e015e9227d89af9eec56794beec8ec2.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/gthumb/ChangeLog11
-rw-r--r--media-gfx/gthumb/files/gthumb-3.2.0-configure-option.patch44
-rw-r--r--media-gfx/gthumb/gthumb-3.2.0.ebuild92
-rw-r--r--media-gfx/gthumb/metadata.xml3
4 files changed, 148 insertions, 2 deletions
diff --git a/media-gfx/gthumb/ChangeLog b/media-gfx/gthumb/ChangeLog
index 3fa392d02796..210714ec28d0 100644
--- a/media-gfx/gthumb/ChangeLog
+++ b/media-gfx/gthumb/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/gthumb
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gthumb/ChangeLog,v 1.158 2012/12/05 22:18:46 tetromino Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gthumb/ChangeLog,v 1.159 2013/03/29 10:03:01 pacho Exp $
+
+*gthumb-3.2.0 (29 Mar 2013)
+
+ 29 Mar 2013; Pacho Ramos <pacho@gentoo.org>
+ +files/gthumb-3.2.0-configure-option.patch, +gthumb-3.2.0.ebuild,
+ metadata.xml:
+ Version bump for Gnome 3.8
05 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
-files/gthumb-no-brasero3.patch, gthumb-2.14.4.ebuild, -gthumb-3.0.0.ebuild,
diff --git a/media-gfx/gthumb/files/gthumb-3.2.0-configure-option.patch b/media-gfx/gthumb/files/gthumb-3.2.0-configure-option.patch
new file mode 100644
index 000000000000..07dc1b681f7f
--- /dev/null
+++ b/media-gfx/gthumb/files/gthumb-3.2.0-configure-option.patch
@@ -0,0 +1,44 @@
+From 3a1128457bd229abf51d48a660abc4b4458b518b Mon Sep 17 00:00:00 2001
+From: Paolo Bacchilega <paobac@src.gnome.org>
+Date: Thu, 28 Mar 2013 17:55:21 +0000
+Subject: configure: fixed unrecognized option --disable-libjson-glib
+
+[bug #696783]
+---
+diff --git a/configure.ac b/configure.ac
+index b3e6845..d496b3b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -518,16 +518,16 @@ AC_SUBST(LIBSOUP_LIBS)
+
+ dnl ===========================================================================
+
+-AC_ARG_ENABLE([json_glib],
++AC_ARG_ENABLE([libjson_glib],
+ [AS_HELP_STRING([--disable-libjson-glib],[do not compile code that uses the libjson-glib library])],,
+- [enable_json_glib=yes])
++ [enable_libjson_glib=yes])
+
+-if test x$enable_json_glib = xyes ; then
++if test x$enable_libjson_glib = xyes ; then
+ PKG_CHECK_MODULES(JSON_GLIB,
+ [json-glib-1.0 >= $JSON_GLIB_REQUIRED],
+ [AC_DEFINE(HAVE_JSON_GLIB, 1, [Have libjson-glib])
+- enable_json_glib=yes],
+- [enable_json_glib=no])
++ enable_libjson_glib=yes],
++ [enable_libjson_glib=no])
+ fi
+ AC_SUBST(JSON_GLIB_CFLAGS)
+ AC_SUBST(JSON_GLIB_LIBS)
+@@ -548,7 +548,7 @@ fi
+ AC_SUBST(WEBKIT2_CFLAGS)
+ AC_SUBST(WEBKIT2_LIBS)
+
+-if [ test "x$enable_libsoup" = xyes && test "x$enable_json_glib" = xyes && test "x$enable_webkit2" = xyes ] ; then
++if [ test "x$enable_libsoup" = xyes && test "x$enable_libjson_glib" = xyes && test "x$enable_webkit2" = xyes ] ; then
+ enable_web_services=yes
+ else
+ enable_web_services=no
+--
+cgit v0.9.1
diff --git a/media-gfx/gthumb/gthumb-3.2.0.ebuild b/media-gfx/gthumb/gthumb-3.2.0.ebuild
new file mode 100644
index 000000000000..257a80f6b66f
--- /dev/null
+++ b/media-gfx/gthumb/gthumb-3.2.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gthumb/gthumb-3.2.0.ebuild,v 1.1 2013/03/29 10:03:01 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Image viewer and browser for Gnome"
+HOMEPAGE="https://live.gnome.org/gthumb"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="cdr exif gstreamer http jpeg json libsecret raw slideshow svg tiff test webkit webp"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.34.0:2
+ >=x11-libs/gtk+-3.4.0:3
+
+ media-libs/libpng:0=
+ sys-libs/zlib
+ x11-libs/libICE
+ x11-libs/libSM
+
+ cdr? ( >=app-cdr/brasero-3.2 )
+ exif? ( >=media-gfx/exiv2-0.21:= )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0 )
+ http? (
+ >=net-libs/libsoup-2.36:2.4
+ >=net-libs/libsoup-gnome-2.36:2.4 )
+ jpeg? ( virtual/jpeg:0= )
+ json? ( >=dev-libs/json-glib-0.15.0 )
+ libsecret? ( >=app-crypt/libsecret-0.11 )
+ slideshow? (
+ >=media-libs/clutter-1:1.0
+ >=media-libs/clutter-gtk-1:1.0 )
+ svg? ( >=gnome-base/librsvg-2.34 )
+ tiff? ( media-libs/tiff:= )
+ raw? ( >=media-libs/libopenraw-0.0.8:= )
+ !raw? ( media-gfx/dcraw )
+ webkit? ( >=net-libs/webkit-gtk-1.10.0:3 )
+ webp? ( >=media-libs/libwebp-0.2.0 )"
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/gsettings-desktop-schemas-0.1.4"
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ app-text/scrollkeeper
+ >=dev-util/intltool-0.35
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+ test? ( ~app-text/docbook-xml-dtd-4.1.2 )"
+# eautoreconf needs:
+# gnome-base/gnome-common
+
+src_prepare() {
+ # Upstream says in configure help that libchamplain support
+ # crashes frequently
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-libchamplain
+ --with-smclient=xsmp
+ $(use_enable cdr libbrasero)
+ $(use_enable exif exiv2)
+ $(use_enable gstreamer)
+ $(use_enable http libsoup)
+ $(use_enable jpeg)
+ $(use_enable json libjson-glib)
+ $(use_enable libsecret)
+ $(use_enable raw libopenraw)
+ $(use_enable slideshow clutter)
+ $(use_enable svg librsvg)
+ $(use_enable test test-suite)
+ $(use_enable tiff)
+ $(use_enable webkit webkit2)
+ $(use_enable webp libwebp)"
+
+ # Remove unwanted CFLAGS added with USE=debug
+ sed -e 's/CFLAGS="$CFLAGS -g -O0 -DDEBUG"//' \
+ -i configure.ac -i configure || die
+
+ # Fixed unrecognized option --disable-libjson-glib, upstream bug #696783
+ epatch "${FILESDIR}/${P}-configure-option.patch"
+
+ eautoreconf
+ gnome2_src_prepare
+}
diff --git a/media-gfx/gthumb/metadata.xml b/media-gfx/gthumb/metadata.xml
index 32759ce0125f..415357c02fb3 100644
--- a/media-gfx/gthumb/metadata.xml
+++ b/media-gfx/gthumb/metadata.xml
@@ -4,6 +4,9 @@
<herd>gnome</herd>
<use>
<flag name="http">Enable webservice integration through <pkg>net-libs/libsoup</pkg></flag>
+ <flag name="json">Compile code that uses the libjson-glib library</flag>
+ <flag name="libsecret">Enable libsecret support to store login credentials</flag>
<flag name="slideshow">Enable slideshow plugin</flag>
+ <flag name="webp">Enable support for webp image format</flag>
</use>
</pkgmetadata>