summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2005-03-22 18:00:43 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2005-03-22 18:00:43 +0000
commitb3feb4dd4ab1c12136c8272f23661f6d6c06c1cb (patch)
tree95bfc66b947b8cf194971f5e81c36af4d686e7b2 /media-gfx
parentAdded plugins and inkjar USE flag to media-gfx/inkscape-0.41 (diff)
downloadgentoo-2-b3feb4dd4ab1c12136c8272f23661f6d6c06c1cb.tar.gz
gentoo-2-b3feb4dd4ab1c12136c8272f23661f6d6c06c1cb.tar.bz2
gentoo-2-b3feb4dd4ab1c12136c8272f23661f6d6c06c1cb.zip
Version bump, bug #81529
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/inkscape/ChangeLog8
-rw-r--r--media-gfx/inkscape/files/digest-inkscape-0.411
-rw-r--r--media-gfx/inkscape/files/inkscape-0.41_gnome-print.patch16
-rw-r--r--media-gfx/inkscape/inkscape-0.41.ebuild74
4 files changed, 98 insertions, 1 deletions
diff --git a/media-gfx/inkscape/ChangeLog b/media-gfx/inkscape/ChangeLog
index e04b1f4a227b..a39d64e544b5 100644
--- a/media-gfx/inkscape/ChangeLog
+++ b/media-gfx/inkscape/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/inkscape
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/inkscape/ChangeLog,v 1.14 2005/02/28 18:05:17 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/inkscape/ChangeLog,v 1.15 2005/03/22 18:00:42 sekretarz Exp $
+
+*inkscape-0.41 (22 Mar 2005)
+
+ 22 Mar 2005; Karol Wojtaszek <sekretarz@gentoo.org>
+ +files/inkscape-0.41_gnome-print.patch, +inkscape-0.41.ebuild:
+ Version bump, bug #81529
28 Feb 2005; Markus Rothe <corsair@gentoo.org> inkscape-0.40-r1.ebuild:
Added ~ppc64 to KEYWORDS
diff --git a/media-gfx/inkscape/files/digest-inkscape-0.41 b/media-gfx/inkscape/files/digest-inkscape-0.41
new file mode 100644
index 000000000000..558fa6e89f0c
--- /dev/null
+++ b/media-gfx/inkscape/files/digest-inkscape-0.41
@@ -0,0 +1 @@
+MD5 9b4bbfaae688127dca4c3d816a42b21a inkscape-0.41.tar.bz2 4430290
diff --git a/media-gfx/inkscape/files/inkscape-0.41_gnome-print.patch b/media-gfx/inkscape/files/inkscape-0.41_gnome-print.patch
new file mode 100644
index 000000000000..10fa49aea555
--- /dev/null
+++ b/media-gfx/inkscape/files/inkscape-0.41_gnome-print.patch
@@ -0,0 +1,16 @@
+--- src/extension/internal/gnome.cpp
++++ src/extension/internal/gnome.cpp
+@@ -183,6 +183,13 @@
+ return 0;
+ }
+
++unsigned int PrintGNOME::comment (Inkscape::Extension::Print * module,
++ const char * comment)
++{
++ // ignore comment
++ return 0;
++}
++
+ unsigned int
+ PrintGNOME::fill(Inkscape::Extension::Print *mod,
+ NRBPath const *bpath, NRMatrix const *ctm, SPStyle const *style,
diff --git a/media-gfx/inkscape/inkscape-0.41.ebuild b/media-gfx/inkscape/inkscape-0.41.ebuild
new file mode 100644
index 000000000000..2059271577c0
--- /dev/null
+++ b/media-gfx/inkscape/inkscape-0.41.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/inkscape/inkscape-0.41.ebuild,v 1.1 2005/03/22 18:00:42 sekretarz Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="A SVG based generic vector-drawing program"
+HOMEPAGE="http://www.inkscape.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="gnome mmx perl python bonobo inkjar doc plugin"
+
+RDEPEND=">=x11-libs/gtk+-2.4.1
+ >=media-libs/libart_lgpl-2.3.16
+ >=dev-libs/libxml2-2.6.7
+ >=x11-libs/pango-1.4.0
+ dev-perl/XML-Parser
+ virtual/xft
+ dev-libs/popt
+ media-libs/fontconfig
+ sys-libs/zlib
+ media-libs/libpng
+ =sys-devel/gcc-3*
+ >=dev-libs/libsigc++-2.0.3
+ >=dev-cpp/gtkmm-2.4
+ dev-cpp/glibmm
+ gnome? ( >=gnome-base/libgnomeprint-2.2
+ >=gnome-base/libgnomeprintui-2.2 )
+ >=dev-libs/boehm-gc-6.4
+ perl? ( dev-lang/perl )
+ python? ( dev-lang/python )
+ plugin? ( >=media-gfx/pstoedit-3.33
+ >=media-gfx/skencil-0.6.16
+ media-libs/libwmf
+ app-office/dia )"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.29"
+
+G2CONF="${G2CONF} --with-xft"
+use mmx || G2CONF="${G2CONF} --disable-mmx"
+use bonobo || G2CONF="${G2CONF} --without-bonobo"
+use inkjar || G2CONF="${G2CONF} --without-inkjar"
+use gnome && G2CONF="${G2CONF} --with-gnome-print"
+use perl && G2CONF="${G2CONF} --with-perl"
+use python && G2CONF="${G2CONF} --with-python"
+
+src_unpack() {
+ unpack ${A}
+
+ # fix for gnome-print error
+ cd ${S}
+ epatch ${FILESDIR}/${P}_gnome-print.patch
+}
+
+DOCS="AUTHORS COPYING ChangeLog HACKING NEWS README"
+
+pkg_postinst() {
+ einfo "Inkscape 0.41 adds several new optional extensions."
+ einfo "It is normal to get a warning the first time Inkscape is run,"
+ einfo ""
+ einfo "If you want all extensions supported, recompile Inkscape"
+ einfo "with the \'plugin\' USE flag. It will install:"
+ einfo ""
+ einfo " >=media-gfx/pstoedit-3.33"
+ einfo " >=media-gfx/skencil-0.6.16"
+ einfo " media-libs/libwmf"
+ einfo " app-office/dia"
+}